Skip to content

Commit

Permalink
dev-lang/hy: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
patricklauer committed Feb 3, 2017
1 parent d2cb15b commit 9b73475
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/hy/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST hy-0.10.0.tar.gz 340981 SHA256 524c9f2a2e0e789fe8896e9c7bea16c9f42e99d5b662
DIST hy-0.10.1.tar.gz 348807 SHA256 16247c2f776147a46cd6c3beed329836c8a7a98e7ccb4b1cc660fced9688e02c SHA512 d96a5857fc6985fe044a152b276572f7943d3c579cf54daa675ec5d3e5d44836c151eb58f8e5cea8811f3bcb32b724fb24f8d61dc9ba917972673630e9cff7dc WHIRLPOOL 72e73cf008379de0e7f734f9a2687c70143fbb11bbb377c131e22eabaad355a88ea034e2b659c9bd1fa168eabfd0b8a802d779ced84b99ea5adb0718339f54a1
DIST hy-0.11.1.tar.gz 358882 SHA256 8d53dd3d37dd15040b4e6fa514d480f88c935855c37ca9f4a4c0d0ed989aceaa SHA512 c3bb39e41bba306a529051aa214350dd51118bce956670b9688ecbd08d8e85c23efd4eae06977bab7f3a50f8cca1626d7a6442de6b59972fe1d91bdb791aa836 WHIRLPOOL 0dcebdd8e87470784603a92ae52bbccb6b84ad138fed5ec7bcb947ebc9d2042a43181805694cdad324f7691fae15758dc91bbc6d50f91b3541d95c9ec904ac80
DIST hy-0.12.0.tar.gz 379282 SHA256 b747477292319e72d09b2b9e84191d1bb46910b4a74a49745aac32b1334bafa4 SHA512 fcad30640aad329c8a8c66167e01f96eddad95fd0d23ce8bf641ed96865c0a7610e8792bc94343edaa36a9a643e72ff946e491e55ca429f6a14a55bd05631470 WHIRLPOOL 4eea576675348bfece5ccdb89359c37d054b57b0824d55111a17aa179f791bddfe67d1d44e096224829d8db8afec8bf4af052701f5623faf8b4339f3035539f7
DIST hy-0.12.1.tar.gz 379361 SHA256 a1cb381ff3241fa1d70aff38b8f0eca0e9153a370710d3e2e0fd973ce855fe2e SHA512 8b1c957b37aa46baf7ac2a20d7ea4321824ee13e08146edcfdd7eb727151aa34036f9d696687df06e6fa48550bd91d6ad3484bab47da8ea3b154363c48e66980 WHIRLPOOL 872363a61cc84ee9b677fee699982564cc5f2bf11c5e94d6aa1a66b0d3148a50460d65845e80b28afd1bf9460c44d55adcc3a4619a42770590440337b63d4c20
43 changes: 43 additions & 0 deletions dev-lang/hy/hy-0.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

RESTRICT="test" # needs some pointy sticks. Seriously.
PYTHON_COMPAT=(python{2_7,3_4,3_5})

inherit distutils-r1 eutils
DESCRIPTION="A LISP dialect running in python"
HOMEPAGE="http://hylang.org/"
SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"

KEYWORDS="~amd64 ~x86"
IUSE="test doc examples"

RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
>=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
>=dev-python/astor-0.5[${PYTHON_USEDEP}]
dev-python/clint[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/tox[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)"
src_prepare() {
use examples && EXAMPLES=( eg/. )
use doc && HTML_DOCS=( docs/_build/html/. )
}

python_compile_all() {
use doc && emake docs
}

python_test() {
nosetests || die "Tests failed under ${EPYTHON}"
}

0 comments on commit 9b73475

Please sign in to comment.