Skip to content

Commit

Permalink
sys-cluster/rdma-core: initial commit
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
Zlogene committed Sep 8, 2019
1 parent 575479c commit 9b83bcf
Show file tree
Hide file tree
Showing 7 changed files with 234 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/rdma-core/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST rdma-core-24.0.tar.gz 1219485 BLAKE2B 400076305ca634a14d8f46df3477f9e3e753b95840237a217cfffe1a78e93ee90994e628f2a0693bde588ce15965df0014acb55bc92c36e3c45011cc69e9898a SHA512 0ef2b2b4250a1738adec964911a286f60e2310472c943dac1be45c70974a8bd1f32ee96013bff9e492132403af810aee1350d404a87ae7671731f7a5bd80c655
7 changes: 7 additions & 0 deletions sys-cluster/rdma-core/files/ibacm.init
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
#!/sbin/openrc-run
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

command="/usr/sbin/ibacm"
pidfile="/run/${SVCNAME}.pid"
start_stop_daemon_args="-b -m"
7 changes: 7 additions & 0 deletions sys-cluster/rdma-core/files/iwpmd.init
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
#!/sbin/openrc-run
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

command="/usr/sbin/iwpmd"
pidfile="/run/${SVCNAME}.pid"
start_stop_daemon_args="-b -m"
20 changes: 20 additions & 0 deletions sys-cluster/rdma-core/files/srpd.init
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
#!/sbin/openrc-run
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

command="/usr/sbin/srp_daemon.sh"
pidfile="/run/${SVCNAME}.pid"
start_stop_daemon_args="-b -m"

rdma_config="/etc/infiniband/openib.conf"
[ -f ${rdma_config} ] && source ${rdma_config}"
[ ${SRP_DEFAULT_TL_RETRY_COUNT} ] && command_args="-l ${SRP_DEFAULT_TL_RETRY_COUNT}"
start_pre() {
if ! [ -e /sys/module/ib_srp ]; then
eerror "SRP kernel module is not loaded, unable to start SRP daemon"
return 1
fi
return 0
}
16 changes: 16 additions & 0 deletions sys-cluster/rdma-core/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Mikle Kolyada</name>
</maintainer>
<use>
<flag name="neigh">Enable iwpmd support</flag>
<flag name="python">Enable pyverbs support</flag>
<flag name="valgrind">Enable valgrind notations</flag>
</use>
<upstream>
<remote-id type="github">linux-rdma/rdma-core</remote-id>
</upstream>
</pkgmetadata>
92 changes: 92 additions & 0 deletions sys-cluster/rdma-core/rdma-core-24.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,92 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{5,6,7} )

inherit cmake-utils python-single-r1 udev systemd

DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
else
SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
SLOT="0"
IUSE="neigh python static-libs systemd valgrind"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

COMMON_DEPEND="
virtual/libudev:=
neigh? ( dev-libs/libnl:3 )
systemd? ( sys-apps/systemd:= )
valgrind? ( dev-util/valgrind )
python? ( ${PYTHON_DEPS} )"

DEPEND="${COMMON_DEPEND}
python? ( dev-python/cython[${PYTHON_USEDEP}] )"

RDEPEND="${COMMON_DEPEND}
!sys-fabric/infiniband-diags
!sys-fabric/libibverbs
!sys-fabric/librdmacm
!sys-fabric/libibumad
!sys-fabric/ibacm
!sys-fabric/libibmad
!sys-fabric/srptools
!sys-fabric/infinipath-psm
!sys-fabric/libcxgb3
!sys-fabric/libcxgb4
!sys-fabric/libmthca
!sys-fabric/libmlx4
!sys-fabric/libmlx5
!sys-fabric/libocrdma
!sys-fabric/libnes"

BDEPEND="virtual/pkgconfig"

pkg_setup() {
python-single-r1_pkg_setup

}

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
-DCMAKE_INSTALL_FULL_RUNDIR=/run
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
-DCMAKE_DISABLE_FIND_PACKAGE_pandoc=yes
$(ver_test -ge 25 && echo -DCMAKE_DISABLE_FIND_PACKAGE_rst2man=yes)
-DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex systemd no yes)"
-DENABLE_VALGRIND="$(usex valgrind)"
-DENABLE_RESOLVE_NEIGH="$(usex neigh)"
-DENABLE_STATIC="$(usex static-libs)"
)

if use python; then
mycmakeargs+=( -DNO_PYVERBS=OFF )
else
mycmakeargs+=( -DNO_PYVERBS=ON )
fi

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die

newinitd "${FILESDIR}"/ibacm.init ibacm
newinitd "${FILESDIR}"/iwpmd.init iwpmd
newinitd "${FILESDIR}"/srpd.init srpd
}
91 changes: 91 additions & 0 deletions sys-cluster/rdma-core/rdma-core-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{5,6,7} )

inherit cmake-utils python-single-r1 udev systemd

DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
else
SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
SLOT="0"
IUSE="neigh python static-libs systemd valgrind"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

COMMON_DEPEND="
virtual/libudev:=
neigh? ( dev-libs/libnl:3 )
systemd? ( sys-apps/systemd:= )
valgrind? ( dev-util/valgrind )
python? ( ${PYTHON_DEPS} )"

DEPEND="${COMMON_DEPEND}
python? ( dev-python/cython[${PYTHON_USEDEP}] )"

RDEPEND="${COMMON_DEPEND}
!sys-fabric/libibverbs
!sys-fabric/librdmacm
!sys-fabric/libibumad
!sys-fabric/ibacm
!sys-fabric/libibmad
!sys-fabric/srptools
!sys-fabric/infinipath-psm
!sys-fabric/libcxgb3
!sys-fabric/libcxgb4
!sys-fabric/libmthca
!sys-fabric/libmlx4
!sys-fabric/libmlx5
!sys-fabric/libocrdma
!sys-fabric/libnes"

BDEPEND="virtual/pkgconfig"

pkg_setup() {
python-single-r1_pkg_setup

}

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
-DCMAKE_INSTALL_FULL_RUNDIR=/run
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
-DCMAKE_DISABLE_FIND_PACKAGE_pandoc=yes
$(ver_test -ge 25 && echo -DCMAKE_DISABLE_FIND_PACKAGE_rst2man=yes)
-DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex systemd no yes)"
-DENABLE_VALGRIND="$(usex valgrind)"
-DENABLE_RESOLVE_NEIGH="$(usex neigh)"
-DENABLE_STATIC="$(usex static-libs)"
)

if use python; then
mycmakeargs+=( -DNO_PYVERBS=OFF )
else
mycmakeargs+=( -DNO_PYVERBS=ON )
fi

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die

newinitd "${FILESDIR}"/ibacm.init ibacm
newinitd "${FILESDIR}"/iwpmd.init iwpmd
newinitd "${FILESDIR}"/srpd.init srpd
}

0 comments on commit 9b83bcf

Please sign in to comment.