Skip to content

Commit

Permalink
kde-apps/kdenlive: Fix build with GCC-7
Browse files Browse the repository at this point in the history
Upstream commit 2ed43d34a124609aef092164e2e58e5476228209

Gentoo-bug: 618070

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
a17r committed Jun 24, 2017
1 parent 296e68a commit 9bae7ef
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
35 changes: 35 additions & 0 deletions kde-apps/kdenlive/files/kdenlive-17.04.2-gcc7.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 2ed43d34a124609aef092164e2e58e5476228209 Mon Sep 17 00:00:00 2001
From: Jean-Baptiste Mardelle <[email protected]>
Date: Mon, 19 Jun 2017 13:21:16 +0200
Subject: Fix compilation

---
src/scopes/audioscopes/spectrogram.cpp | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/scopes/audioscopes/spectrogram.cpp b/src/scopes/audioscopes/spectrogram.cpp
index 1d3a0a2..244e137 100644
--- a/src/scopes/audioscopes/spectrogram.cpp
+++ b/src/scopes/audioscopes/spectrogram.cpp
@@ -241,8 +241,8 @@ QImage Spectrogram::renderHUD(uint)
x = leftDist + (m_innerScopeRect.width() - 1) * ((float)hz) / m_freqMax;

// Hide text if it would overlap with the text drawn at the mouse position
- hideText = m_aTrackMouse->isChecked() && m_mouseWithinWidget && abs(x - (leftDist + mouseX + 20)) < (int) minDistX + 16
- && mouseX < m_innerScopeRect.width() && mouseX >= 0;
+ hideText = m_aTrackMouse->isChecked() && m_mouseWithinWidget && abs(x - (int)(leftDist + mouseX + 20)) < (int) minDistX + 16
+ && mouseX < m_innerScopeRect.width() && mouseX >= 0;

if (x <= rightBorder) {
davinci.drawLine(x, topDist, x, topDist + m_innerScopeRect.height() + 6);
@@ -268,7 +268,7 @@ QImage Spectrogram::renderHUD(uint)
}
// Draw the line at the very right (maximum frequency)
x = leftDist + m_innerScopeRect.width() - 1;
- hideText = m_aTrackMouse->isChecked() && m_mouseWithinWidget && abs(x - (leftDist + mouseX + 30)) < (int) minDistX
+ hideText = m_aTrackMouse->isChecked() && m_mouseWithinWidget && qAbs(x - (int)(leftDist + mouseX + 30)) < (int) minDistX
&& mouseX < m_innerScopeRect.width() && mouseX >= 0;
davinci.drawLine(x, topDist, x, topDist + m_innerScopeRect.height() + 6);
if (!hideText) {
--
cgit v0.11.2
2 changes: 2 additions & 0 deletions kde-apps/kdenlive/kdenlive-17.04.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -56,6 +56,8 @@ DEPEND="${RDEPEND}
sys-devel/gettext
"

PATCHES=( "${FILESDIR}/${P}-gcc7.patch" )

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package freesound Qt5WebKitWidgets)
Expand Down

0 comments on commit 9bae7ef

Please sign in to comment.