Skip to content

Commit

Permalink
net-misc/youtube-dl: Bump to 2021.04.26
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 25, 2021
1 parent 4b9957c commit 9cf64b3
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/youtube-dl/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST youtube-dl-2021.04.07.tar.gz 3324661 BLAKE2B c560b6b07bc3ba0c9b7233a634bfae617f604ed5e019e22aefc90e9221a8cd358b937f727b706bba6e9bb6f0a18a8ebd28d5c1f0be383d9dca2c692266cdf222 SHA512 aabf6a1ceefe9101c710bbb45b91e6253a1256343513d841f7901d2be32521a001dac15f5bf13ac94beaf4638dce691f2a157a6172d89047ce2248d06bcafbf8
DIST youtube-dl-2021.04.17.tar.gz 3331721 BLAKE2B 6b7be0fcb85222d287848cfa40da1dee3f689c59388bbc5d32c335b54cbd0e5ec54c86caf358418641c429d37ae28575858486d4db798d72225a4f5c6e064ac8 SHA512 cb8c76063fc3bd66d07995a669fcf29e5b766c4deb05c9d82fc9795ac3a090a4ae2ee152f150208eae22b93157c286c615044f8f5b0a47798266ab219b49632e
DIST youtube-dl-2021.04.26.tar.gz 3333530 BLAKE2B cffa09f91a1bbfc5962177133711ec1fce4760ef4a073c01daede2cdc168a10cfd868ca536903127f5a3214aece1c111d1dae23739aac86e765d7ff21903c884 SHA512 d187b537fc71ca8e0c9422404f14bab20f66ee9ea10af40d94e9216a79d6b78c1c535600308d18905c34ede0934dbf4f642f58125e898130ce536bc053aa2a10
71 changes: 71 additions & 0 deletions net-misc/youtube-dl/youtube-dl-2021.04.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=(python3_{7..9})

DISTUTILS_USE_SETUPTOOLS=rdepend

inherit bash-completion-r1 distutils-r1 readme.gentoo-r1

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
S=${WORKDIR}/${PN}

LICENSE="public-domain"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
SLOT="0"

RDEPEND="
dev-python/pycryptodome[${PYTHON_USEDEP}]
"

distutils_enable_tests nose

src_prepare() {
sed -i -e '/flake8/d' Makefile || die
distutils-r1_src_prepare
}

python_test() {
emake offlinetest
}

python_install_all() {
doman youtube-dl.1

newbashcomp youtube-dl.bash-completion youtube-dl

insinto /usr/share/zsh/site-functions
newins youtube-dl.zsh _youtube-dl

insinto /usr/share/fish/vendor_completions.d
doins youtube-dl.fish

distutils-r1_python_install_all

rm -r "${ED}"/usr/etc || die
rm -r "${ED}"/usr/share/doc/youtube_dl || die
}

pkg_postinst() {
elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
elog
elog "youtube-dl works fine on its own on most sites. However, if you want"
elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
elog "On some sites - most notably YouTube - videos can be retrieved in"
elog "a higher quality format without sound. youtube-dl will detect whether"
elog "ffmpeg is present and automatically pick the best option."
elog
elog "Videos or video formats streamed via RTMP protocol can only be"
elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
elog
elog "Downloading MMS and RTSP videos requires either mplayer"
elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
elog
elog "If you want youtube-dl to embed thumbnails from the metadata into the"
elog "resulting MP4 files, consider installing media-video/atomicparsley"
}

0 comments on commit 9cf64b3

Please sign in to comment.