Skip to content

Commit

Permalink
games-action/clanbomber: Fix building with GCC-6 (bug #613332)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Closes: gentoo#4311
  • Loading branch information
Peter-Levine authored and SoapGentoo committed Apr 16, 2017
1 parent d760f1e commit 9d3eced
Show file tree
Hide file tree
Showing 2 changed files with 20 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-action/clanbomber/clanbomber-2.1.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -29,6 +29,7 @@ DOCS=( AUTHORS ChangeLog ChangeLog.hg IDEAS NEWS QUOTES README TODO )
PATCHES=(
"${FILESDIR}"/${P}-automake112.patch
"${FILESDIR}"/${P}-boost150.patch
"${FILESDIR}"/${P}-gcc6.patch
)

src_prepare() {
Expand Down
19 changes: 19 additions & 0 deletions games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
--- a/src/Credits.h
+++ b/src/Credits.h
@@ -47,7 +47,7 @@
int speed;
bool stopped;
private:
- static const float yoffset_start = 50;
+ static const float yoffset_start;
static const int normal_speed = 40;
static const int text_height = 40;

--- a/src/Credits.cpp
+++ b/src/Credits.cpp
@@ -273,3 +273,5 @@
(*draw_list_iter)->show();
}
}
+
+const float Credits::yoffset_start = 50;

0 comments on commit 9d3eced

Please sign in to comment.