Skip to content

Commit

Permalink
games-sports/xmoto: upgrade 0.5.11-r2 -> 0.6.0
Browse files Browse the repository at this point in the history
- Rewrite the ebuild as the package has switched to cmake.
- Drop USE=editor which installed a utility called inksmoto, that should
  have been a separate package in the first place. Also there haven't
  been any updates for 10 years, I'm not sure if it's still alive.

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Stefan Strogin <[email protected]>
  • Loading branch information
steils committed Jun 15, 2020
1 parent a4eeac5 commit 9d94de1
Show file tree
Hide file tree
Showing 4 changed files with 63 additions and 100 deletions.
4 changes: 1 addition & 3 deletions games-sports/xmoto/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1 @@
DIST inksmoto-0.7.0.tar.gz 2628941 BLAKE2B b8469739e6368f7b36b9a5b766522c295de43c001fba00975fb3c761ba6df34bf97e684ddf51aa83a6a41a1b800d64d6d6fe77358cf1244f193d3aad4746c6b5 SHA512 af0ae49ea160a2274f6835abd82ccaa00dc9ff81875b7d4ea29789388c131b519cb77e6da42efeaf51d52b97090c67320af38145204a1d5418781c99cb23a704
DIST xmoto-0.5.11-src.tar.gz 40785573 BLAKE2B a1c19656ec5b206417ebdf5ac80e134ce7f29258d8a76f47bad4084ce4d2cdaeeecde1cf6cef1254a0832f21c50a49049947c1896681fe2dd8f3531ba22e7627 SHA512 7046745e8f7a045fa2ce1deb3fd75b73b233dc1092f5ecd6dd4e42938f70269a93a3a623a39a1f0520c90643a42dc1ce93c43ad07bf225ff6c50741cc02511f6
DIST xmoto_0.5.11+dfsg-7.debian.tar.xz 25708 BLAKE2B e4029d9c66b176c6eebbf68c973cb726ef7b2522c6245ce626c7a61c13492f2e599c5a7deff4f2c853bc58d21afb4e53072a0ddc25a4e7bdb8b89b93fd44159a SHA512 d430fa37fdde90ac68e8ff4b7d2707ea5fc73fa8fab241f7a97b27e803a88321f0ea01b094a5f77ac7e43b2202113842b4f69a745e9212eead7ce4a0a5cd220c
DIST xmoto-0.6.0.tar.gz 41635478 BLAKE2B 26db7b5664ea5f999f8fe481f58aede57319a75f7d7c6e9eb74c6b8d058137b44e3d00621995d8ff05dfe8d18b25d9688d80a1f12b54cdaf19920684a23c5fa3 SHA512 dad5183dec547db60f65a6461b59373890d11a4d984b1bbabc560a1ee3b5fbcb0fc53a5f2f52a5bdc29144d65ffa194f395b4f47f593b81a87de807ff79ba9cc
1 change: 0 additions & 1 deletion games-sports/xmoto/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -7,6 +7,5 @@
</maintainer>
<use>
<flag name="double-precision">more precise calculations at the expense of speed</flag>
<flag name="editor">Depend on inkscape, scripts to convert svg to level (svg2lvl)</flag>
</use>
</pkgmetadata>
96 changes: 0 additions & 96 deletions games-sports/xmoto/xmoto-0.5.11-r2.ebuild

This file was deleted.

62 changes: 62 additions & 0 deletions games-sports/xmoto/xmoto-0.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION="A challenging 2D motocross platform game, where physics play an important role"
HOMEPAGE="https://xmoto.tuxfamily.org"
SRC_URI="https://github.com/xmoto/xmoto/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="double-precision +nls"

RDEPEND="app-arch/bzip2
dev-db/sqlite:3
dev-games/ode[double-precision=]
dev-lang/lua:0[deprecated]
dev-libs/libxdg-basedir
dev-libs/libxml2
media-fonts/dejavu
media-libs/libpng:0=
media-libs/libsdl[joystick,opengl]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-net
media-libs/sdl-ttf
net-misc/curl
sys-libs/zlib:=
virtual/jpeg:0
virtual/glu
virtual/opengl
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}"
BDEPEND="app-arch/xz-utils
nls? ( sys-devel/gettext )"

src_prepare() {
sed -e "/^Icon/s/.xpm//" -i extra/xmoto.desktop || die
sed -e "/add_subdirectory.*\(bzip2\|libccd\|lua\|ode\|xdgbasedir\)/d" -i src/CMakeLists.txt || die
rm -rf vendor/{bzip2,lua,ode,xdgbasedir} || die

cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DUSE_GETTEXT=$(usex nls)
-DOpenGL_GL_PREFERENCE=GLVND
)

cmake_src_configure
}

src_install() {
cmake_src_install

rm -f "${ED}/usr/share/xmoto"/Textures/Fonts/DejaVuSans{Mono,}.ttf || die
dosym ../../../fonts/dejavu/DejaVuSans.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSans.ttf
dosym ../../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSansMono.ttf
}

0 comments on commit 9d94de1

Please sign in to comment.