Skip to content

Commit

Permalink
dev-util/ccache: version bump to 3.2.7
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Jul 21, 2016
1 parent dc318f3 commit 9de36e4
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/ccache/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ccache-3.2.4.tar.xz 302548 SHA256 1c3da93f654e78a4ac71a54b0f63b19bc0fef9aa5522f4ebb9c201d4361cea5d SHA512 d048b70804c81dece97f3ba511b3c109ec0d14e7dca69bc68faeeb61a4a7b5639c03e3e5ad7dad4e42b4bd198d7a7fffa4e3b7ef99590dfd4df0805db6c25db7 WHIRLPOOL 3dc1de9d1cab8769b3776e48746a1967536e7a9d01e4eb23e1ddbaaf2858c16eba170a185312bfdb0a58951c77cd6c79ff30c7cf6ab366ade64c2b6997df7703
DIST ccache-3.2.5.tar.xz 304592 SHA256 117011534b199dbe290b08acae1591c81525536a1e140da22e0fbc04c20bab85 SHA512 12612b899044db50c60bea8ed6cfeb54960ab67514d0aabaea5ee71d3d4d83bb00637e02008365d1d061adf5aa546499948a5eb8a0419222f681058c7fd5fd24 WHIRLPOOL 2cad966b419c16d7956fb2644c1113a8817437f313d54dd17fb16ae4a15f67a322b59d1b225307c980d2e17442478b71ef2bb118d2af4025e530e68fb46767cb
DIST ccache-3.2.7.tar.xz 305596 SHA256 f1db1ef3cdcf85cf40c7be926c28b4a3beb12ea4d7f1760edf45e753c5147d95 SHA512 4292bd880f7ec39591a4abc232822121e79e706659e36c6aac3f3846fa119ebe18eed3bfefb535e229da8556fe787f1700ff3c63df56d459c6f44260db24b9fa WHIRLPOOL 9abbb67873fb894d1a82e96773b723ec06830dc2a344e4d1fdfc713bc5a9a219b918633ea2b2e9c9a48a0eddc4eca3ca0eb2eb6c8b484e6e469990010dfee904
67 changes: 67 additions & 0 deletions dev-util/ccache/ccache-3.2.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

inherit eutils readme.gentoo-r1

DESCRIPTION="fast compiler cache"
HOMEPAGE="http://ccache.samba.org/"
SRC_URI="http://samba.org/ftp/ccache/${P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE=""

DEPEND="app-arch/xz-utils
sys-libs/zlib"
RDEPEND="${DEPEND}
sys-apps/gentoo-functions"

src_prepare() {
# make sure we always use system zlib
rm -rf zlib || die
epatch "${FILESDIR}"/${PN}-3.1.10-size-on-disk.patch #456178
sed \
-e "/^EPREFIX=/s:'':'${EPREFIX}':" \
"${FILESDIR}"/ccache-config-3 > ccache-config || die
}

src_install() {
DOCS=( AUTHORS.txt MANUAL.txt NEWS.txt README.txt )
default

dobin ccache-config

DOC_CONTENTS="
To use ccache with **non-Portage** C compiling, add
${EPREFIX}/usr/lib/ccache/bin to the beginning of your path, before ${EPREFIX}/usr/bin.
Portage 2.0.46-r11+ will automatically take advantage of ccache with
no additional steps. If this is your first install of ccache, type
something like this to set a maximum cache size of 2GB:\\n
# ccache -M 2G\\n
If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
ccache now supports sys-devel/clang and dev-lang/icc, too!"

readme.gentoo_create_doc
}

pkg_prerm() {
if [[ -z ${REPLACED_BY_VERSION} ]] ; then
"${EROOT}"/usr/bin/ccache-config --remove-links
"${EROOT}"/usr/bin/ccache-config --remove-links ${CHOST}
fi
}

pkg_postinst() {
"${EROOT}"/usr/bin/ccache-config --install-links
"${EROOT}"/usr/bin/ccache-config --install-links ${CHOST}

# nuke broken symlinks from previous versions that shouldn't exist
rm -f "${EROOT}"/usr/lib/ccache/bin/${CHOST}-cc || die
rm -rf "${EROOT}"/usr/lib/ccache.backup || die

readme.gentoo_print_elog
}

0 comments on commit 9de36e4

Please sign in to comment.