Skip to content

Commit

Permalink
sys-kernel/gentoo-kernel-bin: bump to 5.4.100 for arm64
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.15, Repoman-3.0.2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Feb 26, 2021
1 parent 60f9fd4 commit 9de6e31
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/gentoo-kernel-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,7 @@ DIST gentoo-kernel-5.10.17-1.x86.xpak 57292329 BLAKE2B 824b77875aa1336fff7b9f054
DIST gentoo-kernel-5.10.18-1.amd64.xpak 64024674 BLAKE2B 456b0e7e35bf54ba06908212e1a8c98dd8dd99b3670dcf344fa9b4a829413eb2c38e98f52dea3af0df80a31e925c9349851049689f4270a3cd2e03882d66c636 SHA512 9ca89659dd020fae705c71813e276bf36ef874f74d1264b7b33420aa508f01cb018b0ccbcedf774a09d00c2b881f4798b7aa3c42aeaa8319175fc9318af02ba5
DIST gentoo-kernel-5.10.18-1.x86.xpak 56984732 BLAKE2B 8c764915907440e0840f345fa9c7f475f5a016f02d19956a36b00349356755428114629a47ae4a24d212cea2ae3694adbab0d4a5a367dc4992dc542855373ff0 SHA512 b59956497a7ae1f79325108857a6bc7c9abcaea6874ce857a8021e8e26204f860afc6b7e29a9a028b3e0f13409e50ebfc6ff747fe32c0789302296012a9c07b1
DIST gentoo-kernel-5.4.100-1.amd64.xpak 61080710 BLAKE2B 84b33a1aa252b0957eb90ddd792f001942589d7f65399a5b007a2c831d0a1fa3b879814a55e5cf8b1ad6166970d3ac89838f57a2c61cec6b7b136b55d5ea4c7b SHA512 98b3dfd31a2830ed49dfc7094e9f37a39e7fbef54b648b4840122f2b53b8e970fb9c75a653445753d8e4efbd723716b9c56b2f99214c79832f3e49de63b3efbe
DIST gentoo-kernel-5.4.100-1.arm64.xpak 56394488 BLAKE2B b8ea7a56a087e98706099cc151b652dba2a40e2a39ae99670b0989ce2f11c133f07b53dda1a9749f946719ab8a5b97a57ee0a12fcf3d9a568b498859420eeef5 SHA512 549ada0acf8874d3254c8a586f5c4d0ed4f08a103aee74befae38fc47d10c716d86f3f133b8ee3c49e61fcacda2298b04b5fe96bf35917b0963f922fe424e96f
DIST gentoo-kernel-5.4.100-1.x86.xpak 52912122 BLAKE2B 5f1a8f7ccf3f9df6a89650d62df903896cf0342b9cf6e0fc265e67a887aa9a0608d62b023d9641711a2d9196958ddfbddec4e19f5f731356f5bf3a74421145f9 SHA512 6d1e5089bb817cf9e7401bb1be0b1d1433caea884b8ba4208c973fc7bbd879b65b69ace8fe3cba05bcb6aae0607ff1be9a63da42642ec2c32fe5ff7adf6fef28
DIST gentoo-kernel-5.4.94-1.amd64.xpak 61075025 BLAKE2B 96f7d69735dacd618266d4220907d2e196d4a59f39fdb6c93e88299ecd26a503684bcfbe0a0dcc8c027c3e1b90fc7c066f0d0cb5e007efee859215c6a4b91807 SHA512 e786c30e4ac3e62f25cb6403105847c20b7673f0e9fee32f513854c6e739cce513409f136da9dfd8c366d74ffc4db00625dc5d6270623af56149e4dd05801c57
DIST gentoo-kernel-5.4.94-1.arm64.xpak 56309818 BLAKE2B 50f9f4d7bfaee560860899a0a16805c0a805a9cd0b915a0dec3f654180db73cc73f3247ccc808842103fefabe9cbc0aa963aff8c649c0fe2d314a6ddf22a02ce SHA512 36ee8c73e76ac00ea6c26a5530d6dab91df46fcf2b5f072bbcc44d8bf8b7df710fa601584ee2707cb1c1bbfad9342e369a00926224a0527f1fd4588d01085508
Expand Down
59 changes: 59 additions & 0 deletions sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.100-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit kernel-install

MY_P=${P/-bin/}-1
DESCRIPTION="Pre-built Linux kernel with genpatches"
HOMEPAGE="https://www.kernel.org/"
SRC_URI+="
amd64? (
https://dev.gentoo.org/~mgorny/binpkg/amd64/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
-> ${MY_P}.amd64.xpak
)
arm64? (
https://dev.gentoo.org/~sam/binpkg/arm64/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
-> ${MY_P}.arm64.xpak
)
x86? (
https://dev.gentoo.org/~mgorny/binpkg/x86/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
-> ${MY_P}.x86.xpak
)"
S=${WORKDIR}

LICENSE="GPL-2"
KEYWORDS="~arm64"

RDEPEND="
!sys-kernel/gentoo-kernel:${SLOT}
!sys-kernel/vanilla-kernel:${SLOT}
!sys-kernel/vanilla-kernel-bin:${SLOT}"
PDEPEND="
>=virtual/dist-kernel-${PV}"

QA_PREBUILT='*'

pkg_pretend() {
ewarn "Starting with 5.4.52, Distribution Kernels are switching from Arch"
ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."

kernel-install_pkg_pretend
}

src_unpack() {
ebegin "Unpacking ${MY_P}.${ARCH}.xpak"
tar -x < <(xz -c -d --single-stream "${DISTDIR}/${MY_P}.${ARCH}.xpak")
eend ${?} || die "Unpacking ${MY_P} failed"
}

src_test() {
kernel-install_test "${PV}" \
"${WORKDIR}/usr/src/linux-${PV}/$(dist-kernel_get_image_path)" \
"lib/modules/${PV}"
}

src_install() {
mv * "${ED}" || die
}

0 comments on commit 9de6e31

Please sign in to comment.