Skip to content

Commit

Permalink
app-editors/focuswriter: add version 1.7.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <[email protected]>
Closes: gentoo#15444
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
Chiitoo authored and a17r committed Apr 21, 2020
1 parent 000222a commit 9f75c3a
Show file tree
Hide file tree
Showing 3 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/focuswriter/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST focuswriter-1.7.2-src.tar.bz2 10310759 BLAKE2B 92f0cd0ec2bb29c41f2c98e52dcb2187a70bc1c0641aed521b3d577302937cf6560f3adf422372019c8726ca29a9978b5b4d9e56e4c0c26a65fdc5d6aa0b7767 SHA512 195ddf6579aa00af120644ef1ddc88a6aaf0a6003feefb7b3dd3ca72c4bb17440553a171ad469f2d25d90416fc0e1a03f1b9d43e3b5790dac180f18b4ed657bf
DIST focuswriter-1.7.5-src.tar.bz2 10311298 BLAKE2B c495aced12e2e4deea1b602a0d1e2f97adbf2c91edf94302978fbeca9e33807e20fc05db2758ee05fc4c54ee7281cca10b6c01b70f2859899a6b227235e7aed0 SHA512 b9b533180160c5395eee8b921cf05f56e13eb48db402d352359854b419bd5367f21bac1b07fb80d4bb59ab019a7051bb9aeb1321e35a8f9d250a9584475def8b
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 026fb9b1fbfa8040815ac524b6002f93b6411d45 Mon Sep 17 00:00:00 2001
From: Jimi Huotari <[email protected]>
Date: Mon, 20 Apr 2020 22:58:48 +0300
Subject: [PATCH] Fix build against Qt 5.15.

Due to a change in Qt, 'QPainterPath' needs to be explicitly
included.
---
src/theme.cpp | 1 +
1 file changed, 1 insertion(+)

diff --git a/src/theme.cpp b/src/theme.cpp
index 4708338..59551ea 100644
--- a/src/theme.cpp
+++ b/src/theme.cpp
@@ -27,6 +27,7 @@
#include <QFile>
#include <QImageReader>
#include <QPainter>
+#include <QPainterPath>
#include <QSettings>
#include <QTextEdit>
#include <QUuid>
--
2.26.1

49 changes: 49 additions & 0 deletions app-editors/focuswriter/focuswriter-1.7.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit qmake-utils xdg

DESCRIPTION="Fullscreen and distraction-free word processor"
HOMEPAGE="https://gottcode.org/focuswriter/"
SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"

LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

BDEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig
"
RDEPEND="
app-text/hunspell:=
>=dev-qt/qtcore-5.11:5
>=dev-qt/qtgui-5.11:5
>=dev-qt/qtmultimedia-5.11:5
>=dev-qt/qtprintsupport-5.11:5
dev-qt/qtsingleapplication[qt5(+),X]
>=dev-qt/qtwidgets-5.11:5
sys-libs/zlib
"
DEPEND="${RDEPEND}
dev-qt/qtconcurrent:5
"

DOCS=( ChangeLog CREDITS README )

PATCHES=(
"${FILESDIR}/${PN}-1.6.0-unbundle-qtsingleapplication.patch"
"${FILESDIR}/${PN}-1.7.5-qt-5.15-build.patch"
)

src_configure() {
eqmake5 PREFIX="${EPREFIX}"/usr
}

src_install() {
emake INSTALL_ROOT="${D}" install
einstalldocs
}

0 comments on commit 9f75c3a

Please sign in to comment.