forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Alon Bar-Lev <[email protected]> Package-Manager: Portage-2.3.66, Repoman-2.3.11
- Loading branch information
Showing
4 changed files
with
121 additions
and
73 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1 @@ | ||
DIST tpm2-abrmd-2.0.3.tar.gz 563029 BLAKE2B 89c20066b05818825a2addacaf123568ec095d021e9811b78d11c336af9a9e97fe280a08b4478331663efd1da9b2db54207ca53728398aefe4407bfe4b0c7efd SHA512 70b431b9d09e1c1db819aabf6ca8e40a7553573339f43a6c872ad685b7822e5046bd8ede25dcd0608ce2d8fa32257f6c1dd7f234aa7d6a447ac795625d4e0fac | ||
DIST tpm2-abrmd-2.1.1.tar.gz 561352 BLAKE2B 4106811b238fee7b503bf0afb4ed857371bab023d8e449d5864eebb2386779e2bc8fb0f2bf8e334ebd8d7abe5c569f2b2cc2ea60b07672b1d3294092e63c2a5a SHA512 d685812c26a097190ced5a9e8ceb1544eb9e3858606123644d5496031706af91e5ba9fb54eb371bcb4eed4d236617f7a21a49a792196db9c5ebf277582ac7124 |
This file was deleted.
Oops, something went wrong.
118 changes: 118 additions & 0 deletions
118
app-crypt/tpm2-abrmd/files/tpm2-abrmd-2.1.1-build.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,118 @@ | ||
From a0a961c05c8916863a67a61f469c717f617e1c58 Mon Sep 17 00:00:00 2001 | ||
From: Alon Bar-Lev <[email protected]> | ||
Date: Fri, 31 May 2019 01:03:03 +0300 | ||
Subject: [PATCH 1/2] build: let autoconf detect system extensions | ||
|
||
Signed-off-by: Alon Bar-Lev <[email protected]> | ||
--- | ||
configure.ac | 4 +--- | ||
1 file changed, 1 insertion(+), 3 deletions(-) | ||
|
||
https://github.com/tpm2-software/tpm2-abrmd/pull/632 | ||
|
||
diff --git a/configure.ac b/configure.ac | ||
index 35a0c21..0cc8ce8 100644 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -7,6 +7,7 @@ AC_INIT([tpm2-abrmd], | ||
AC_CONFIG_MACRO_DIR([m4]) | ||
AC_PROG_CC | ||
AC_PROG_LN_S | ||
+AC_USE_SYSTEM_EXTENSIONS | ||
LT_INIT() | ||
PKG_INSTALLDIR() | ||
AM_INIT_AUTOMAKE([foreign subdir-objects]) | ||
@@ -151,9 +152,6 @@ AX_ADD_TOOLCHAIN_FLAG([-fstack-protector-all]) | ||
AX_ADD_COMPILER_FLAG([-fpic]) | ||
AX_ADD_COMPILER_FLAG([-fPIC]) | ||
AX_ADD_COMPILER_FLAG([-Wstrict-overflow=5]) | ||
-AX_ADD_PREPROC_FLAG([-D_GNU_SOURCE]) | ||
-AX_ADD_PREPROC_FLAG([-U_FORTIFY_SOURCE]) | ||
-AX_ADD_PREPROC_FLAG([-D_FORTIFY_SOURCE=2]) | ||
AX_ADD_LINK_FLAG([-Wl,--gc-sections]) | ||
AX_ADD_LINK_FLAG([-Wl,--no-undefined]) | ||
AX_ADD_LINK_FLAG([-Wl,-z,noexecstack]) | ||
-- | ||
2.21.0 | ||
|
||
From 977de33fe1499e7e8fa25f4c1247aaf9b71ba3a2 Mon Sep 17 00:00:00 2001 | ||
From: Alon Bar-Lev <[email protected]> | ||
Date: Fri, 31 May 2019 01:03:08 +0300 | ||
Subject: [PATCH 2/2] build: add --disable-defaultflags | ||
|
||
Align with other tpm2 build systems. | ||
Enable downstream to override flags. | ||
|
||
Signed-off-by: Alon Bar-Lev <[email protected]> | ||
--- | ||
configure.ac | 54 ++++++++++++++++++++++++++++++---------------------- | ||
1 file changed, 31 insertions(+), 23 deletions(-) | ||
|
||
diff --git a/configure.ac b/configure.ac | ||
index 0cc8ce8..dc32b09 100644 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -134,29 +134,37 @@ AS_IF([test \( "x$enable_integration" = "xyes" \) -a \( "x$enable_test_hwtpm" = | ||
[AC_MSG_NOTICE([Integration tests will be executed against the TPM device.])]) | ||
AM_CONDITIONAL([ENABLE_INTEGRATION],[test "x$enable_integration" = "xyes"]) | ||
|
||
-# preprocessor / compiler / linker flags | ||
-# these macros are defined in m4/flags.m4 | ||
-AX_ADD_COMPILER_FLAG([-Wall]) | ||
-AX_ADD_COMPILER_FLAG([-Wextra]) | ||
-AX_ADD_COMPILER_FLAG([-Werror]) | ||
-AX_ADD_COMPILER_FLAG([-std=gnu99]) | ||
-AX_ADD_COMPILER_FLAG([-Wformat]) | ||
-AX_ADD_COMPILER_FLAG([-Wformat-security]) | ||
-AX_ADD_COMPILER_FLAG([-Wno-missing-braces]) | ||
-# work around for Glib usage of function pointers type casting | ||
-# https://bugzilla.gnome.org/show_bug.cgi?id=793272 | ||
-AX_ADD_COMPILER_FLAG([-Wno-cast-function-type]) | ||
-AX_ADD_COMPILER_FLAG([-fdata-sections]) | ||
-AX_ADD_COMPILER_FLAG([-ffunction-sections]) | ||
-AX_ADD_TOOLCHAIN_FLAG([-fstack-protector-all]) | ||
-AX_ADD_COMPILER_FLAG([-fpic]) | ||
-AX_ADD_COMPILER_FLAG([-fPIC]) | ||
-AX_ADD_COMPILER_FLAG([-Wstrict-overflow=5]) | ||
-AX_ADD_LINK_FLAG([-Wl,--gc-sections]) | ||
-AX_ADD_LINK_FLAG([-Wl,--no-undefined]) | ||
-AX_ADD_LINK_FLAG([-Wl,-z,noexecstack]) | ||
-AX_ADD_LINK_FLAG([-Wl,-z,now]) | ||
-AX_ADD_LINK_FLAG([-Wl,-z,relro]) | ||
+AC_ARG_ENABLE([defaultflags], | ||
+ [AS_HELP_STRING([--disable-defaultflags], | ||
+ [Disable default preprocessor, compiler, and linker flags.])], | ||
+ [enable_defaultflags=$enableval], | ||
+ [enable_defaultflags=yes]) | ||
+AS_IF([test "x$enable_defaultflags" = "xyes"], | ||
+ [ | ||
+ # preprocessor / compiler / linker flags | ||
+ # these macros are defined in m4/flags.m4 | ||
+ AX_ADD_COMPILER_FLAG([-Wall]) | ||
+ AX_ADD_COMPILER_FLAG([-Wextra]) | ||
+ AX_ADD_COMPILER_FLAG([-Werror]) | ||
+ AX_ADD_COMPILER_FLAG([-std=gnu99]) | ||
+ AX_ADD_COMPILER_FLAG([-Wformat]) | ||
+ AX_ADD_COMPILER_FLAG([-Wformat-security]) | ||
+ AX_ADD_COMPILER_FLAG([-Wno-missing-braces]) | ||
+ # work around for Glib usage of function pointers type casting | ||
+ # https://bugzilla.gnome.org/show_bug.cgi?id=793272 | ||
+ AX_ADD_COMPILER_FLAG([-Wno-cast-function-type]) | ||
+ AX_ADD_COMPILER_FLAG([-fdata-sections]) | ||
+ AX_ADD_COMPILER_FLAG([-ffunction-sections]) | ||
+ AX_ADD_TOOLCHAIN_FLAG([-fstack-protector-all]) | ||
+ AX_ADD_COMPILER_FLAG([-fpic]) | ||
+ AX_ADD_COMPILER_FLAG([-fPIC]) | ||
+ AX_ADD_COMPILER_FLAG([-Wstrict-overflow=5]) | ||
+ AX_ADD_LINK_FLAG([-Wl,--gc-sections]) | ||
+ AX_ADD_LINK_FLAG([-Wl,--no-undefined]) | ||
+ AX_ADD_LINK_FLAG([-Wl,-z,noexecstack]) | ||
+ AX_ADD_LINK_FLAG([-Wl,-z,now]) | ||
+ AX_ADD_LINK_FLAG([-Wl,-z,relro]) | ||
+ ]) | ||
|
||
AC_SUBST([PATH]) | ||
|
||
-- | ||
2.21.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters