forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emacs/lyskom-elisp-client: New snapshot.
Closes: https://bugs.gentoo.org/710824 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Ulrich Müller <[email protected]>
- Loading branch information
Showing
2 changed files
with
45 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST lyskom-elisp-client-0.48_p20180410.tar.xz 889468 BLAKE2B b8a1766b6f6b1d4b01676792f45d66517cdc43d2e29ae6e5b0704b90e4dfc749f8e4155159fd28a25426d79502bcaf7f2cbded32b2e64e22b2b36f11cbdbd123 SHA512 efb04b2100d59fac971898a6db3e48cf45e3bdc4455f06a0cdd065a97db5441edd4eda2e838a5e88c0b0246387dba0e3f71777892b3a6889c51960f0259fbdfc | ||
DIST lyskom-elisp-client-0.48_p20200226.tar.xz 896372 BLAKE2B e9d2c7db2cbce40fa48a788c09db052ff819db2cb00848c735646c8d6fc72ea808c03881295bf91d5cb37ce63ceebf6d4537674b9a87946c75a0a92c613eb37b SHA512 901257ef054e5700038cc59712d02e855920851782bf0d44090e1db500f545fee44e47c70c8036bb29a92056c2e72ff48ac518ccdb36ab84c18a6ac18e309529 |
44 changes: 44 additions & 0 deletions
44
app-emacs/lyskom-elisp-client/lyskom-elisp-client-0.48_p20200226.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit elisp readme.gentoo-r1 | ||
|
||
DESCRIPTION="Elisp client for the LysKOM conference system" | ||
HOMEPAGE="http://www.lysator.liu.se/lyskom/klienter/emacslisp/index.en.html" | ||
# snapshot of git://git.lysator.liu.se/${PN}/${PN}.git | ||
SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~sparc ~x86" | ||
IUSE="l10n_sv" | ||
|
||
S="${WORKDIR}/${PN}" | ||
ELISP_PATCHES="${PN}-0.48_p20161231-no-git.patch" | ||
SITEFILE="50${PN}-gentoo.el" | ||
|
||
src_prepare() { | ||
elisp_src_prepare | ||
local d=${PV#*_p} | ||
sed -i "s/@@DATE@@/${d:0:4}-${d:4:2}-${d:6:2}/" src/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
emake -C src EMACS=emacs | ||
# Info page is in Swedish only | ||
use l10n_sv && emake -C doc elisp-client | ||
} | ||
|
||
src_install() { | ||
elisp-install ${PN} src/lyskom.{el,elc} | ||
elisp-site-file-install "${FILESDIR}/${SITEFILE}" | ||
dodoc src/{ChangeLog*,README,TODO} doc/NEWS* | ||
use l10n_sv && doinfo doc/elisp-client | ||
|
||
DOC_CONTENTS="If you prefer an English language environment, add the | ||
following line to your ~/.emacs file: | ||
\n\t(setq-default kom-default-language 'en)" | ||
readme.gentoo_create_doc | ||
} |