Skip to content

Commit

Permalink
dev-ml/ppx_typerep_conv: fix build with ocaml 4.03
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed May 3, 2016
1 parent fca5650 commit a0ca567
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
61 changes: 61 additions & 0 deletions dev-ml/ppx_typerep_conv/files/oc43.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
diff -uNr ppx_typerep_conv-113.33.00/_oasis ppx_typerep_conv-113.33.00+4.03/_oasis
--- ppx_typerep_conv-113.33.00/_oasis 2016-03-09 16:44:55.000000000 +0100
+++ ppx_typerep_conv-113.33.00+4.03/_oasis 2016-03-22 15:13:51.000000000 +0100
@@ -1,8 +1,8 @@
OASISFormat: 0.4
-OCamlVersion: >= 4.02.3
+OCamlVersion: >= 4.03.0
FindlibVersion: >= 1.3.2
Name: ppx_typerep_conv
-Version: 113.33.00
+Version: 113.33.00+4.03
Synopsis: Generation of runtime types from type declarations
Authors: Jane Street Group, LLC <[email protected]>
Copyrights: (C) 2015-2016 Jane Street Group LLC <[email protected]>
diff -uNr ppx_typerep_conv-113.33.00/opam ppx_typerep_conv-113.33.00+4.03/opam
--- ppx_typerep_conv-113.33.00/opam 2016-03-18 12:08:01.000000000 +0100
+++ ppx_typerep_conv-113.33.00+4.03/opam 2016-03-22 17:51:38.000000000 +0100
@@ -17,4 +17,4 @@
"ppx_type_conv"
"typerep"
]
-available: [ ocaml-version >= "4.02.3" ]
+available: [ ocaml-version >= "4.03.0" ]
diff -uNr ppx_typerep_conv-113.33.00/src/ppx_typerep_conv.ml ppx_typerep_conv-113.33.00+4.03/src/ppx_typerep_conv.ml
--- ppx_typerep_conv-113.33.00/src/ppx_typerep_conv.ml 2016-03-09 16:44:55.000000000 +0100
+++ ppx_typerep_conv-113.33.00+4.03/src/ppx_typerep_conv.ml 2016-03-22 15:13:51.000000000 +0100
@@ -134,7 +134,7 @@
let label = cd.pcd_name.txt in
let loc = cd.pcd_loc in
match cd.pcd_args with
- | [] ->
+ | Pcstr_tuple [] ->
{ label;
ctyp = None;
poly = false;
@@ -142,7 +142,7 @@
index;
arity_index = no_arg ();
}
- | args ->
+ | Pcstr_tuple args ->
let arity = List.length args in
let ctyp = ptyp_tuple ~loc args in
{ label;
@@ -152,6 +152,7 @@
index;
arity_index = with_arg ();
}
+ | Pcstr_record _ -> failwith "Pcstr_record not supported"
in
List.mapi cds ~f:mapi
end
@@ -263,7 +264,7 @@
[%stri let name = [%e estring ~loc full_type_name] ]
in
pmod_structure ~loc
- [ pstr_type ~loc [td]
+ [ pstr_type ~loc Nonrecursive [td]
; name_def
]

4 changes: 4 additions & 0 deletions dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.33.00.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -24,6 +24,10 @@ DEPEND="
RDEPEND="${DEPEND}"
DEPEND="${DEPEND} dev-ml/opam"

src_prepare() {
has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
}

src_configure() {
emake setup.exe
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
Expand Down

0 comments on commit a0ca567

Please sign in to comment.