Skip to content

Commit

Permalink
dev-tex/hevea: bump to 2.31
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.11, Repoman-2.3.3
  • Loading branch information
aballier committed Oct 18, 2017
1 parent 8a64d8f commit a236e64
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-tex/hevea/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST hevea-2.29.tar.gz 969599 SHA256 06bf0b01834a25358415c666a0a477effc12eeeb1da4da1eeefaca67b29af8c4 SHA512 4ea2f3d60fd43d183712a868cb3894b38f6d9809ba7905d69123a7672faba0d6dfe73ad1379d7996ede98ceb645bba903e5b7550bdf92e7950ce69ba7f4f3994 WHIRLPOOL e336c088d862442d3b44acaeec19064c69ecf2c6bb1c1e50822e383b03b90201d9eced19f234f3ea07de47c8cdfd0e9447cc276aac4f5a946285552c994a258e
DIST hevea-2.30.tar.gz 965635 SHA256 9e93deac8d2cc62a8d9eae2817094cdba81cabef264d009f3d434d85ab9a249c SHA512 75c700e009070bff4845ccc6f984ade8068f90ea78630a2e6ab1d27618a225a4bbbb7c4aa07c08be03094ddad4aac5d0c9e83fa01d41ff501f5c1eed9f4428eb WHIRLPOOL d91e124108b0b10cfe37d342e78d668ce75522b09e2e385119eab9cb0b253cdf04d92b6b207363fdd4c0939dc4ab706ae9bbabdc8e46cda8353a43a0ee856e13
DIST hevea-2.31.tar.gz 965678 SHA256 fbd7ad20aff45e557f5835f99a53d29a1753657cf2c004f26de83345b1b5b997 SHA512 4b66030f69b8b60750f8e62a9d81240b0ba399af8af69df10b33742e10d23fe7aef3e7782265fac9705f27715e5964debd47b9da7a394f70fda947b5fcd2d6ea WHIRLPOOL 35983a87e6210bab40198bbbafd64d44164daa462de5418b68b6e29e18cbb836b100e78177343c52da6e5df16367343effc9220c13bf855d651ad69c7aa6d350
58 changes: 58 additions & 0 deletions dev-tex/hevea/hevea-2.31.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils multilib

IUSE="+ocamlopt"

DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
HOMEPAGE="http://hevea.inria.fr/"
SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"

LICENSE="QPL"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"

DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
RDEPEND="${DEPEND}
dev-texlive/texlive-latexextra"
DEPEND="${DEPEND} dev-ml/ocamlbuild"

src_compile() {
rm -f config.sh
emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
if use ocamlopt; then
emake PREFIX=/usr || die "Failed to build native code binaries"
else
emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
fi
}

src_install() {
if use ocamlopt; then
emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
else
emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
fi

dodoc README CHANGES
}

# If texmf-update is present this means we have a latex install; update it so
# that hevea.sty can be found
# Do not (r)depend on latex though because hevea does not need it itself
# If latex is installed later, it will see hevea.sty

pkg_postinst() {
if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
/usr/sbin/texmf-update
fi
}

pkg_postrm() {
if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
/usr/sbin/texmf-update
fi
}

0 comments on commit a236e64

Please sign in to comment.