forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mail-filter/tmda: python-single-r1, EAPI=6
- Loading branch information
Showing
3 changed files
with
56 additions
and
75 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit python-single-r1 | ||
|
||
DESCRIPTION="Python-based SPAM reduction system" | ||
HOMEPAGE="http://www.tmda.net/" | ||
SRC_URI="mirror://sourceforge/${PN}/${P}.tgz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ppc ~sparc x86" | ||
IUSE="" | ||
|
||
DEPEND="virtual/mta" | ||
RDEPEND="${DEPEND}" | ||
|
||
PATCHES=( | ||
# Do not open /dev/tty when in batch mode. (bug #67150) -ticho | ||
"${FILESDIR}/tmda-1.0-non-interactive-tty.patch" | ||
) | ||
|
||
src_install() { | ||
# Executables | ||
python_doscript bin/tmda-* | ||
|
||
# The Python TMDA module | ||
python_domodule TMDA | ||
|
||
# The templates | ||
insinto /etc/tmda | ||
doins templates/*.txt | ||
|
||
# Documentation | ||
dodoc ChangeLog CODENAMES CRYPTO NEWS README THANKS UPGRADE | ||
dodoc -r doc/html | ||
|
||
# Contributed binaries and stuff | ||
cd contrib || die | ||
|
||
exeinto /usr/$(get_libdir)/tmda/contrib | ||
doexe collectaddys def2html printcdb printdbm \ | ||
sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \ | ||
vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh | ||
|
||
insinto /usr/$(get_libdir)/tmda/contrib | ||
doins ChangeLog tmda.el tmda.spec \ | ||
tofmipd.init tofmipd.sysconfig vtmdarc | ||
doins -r dot-tmda | ||
} |
This file was deleted.
Oops, something went wrong.