Skip to content

Commit

Permalink
dev-python/testtools: add version 2.2.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
Alex Brandt committed May 28, 2016
1 parent 153bb75 commit a2ede6e
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/testtools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST testtools-1.8.0.tar.gz 207976 SHA256 8afd6400fb4e75adb0b29bd09695ecb2024cd7
DIST testtools-1.8.1.tar.gz 209327 SHA256 155ed29086e48156519e15f7801b702c15ba34d8700d80ba606101f448a3839f SHA512 0bd765bd3cc82a38c980d251427f9f32d44c377aa753d2d83c36fb8cfaeb8a10cfc86a38899b89ff454fe11742ab5e309439980e12a8bbae19b3d9df799803d9 WHIRLPOOL 06f654e447b6ae42cffbff454886dc1016746bf218c90e89c4b9361af2dc709acdfdcd0100c1624dffc1f72dec5c8037dd4357aa373a6413abf945c0d27868e1
DIST testtools-1.9.0.tar.gz 221760 SHA256 b46eec2ad3da6e83d53f2b0eca9a8debb687b4f71343a074f83a16bbdb3c0644 SHA512 d4d78fb3fd105789e1ee749c66f4612494557af963ba7c3bf5b3c322609bb2ce98c6027f714cbf71720fe248d72a459b554aa65374c6a0b56904b7dabb38a112 WHIRLPOOL 926e738afd86fe945765f9fa08fa40deed7e73db4f37eb2fca9fa30321e28cda9c99e86a1e583853fe1abf93919a71c808131d2cd0694cded3d7203a406fc8d9
DIST testtools-2.0.0.tar.gz 224923 SHA256 8237ab211cdeced2ff69e7b51c66ed8b1fd2aa0b338b1749609f9567646fad57 SHA512 e27659bc1a21f20de7b8f3699198067e25024dfed68fc9553045a1356a8b46df494882b8946212e11c9cb5a1d4ce8882758839a4accf5bd01db4398ff9e0413d WHIRLPOOL db4daec29b6e1fbe4b9c6989af7f0c70dc70a0d39f84336a9885d1e977cbe0303bf5471342a1d74e0e6a7eb961945d6180153711229dc18e8fdbb9f92b4d6df8
DIST testtools-2.2.0.tar.gz 230716 SHA256 80f606607a6e4ce4d0e24e5b786562aa42c581906f3c070607a4265f3da65810 SHA512 f5ba08971975aa1ccf923c4c997ca7b093d00615131f440a9a5aad96d63be5b9e72f3364f3185d523fce9b5a7055bd52f767b54f7f9f17a102c4166efec189c5 WHIRLPOOL 042ef9e8177b44b37582b1b8013809b0fd443ac7c57e39317f73e081877c665fd368828e72568b89c0656ebc9d89e82c2ee7ffcd2bf0f31e07573df8573d3313
54 changes: 54 additions & 0 deletions dev-python/testtools/testtools-2.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 pypy pypy3 )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="Extensions to the Python standard library unit testing framework"
HOMEPAGE="https://github.com/testing-cabal/testtools"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc test"

CDEPEND="
>=dev-python/extras-1.0.0[${PYTHON_USEDEP}]
dev-python/mimeparse[${PYTHON_USEDEP}]
>=dev-python/pbr-0.11[${PYTHON_USEDEP}]
dev-python/pyrsistent[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
dev-python/traceback2[${PYTHON_USEDEP}]
>=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
>=dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]
dev-python/testscenarios[${PYTHON_USEDEP}]
)
"
RDEPEND="${CDEPEND}"
PDEPEND=">=dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]"

python_compile_all() {
use doc && emake -C doc html
}

python_test() {
"${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && HTML_DOCS=( doc/_build/html/. )

distutils-r1_python_install_all
}

0 comments on commit a2ede6e

Please sign in to comment.