Skip to content

Commit

Permalink
sys-kernel/dracut: bump to 046
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/627694
Package-Manager: Portage-2.3.14_p5, Repoman-2.3.6
  • Loading branch information
floppym committed Nov 18, 2017
1 parent 6598d0c commit a3a854e
Show file tree
Hide file tree
Showing 2 changed files with 167 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/dracut/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dracut-044.tar.xz 280004 SHA256 84b97c9b0120e9fde06c3b9cf2ede1c4632cccd8e085e980b9ec9c788655af05 SHA512 bc788076e425b223d98cf0e0b15ff57d75d423991d7a67fb564a2857c38d5c3a21d846d2ca4523f9d4b0128bb981d09b5c26031435c5fc5e30f53080bca19b3d WHIRLPOOL 684591df596fa902447e671adfaeeb8cdc469c257f756616e42747835b71be7caaac9c72bd4b1a5ba5728ec4332baaba1d265cddb1c30cbfa65cf4dce0690bc0
DIST dracut-045.tar.xz 292652 SHA256 ca9c7ea54d3efc8b57ac1427cc5fa4d66688f6cf9d3088f4c5e7ae7c7e84ebf8 SHA512 b57aab1f6fbdd5ad52a13a0eb99937b1abcd11507a2a3e6ec9bcb94e578cc32edc01a814ea2cef93158c27c17e3e40bcdd32a66457a20363f8136b8b546bbb4a WHIRLPOOL d9cdf32e4fb745b2598aa2f0504c943f5a069dddc17d5261d594b2fc33921306196386bc35156d5bf71983cc15be3b0cddd504d1b6a2042b45b5c5ae622b23b9
DIST dracut-046.tar.xz 299520 SHA256 3cb206abc198811972d452d53e88c32f29dd1b0bb24e35e23b4056aa74824f99 SHA512 75cefc184960024ef32f7bb5a0fe060e9c7d82dbfd0fe247d54b585e2ebbf0f8af5d5dc1be7e5e8cf2c3bc27b3293842c6361ae62d047289d0c59d7d40b09122 WHIRLPOOL 2a430978934e00a5c87908a6e312e94785d8c2d4d9281c23de9a04d0e91658d234e97dbf826c3e90c6d3c7186f96eb251cfd5e7508ac0c2d2e9dd46486dc284d
166 changes: 166 additions & 0 deletions sys-kernel/dracut/dracut-046.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,166 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit bash-completion-r1 linux-info toolchain-funcs systemd

DESCRIPTION="Generic initramfs generation tool"
HOMEPAGE="https://dracut.wiki.kernel.org"
SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug selinux"

RESTRICT="test"

CDEPEND="virtual/udev
virtual/pkgconfig
>=sys-apps/kmod-15[tools]
"
RDEPEND="${CDEPEND}
app-arch/cpio
>=app-shells/bash-4.0:0
|| (
>=sys-apps/sysvinit-2.87-r3
sys-apps/systemd[sysv-utils]
)
sys-apps/coreutils[xattr(-)]
>=sys-apps/util-linux-2.21
debug? ( dev-util/strace )
selinux? (
sys-libs/libselinux
sys-libs/libsepol
sec-policy/selinux-dracut
)
!net-analyzer/arping
"
DEPEND="${CDEPEND}
app-text/asciidoc
>=dev-libs/libxslt-1.1.26
app-text/docbook-xml-dtd:4.5
>=app-text/docbook-xsl-stylesheets-1.75.2
"

DOCS=( AUTHORS HACKING NEWS README README.generic README.kernel README.modules
README.testsuite TODO )

QA_MULTILIB_PATHS="usr/lib/dracut/.*"

PATCHES=(
"${FILESDIR}/045-systemdutildir.patch"
)

src_configure() {
local myconf=(
--prefix="${EPREFIX}/usr"
--sysconfdir="${EPREFIX}/etc"
--bashcompletiondir="$(get_bashcompdir)"
--systemdsystemunitdir="$(systemd_get_systemunitdir)"
)

tc-export CC PKG_CONFIG

echo ./configure "${myconf[@]}"
./configure "${myconf[@]}" || die
}

src_install() {
default

local dracutlibdir="usr/lib/dracut"

local libdirs="/$(get_libdir) /usr/$(get_libdir)"
if [[ ${SYMLINK_LIB} = yes ]]; then
# Preserve lib -> lib64 symlinks in initramfs
[[ $libdirs =~ /lib\ ]] || libdirs+=" /lib /usr/lib"
fi

einfo "Setting libdirs to \"${libdirs}\" ..."
echo "libdirs=\"${libdirs}\"" > "${T}/gentoo.conf"
insinto "${dracutlibdir}/dracut.conf.d"
doins "${T}/gentoo.conf"

insinto /etc/logrotate.d
newins dracut.logrotate dracut

dodir /var/lib/dracut/overlay

dodoc dracut.html
}

pkg_postinst() {
if linux-info_get_any_version && linux_config_exists; then
ewarn ""
ewarn "If the following test report contains a missing kernel"
ewarn "configuration option, you should reconfigure and rebuild your"
ewarn "kernel before booting image generated with this Dracut version."
ewarn ""

local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"

# Kernel configuration options descriptions:
local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
"(initramfs/initrd) support"

local opt desc

# Generate ERROR_* variables for check_extra_config.
for opt in ${CONFIG_CHECK}; do
opt=${opt#\~}
desc=desc_${opt}
eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
"is missing and REQUIRED'"
done

check_extra_config
echo
else
ewarn ""
ewarn "Your kernel configuration couldn't be checked. Do you have"
ewarn "/usr/src/linux/.config file there? Please check manually if"
ewarn "following options are enabled:"
ewarn ""
ewarn " CONFIG_BLK_DEV_INITRD"
ewarn " CONFIG_DEVTMPFS"
ewarn ""
fi

elog "To get additional features, a number of optional runtime"
elog "dependencies may be installed:"
elog ""
optfeature "Networking support" net-misc/curl "net-misc/dhcp[client]" \
sys-apps/iproute2 "net-misc/iputils[arping]"
optfeature \
"Measure performance of the boot process for later visualisation" \
app-benchmarks/bootchart2 app-admin/killproc sys-process/acct
optfeature "Scan for Btrfs on block devices" sys-fs/btrfs-progs
optfeature "Load kernel modules and drop this privilege for real init" \
sys-libs/libcap
optfeature "Support CIFS" net-fs/cifs-utils
optfeature "Decrypt devices encrypted with cryptsetup/LUKS" \
"sys-fs/cryptsetup[-static-libs]"
optfeature "Support for GPG-encrypted keys for crypt module" \
app-crypt/gnupg
optfeature \
"Allows use of dash instead of default bash (on your own risk)" \
app-shells/dash
optfeature "Framebuffer splash (media-gfx/splashutils)" \
media-gfx/splashutils
optfeature "Support iSCSI" sys-block/open-iscsi
optfeature "Support Logical Volume Manager" sys-fs/lvm2
optfeature "Support MD devices, also known as software RAID devices" \
sys-fs/mdadm
optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
optfeature "Support network block devices" sys-block/nbd
optfeature "Support NFS" net-fs/nfs-utils net-nds/rpcbind
optfeature \
"Install ssh and scp along with config files and specified keys" \
net-misc/openssh
optfeature "Enable logging with syslog-ng or rsyslog" app-admin/syslog-ng \
app-admin/rsyslog
}

0 comments on commit a3a854e

Please sign in to comment.