Skip to content

Commit

Permalink
media-libs/libaom: 1.0.0-r2 EAPI-7 bump, use cmake.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 19, 2020
1 parent 36e4c32 commit a54a2e6
Showing 1 changed file with 13 additions and 15 deletions.
28 changes: 13 additions & 15 deletions media-libs/libaom/libaom-1.0.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

CMAKE_ECLASS=cmake
inherit cmake-multilib

if [[ ${PV} == *9999* ]]; then
Expand All @@ -28,20 +30,19 @@ IUSE="doc examples"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_avx cpu_flags_x86_avx2"
IUSE="${IUSE} cpu_flags_arm_neon"

RDEPEND=""
DEPEND="abi_x86_32? ( dev-lang/yasm )
REQUIRED_USE="
cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
"

BDEPEND="abi_x86_32? ( dev-lang/yasm )
abi_x86_64? ( dev-lang/yasm )
abi_x86_x32? ( dev-lang/yasm )
x86-fbsd? ( dev-lang/yasm )
amd64-fbsd? ( dev-lang/yasm )
doc? ( app-doc/doxygen )
"

REQUIRED_USE="
cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
"

PATCHES=(
"${FILESDIR}/libdirpc2.patch"
"${FILESDIR}/pthread_lib2.patch"
Expand All @@ -55,7 +56,7 @@ DOCS=( PATENTS )

src_prepare() {
sed -e 's/lib"/lib${LIB_SUFFIX}"/' -i CMakeLists.txt || die
cmake-utils_src_prepare
cmake_src_prepare
}

multilib_src_configure() {
Expand All @@ -77,17 +78,14 @@ multilib_src_configure() {
-DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
-DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
-DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)

-DBUILD_SHARED_LIBS=ON
)
cmake-utils_src_configure
cmake_src_configure
rm aom.pc # ensure it is rebuilt with proper libdir
}

multilib_src_install() {
cmake-utils_src_install
if multilib_is_native_abi && use doc ; then
docinto html
dodoc docs/html/*
local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
cmake_src_install
}

0 comments on commit a54a2e6

Please sign in to comment.