Skip to content

Commit

Permalink
app-emulation/vagrant: bump to 2.2.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
gyakovlev committed Jan 10, 2019
1 parent 83cbcb1 commit a67d546
Show file tree
Hide file tree
Showing 2 changed files with 91 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/vagrant/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vagrant-2.1.5.tar.gz 1238788 BLAKE2B 8e3dfeb4d830fde1984c08b16422c99b51ce455fcc63e1fad0eca7860efccbf2e77edc13537bfa495345e585b559fe5462ae872decce036b45c1f54c453983ea SHA512 544216eb25c06a1ebddbadcc9d2d6a6dd9932e33d2554e3d51dba0e24a339b9afe0b85d1322bdb67c5de3d070aa4c854f1ccc931b23ea80f0625eb4d1f120238
DIST vagrant-2.2.2.tar.gz 1223645 BLAKE2B 595d26a11f27a23a9e66386820dec7c23fbafe079e9e9750e7cbc928cac2e965782abbb062f6b04efd367b56297d040af2b4f4f56d6df06e604f018110e10329 SHA512 70c83fcd896ae3b84fac22c539eb85db9bf08c8f75108d5f2b86841821cf7a885b72565814519b6f2ef3422d84d2f67fc402b983b1a15c1edfd0dc78196cd957
DIST vagrant-2.2.3.tar.gz 1236158 BLAKE2B 083b153bc723b94aa543e02b275d1864dba5b2d7408266f8fe3813ba19302725aabc25e20e5b4df004055ea1ffa937f16f27307626cec137a253a6dab2b8f972 SHA512 ff3d95968a51a37a397342c013ebcc3bbfe7ff5b76fb35fead92e9a3b770c85f2f4720514aa68878b0b6e4fbd92629832dc1ddf925691529adf0c84c8f44d84c
90 changes: 90 additions & 0 deletions app-emulation/vagrant/vagrant-2.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,90 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby23 ruby24 ruby25"

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
RUBY_FAKEGEM_TASK_DOC=""

inherit bash-completion-r1 ruby-fakegem

DESCRIPTION="A tool for building and distributing development environments"
HOMEPAGE="https://vagrantup.com/"
SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+virtualbox"
RESTRICT="test"

RDEPEND="${RDEPEND}
app-arch/libarchive
net-misc/curl
virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"

ruby_add_rdepend "
>=dev-ruby/bcrypt_pbkdf-1.0.0
>=dev-ruby/childprocess-0.6.0
>=dev-ruby/ed25519-1.2.4
>=dev-ruby/erubis-2.7.0
>=dev-ruby/hashicorp-checkpoint-0.1.5
>=dev-ruby/i18n-1.1.1:1
>=dev-ruby/listen-3.1.5
<dev-ruby/log4r-1.1.11
<dev-ruby/mime-types-3:*
>=dev-ruby/net-ssh-5.1.0:*
>=dev-ruby/net-sftp-2.1
>=dev-ruby/net-scp-1.2.0
dev-ruby/rest-client:2
>=dev-ruby/rubyzip-1.2.2
>=dev-ruby/vagrant_cloud-2.0.2
"

# upstream specifies rake>=12 but it apparently doesn't need something this
# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
# is tricky, we specify a lower dependency requirement here. This way, we'll be
# able to stabilize vagrant sooner.
ruby_add_bdepend "
>=dev-ruby/rake-10.5.0
"

all_ruby_prepare() {
# remove bundler support
sed -i '/[Bb]undler/d' Rakefile || die
rm Gemfile || die

# loosen dependencies
sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
-e '/ruby_dep/s/<=/>=/' \
-i ${PN}.gemspec || die

# remove windows-specific gems
sed -e '/wdm\|winrm/d' \
-i ${PN}.gemspec || die

# remove bsd-specific gems
sed -e '/rb-kqueue/d' \
-i ${PN}.gemspec || die

sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
}

all_ruby_install() {
all_fakegem_install

newbashcomp contrib/bash/completion.sh ${PN}

# provide executable similar to upstream:
# https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
dobin "${PN}"

# directory for plugins.json
keepdir /var/lib/vagrant

insinto /usr/share/vim/vimfiles/syntax/
doins contrib/vim/vagrantfile.vim
}

0 comments on commit a67d546

Please sign in to comment.