forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.24
- Loading branch information
Michael Sterrett
committed
Dec 23, 2015
1 parent
9522d24
commit a6f2ea0
Showing
12 changed files
with
209 additions
and
7 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST supertux-0.1.3.tar.bz2 6715265 SHA256 0092588351776626955339caaa62d12ce5954bb80c5f6952f60a122f53c2ad97 SHA512 75848583f9f9b9d0f36fec77812501875420fde8befe1ff9ac4ea7613f4d9464b2eb460c2ed89b4dc31e697fbb449a5431c72675e2820d13f5c42653dc07ad98 WHIRLPOOL bb8998845bee7f33a7aff94109d9767d000c89df6c670a1ccb85c4e9158a8ce6c4064f89587b9ea40d9ba1a854b9f5bba82ccc7dcac6dedcdb337cfaa1777898 | ||
DIST supertux-0.4.0.tar.bz2 79713147 SHA256 d18dde3c415e619b4bb035e694ffc384be16576250c9df16929d9ec38daff782 SHA512 66ca63c982b6076847662c187069eb965211439e5dfc628300f2a9bd0d2b4c0f7b53f6e7c2aed263c098cc9b77fedf132e73b1f3b3eacaf5535cae8300262fb5 WHIRLPOOL 12551b655f0459a37d3b91b1eff058ec383df34c9f3c29c1e8a63c070c12b32ec798b772053cd08b11d32b612bab1188b69678e71585279e94ad380052076f64 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- supertux2.desktop.orig | ||
+++ supertux2.desktop | ||
@@ -35,7 +35,7 @@ | ||
Comment[pt]=Joga este clássico de plataformas 2D | ||
Comment[pt_BR]=Encarne o pinguin Tux neste jogo inspirado em clássicos de Pular&Correr | ||
Comment[hu]=Egy klasszikus 2D-s oldalnézeti játék | ||
-Icon=supertux.png | ||
+Icon=supertux | ||
Exec=supertux2 | ||
Terminal=false | ||
StartupNotify=false |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
--- CMakeLists.txt.orig | ||
+++ CMakeLists.txt | ||
@@ -329,7 +329,7 @@ | ||
endif(COMPILER_SUPPORTS_CXX11) | ||
|
||
|
||
-IF(CMAKE_COMPILER_IS_GNUCC) | ||
+IF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS) | ||
SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g" CACHE STRING "Debug flags") | ||
SET(CMAKE_C_FLAGS_DEBUG "-O0 -g" CACHE STRING "Debug flags") | ||
SET(CMAKE_CXX_FLAGS_PROFILE "-pg" CACHE STRING "Profile flags") | ||
@@ -352,7 +352,7 @@ | ||
# -Wlogical-op -Wstrict-null-sentinel | ||
SET(SUPERTUX2_EXTRA_WARNING_FLAGS "-fdiagnostics-show-option -pedantic -Wno-long-long -Wcast-align -Wdisabled-optimization -Winit-self -Winvalid-pch -Wmissing-include-dirs -Wmissing-noreturn -Wpacked -Wredundant-decls -Wstack-protector -Wformat=2 -Weffc++ -Wctor-dtor-privacy -Wno-unused-parameter -Wshadow -Wnon-virtual-dtor -Wcast-qual") | ||
ENDIF(WARNINGS) | ||
-ENDIF(CMAKE_COMPILER_IS_GNUCC) | ||
+ENDIF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS) | ||
|
||
## If xgettext is available, generate messages.pot for sources | ||
|
||
@@ -407,9 +407,9 @@ | ||
ENDIF(GENERATE_MESSAGESPOT) | ||
|
||
## Some additional compiler switches | ||
-IF(CMAKE_COMPILER_IS_GNUCC) | ||
+IF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS) | ||
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-strict-aliasing") | ||
-ENDIF(CMAKE_COMPILER_IS_GNUCC) | ||
+ENDIF(CMAKE_COMPILER_IS_GNUCC_NOTOUCHING_FLAGS) | ||
|
||
IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin") | ||
ADD_DEFINITIONS(-DMACOSX) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- CMakeLists.txt.orig | ||
+++ CMakeLists.txt | ||
@@ -571,7 +571,7 @@ | ||
|
||
SET(APPS "\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${INSTALL_SUBDIR_BIN}/supertux2") | ||
|
||
- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.png ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.xpm DESTINATION "share/pixmaps/") | ||
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.png DESTINATION "share/pixmaps/") | ||
|
||
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin" AND DISABLE_CPACK_BUNDLING) | ||
ENDIF(WIN32 AND NOT UNIX) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- CMakeLists.txt.orig | ||
+++ CMakeLists.txt | ||
@@ -578,7 +578,7 @@ | ||
|
||
INSTALL(TARGETS supertux2_exe DESTINATION ${INSTALL_SUBDIR_BIN}) | ||
|
||
-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/INSTALL.md ${CMAKE_CURRENT_SOURCE_DIR}/README.md ${CMAKE_CURRENT_SOURCE_DIR}/LICENSE.txt ${CMAKE_CURRENT_SOURCE_DIR}/NEWS.md DESTINATION ${INSTALL_SUBDIR_DOC}) | ||
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/INSTALL.md ${CMAKE_CURRENT_SOURCE_DIR}/README.md ${CMAKE_CURRENT_SOURCE_DIR}/NEWS.md DESTINATION ${INSTALL_SUBDIR_DOC}) | ||
|
||
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/credits.txt DESTINATION ${INSTALL_SUBDIR_SHARE}) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
--- CMakeLists.txt.orig | ||
+++ CMakeLists.txt | ||
@@ -251,7 +251,6 @@ | ||
include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/squirrel/include/) | ||
include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/tinygettext/include/) | ||
include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/findlocale/) | ||
-include_directories (${CMAKE_CURRENT_SOURCE_DIR}/external/obstack/) | ||
|
||
IF(WIN32) | ||
ADD_DEFINITIONS(-D_USE_MATH_DEFINES -DNOMINMAX) | ||
@@ -260,7 +259,7 @@ | ||
|
||
## Build list of sources for supertux binary | ||
|
||
-FILE(GLOB SUPERTUX_SOURCES_C RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} external/obstack/*.c external/findlocale/findlocale.c) | ||
+FILE(GLOB SUPERTUX_SOURCES_C RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} external/findlocale/findlocale.c) | ||
|
||
FILE(GLOB SUPERTUX_SOURCES_CXX RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} src/*/*.cpp src/supertux/menu/*.cpp src/video/sdl/*.cpp) | ||
FILE(GLOB SUPERTUX_RESOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "${PROJECT_BINARY_DIR}/tmp/*.rc") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- supertux-0.4.0.orig/external/squirrel/CMakeLists.txt | ||
+++ supertux-0.4.0/external/squirrel/CMakeLists.txt | ||
@@ -65,8 +65,6 @@ | ||
|
||
# the squirrel sources are out of our control so don't be too pedantic about | ||
# them | ||
-SET(CMAKE_CXX_FLAGS "") | ||
-SET(CMAKE_C_FLAGS "") | ||
|
||
## define a target for building the library | ||
|
||
@@ -82,8 +80,3 @@ | ||
set(LIB_SUBDIR "lib${LIB_SUFFIX}" | ||
CACHE STRING "Subdirectory of prefix into which libraries are installed (e.g., lib32, lib64)") | ||
|
||
-INSTALL(TARGETS squirrel | ||
- RUNTIME DESTINATION bin | ||
- ARCHIVE DESTINATION ${LIB_SUBDIR} | ||
- LIBRARY DESTINATION ${LIB_SUBDIR} | ||
- COMPONENT squirrel) |
50 changes: 50 additions & 0 deletions
50
games-arcade/supertux/files/supertux-0.4.0-tinygettext.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
--- supertux-0.4.0.orig/external/tinygettext/CMakeLists.txt | ||
+++ supertux-0.4.0/external/tinygettext/CMakeLists.txt | ||
@@ -59,7 +59,7 @@ | ||
) | ||
|
||
## Reveal library type choice to users | ||
-option(BUILD_SHARED_LIBS "Produce dynamic library instead of static archive" ON) | ||
+option(BUILD_SHARED_LIBS "Produce dynamic library instead of static archive" OFF) | ||
|
||
# TinyGetText library compilation | ||
|
||
@@ -127,14 +127,9 @@ | ||
## Debug options | ||
|
||
option(WERROR "Stops on first compiler warning in debug mode" OFF) | ||
-option(WARNINGS "Enable long list of warnings for compiler to check" ON) | ||
+option(WARNINGS "Enable long list of warnings for compiler to check" OFF) | ||
|
||
CHECK_CXX_FLAG(std=c++0x) | ||
-CHECK_CXX_FLAG(O3) | ||
-CHECK_CXX_FLAG(Wall) | ||
-CHECK_CXX_FLAG(Wextra) | ||
-CHECK_CXX_FLAG(Weffc++) | ||
-CHECK_CXX_FLAG(pedantic) | ||
|
||
if(WARNINGS) | ||
CHECK_CXX_FLAG(Wabi) | ||
@@ -194,22 +189,4 @@ | ||
endforeach(TEST) | ||
ENDIF() | ||
|
||
-## Install tinygettext | ||
- | ||
-# use standardized variable name | ||
-set(LIB_SUBDIR "lib${LIB_SUFFIX}" | ||
- CACHE STRING "Subdirectory of prefix into which libraries are installed (e.g., lib32, lib64)") | ||
- | ||
-## prepare tinygettext.pc | ||
-configure_file(tinygettext.pc.in tinygettext.pc @ONLY) | ||
- | ||
-install(TARGETS tinygettext | ||
- RUNTIME DESTINATION bin | ||
- ARCHIVE DESTINATION ${LIB_SUBDIR} | ||
- LIBRARY DESTINATION ${LIB_SUBDIR}) | ||
-install(FILES ${TINYGETTEXT_HEADERS} | ||
- DESTINATION include/tinygettext) | ||
-install(FILES ${tinygettext_BINARY_DIR}/tinygettext.pc | ||
- DESTINATION ${LIB_SUBDIR}/pkgconfig) | ||
- | ||
# EOF # |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit cmake-utils games | ||
|
||
DESCRIPTION="A game similar to Super Mario Bros." | ||
HOMEPAGE="http://supertuxproject.org/" | ||
SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${PV}/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug" | ||
|
||
RDEPEND="dev-games/physfs | ||
dev-libs/boost:= | ||
media-libs/glew:= | ||
virtual/opengl | ||
media-libs/libvorbis | ||
media-libs/openal | ||
>=media-libs/libsdl2-2.0.1[joystick,video] | ||
>=media-libs/sdl2-image-2.0.0[png,jpeg] | ||
>=net-misc/curl-7.21.7" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
PATCHES=( "${FILESDIR}"/${P}-{obstack,tinygettext,squirrel,desktop,flags,license,icon}.patch ) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWERROR=OFF | ||
-DINSTALL_SUBDIR_BIN=games/bin | ||
-DINSTALL_SUBDIR_DOC=share/doc/${PF} | ||
$(cmake-utils_use_enable debug SQDBG) | ||
$(cmake-utils_use debug) | ||
) | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_compile() { | ||
cmake-utils_src_compile | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
prepgamesdirs | ||
} |