Skip to content

Commit

Permalink
dev-python/django-extensions: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Dec 17, 2015
1 parent 378ccfd commit a805885
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/django-extensions/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST django-extensions-1.5.6.tar.gz 404366 SHA256 65fb2d714fd5bdb9b08832993c2c8478b25d98c2a3e787696cfe762acae64544 SHA512 4925f1b3a511e554e160b183bab5f6396d7af4c7a4862c01b805fde296de7380416f578f2dc4cfce03b563ed310ced046a9107a688a0e2df382d559a6b0e3615 WHIRLPOOL ababa6595e187b20890830bd815a8c7d745e4c0ef7c613728dfa91fb89b4893596dcf5bff2a47dd3ea56e66987f6fe187446f870ad2ffe262c13926e5bab3b65
DIST django-extensions-1.5.7.tar.gz 404240 SHA256 7061f4aeedd34e3290e31efa9fb76131c4f1235838e01cb1b28edda7f75945cf SHA512 5a22fb073d89b4dd04b1fdda83928c9e560511252c13652dbcced0ab678dc0f86482662ac63ec98ab5cd12f443c0aac3debe91ed6cfc139ae030cae64d3948eb WHIRLPOOL 2bebf02aed5c1ac98ec3367ba012502c209ad0a1cbe779aa540d9ac567c7d6aa1d8d8ded8803d68068c4d6e0507b31aa0622b952cdd1c4545193481fcb43b33a
DIST django-extensions-1.5.9.tar.gz 405401 SHA256 59c12ad4dae6cb7a54deac626a0907d8b0d19b5757dc1d15b06374695131528b SHA512 6887df5406e74201fec0adc674176810fcbd93ef249b5433a38c9c783f5e23dfd384649901bf7dc8aa8f04accf731024887cf95fd335982ec84b3d4261a9712f WHIRLPOOL 6310470dbce5f8b728e680842e6d66e6d4150d53d25c58ea9205ac0c29b8735edcde525c1a505ed30e64860d916b62be5ac1de6f6d093b7cf7845c3ef86dde8b
DIST django-extensions-1.6.1.tar.gz 371907 SHA256 4799534f35eba1c07cb6f9859aa5bb719886769f5d35d2a38e7490ce90c0ce69 SHA512 c16b99e64f4faaa6034ab343a44488d031fcc0e2ec4fe78c7cc426dd810988ebcfa28b8bcce6054188fad3fe2a30851d6df4968aa9518e540208e1af0089c6b5 WHIRLPOOL b1d2a14cb48491ad4d6cf3661d986d855189ede6b6d5b85ae0b33f2c96d9926857fbcfa51a762def175ba580ec290aeaa714d0b74afc08c76c4d7804ebb10fa5
62 changes: 62 additions & 0 deletions dev-python/django-extensions/django-extensions-1.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4} )

inherit distutils-r1 eutils

DESCRIPTION="Django Command Extensions"
HOMEPAGE="https://github.com/django-extensions/django-extensions http://django-extensions.readthedocs.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD || ( MIT GPL-2 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

# Req'd for tests
DISTUTILS_IN_SOURCE_BUILD=1

RESTRICT=test

RDEPEND="
>=dev-python/django-1.5.4[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
>=dev-python/django-1.5.4[${PYTHON_USEDEP}]
dev-python/shortuuid[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
py.test -vv || die
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}

pkg_postinst() {
echo ""
elog "Further enhancements can be achieved by installing the following packages:"
echo ""
optfeature "Use ipython in shell_plus" dev-python/ipython
optfeature "Use ptpython in shell_plus" dev-python/ptpython
optfeature "Renders a graphical overview of your project or specified apps." dev-python/pygraphviz
optfeature "sync your MEDIA_ROOT and STATIC_ROOT folders to S3" dev-python/boto
optfeature "RunServerPlus-typical runserver with Werkzeug debugger baked in" dev-python/werkzeug dev-python/watchdog
}

0 comments on commit a805885

Please sign in to comment.