Skip to content

Commit

Permalink
app-i18n/mozc: Fix building with GCC 8.
Browse files Browse the repository at this point in the history
  • Loading branch information
Arfrever Frehtes Taifersar Arahesis authored and floppym committed Jun 13, 2018
1 parent b9ccc94 commit a917a82
Show file tree
Hide file tree
Showing 3 changed files with 24 additions and 0 deletions.
22 changes: 22 additions & 0 deletions app-i18n/mozc/files/mozc-2.23.2815.102-gcc-8.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
https://github.com/google/mozc/issues/441

--- /src/prediction/zero_query_dict.h
+++ /src/prediction/zero_query_dict.h
@@ -147,6 +147,17 @@
return iter;
}

+ iterator &operator--() {
+ ptr_ -= kTokenByteSize;
+ return *this;
+ }
+
+ iterator operator--(int) {
+ const iterator tmp(ptr_, string_array_);
+ ptr_ -= kTokenByteSize;
+ return tmp;
+ }
+
iterator &operator-=(ptrdiff_t n) {
ptr_ -= n * kTokenByteSize;
return *this;
1 change: 1 addition & 0 deletions app-i18n/mozc/mozc-2.23.2815.102.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -99,6 +99,7 @@ src_unpack() {

src_prepare() {
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-system_libraries.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-gcc-8.patch"
eapply -p2 "${FILESDIR}/${PN}-2.20.2673.102-tests_build.patch"
eapply -p2 "${FILESDIR}/${PN}-2.20.2673.102-tests_skipping.patch"

Expand Down
1 change: 1 addition & 0 deletions app-i18n/mozc/mozc-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -99,6 +99,7 @@ src_unpack() {

src_prepare() {
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-system_libraries.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-gcc-8.patch"
eapply -p2 "${FILESDIR}/${PN}-2.20.2673.102-tests_build.patch"
eapply -p2 "${FILESDIR}/${PN}-2.20.2673.102-tests_skipping.patch"

Expand Down

0 comments on commit a917a82

Please sign in to comment.