Skip to content

Commit

Permalink
games-fps/avp: Port to EAPI 7
Browse files Browse the repository at this point in the history
* Restrict redistribution
* Fix -fno-common

Closes: https://bugs.gentoo.org/694940
Closes: https://bugs.gentoo.org/708416
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Nov 15, 2020
1 parent 1018276 commit a95a36e
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 17 deletions.
29 changes: 12 additions & 17 deletions games-fps/avp/avp-20150214-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils cmake-utils
EAPI=7

inherit cmake

DESCRIPTION="Linux port of Aliens vs Predator"
HOMEPAGE="http://www.icculus.org/avp/"
Expand All @@ -11,36 +12,30 @@ SRC_URI="http://www.icculus.org/avp/files/${P}.tar.gz"
LICENSE="AvP"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="bindist mirror"

RDEPEND="
media-libs/libsdl[video,joystick,opengl]
media-libs/openal"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

CMAKE_BUILD_TYPE=Release
PATCHES=( "${FILESDIR}"/avp-20150214-fno-common.patch )

src_configure() {
local mycmakeargs=(
"-DCMAKE_VERBOSE_MAKEFILE=TRUE"
-DSDL_TYPE=SDL
-DOPENGL_TYPE=OPENGL
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
cmake_src_configure
}

src_install() {
dobin "${BUILD_DIR}/${PN}"
dodoc README
dobin "${BUILD_DIR}"/avp
einstalldocs
}

pkg_postinst() {
elog "Please follow the instructions in /usr/share/doc/${PF}"
elog "Please follow the instructions in ${EROOT}/usr/share/doc/${PF}"
elog "to install the rest of the game."
}
22 changes: 22 additions & 0 deletions games-fps/avp/files/avp-20150214-fno-common.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
--- a/src/avp/win95/d3d_render.cpp
+++ b/src/avp/win95/d3d_render.cpp
@@ -2990,7 +2990,7 @@
//#define WATER_POLY_SCALE 256
int MeshXScale;
int MeshZScale;
-int WaterFallBase;
+extern int WaterFallBase;
void PostLandscapeRendering(void)
{
extern int NumOnScreenBlocks;
--- a/src/opengl.c
+++ b/src/opengl.c
@@ -2796,7 +2796,7 @@

int MeshXScale;
int MeshZScale;
-int WaterFallBase;
+extern int WaterFallBase;

int WaterXOrigin;
int WaterZOrigin;

0 comments on commit a95a36e

Please sign in to comment.