Skip to content

Commit

Permalink
dev-java/laf-plugin: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
monsieurp committed Mar 25, 2017
1 parent 117e701 commit a96d532
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/laf-plugin/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST laf-plugin-0.2-src.tar.bz2 13799 SHA256 e2252f74efbaa1f0c32a475c320283e614932e3af2d98a65462bf0e1f8cc00ba SHA512 91ac3f9f5ebfcd70e7cc76f2e028e9578c6113a848b0ccdc6b001fff006bf5aaa12af08b1752851693d218d4b2d7d053f62461481e49d5a0bde21e5a7d086331 WHIRLPOOL 6aaea36bbcc22eca1704185faf866fba1b723cd3d6ff02197f28287ded67fc43bb4c2f9cbe8a2dce9e82eaa88774b1fdb4c66e54cdc4f09ad946718641cb1334
DIST laf-plugin-0.2.tar.bz2 13799 SHA256 e2252f74efbaa1f0c32a475c320283e614932e3af2d98a65462bf0e1f8cc00ba SHA512 91ac3f9f5ebfcd70e7cc76f2e028e9578c6113a848b0ccdc6b001fff006bf5aaa12af08b1752851693d218d4b2d7d053f62461481e49d5a0bde21e5a7d086331 WHIRLPOOL 6aaea36bbcc22eca1704185faf866fba1b723cd3d6ff02197f28287ded67fc43bb4c2f9cbe8a2dce9e82eaa88774b1fdb4c66e54cdc4f09ad946718641cb1334
DIST laf-plugin-1.1.jar 8105 SHA256 2b7919c502906983307b556284d6e86df2034b69ebf3394f303490e99936500d SHA512 2ca265d23ac95e5d194e4905ead4c975cb8739a0aa30096c028d2f6467b148de2ac0ff71c6730752a666eee53551867d9d8c852d25238a873fbd4bd994cf80c0 WHIRLPOOL cda35e80834745d00ab2e1a3f3531ecc0e5cf4b140c5a167b86ffd213ccf9cdf0bb76d4582ec1745d738fbccd5fa81e1267e6f54a7a330521cd78fb6897d6e3d
42 changes: 42 additions & 0 deletions dev-java/laf-plugin/files/laf-plugin-0.2-enum.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
--- a/src/org/jvnet/lafplugin/XMLElement.java 2017-03-24 19:08:40.320048066 +0000
+++ b/src/org/jvnet/lafplugin/XMLElement.java 2017-03-24 19:10:18.490049991 +0000
@@ -478,9 +478,9 @@
this.children = new Vector();
this.entities = entities;
this.lineNr = 0;
- Enumeration enum = this.entities.keys();
- while (enum.hasMoreElements()) {
- Object key = enum.nextElement();
+ Enumeration myEnum = this.entities.keys();
+ while (myEnum.hasMoreElements()) {
+ Object key = myEnum.nextElement();
Object value = this.entities.get(key);
if (value instanceof String) {
value = ((String) value).toCharArray();
@@ -2168,10 +2168,10 @@
writer.write('<');
writer.write(this.name);
if (! this.attributes.isEmpty()) {
- Enumeration enum = this.attributes.keys();
- while (enum.hasMoreElements()) {
+ Enumeration myEnum = this.attributes.keys();
+ while (myEnum.hasMoreElements()) {
writer.write(' ');
- String key = (String) enum.nextElement();
+ String key = (String) myEnum.nextElement();
String value = (String) this.attributes.get(key);
writer.write(key);
writer.write('='); writer.write('"');
@@ -2189,9 +2189,9 @@
writer.write('/'); writer.write('>');
} else {
writer.write('>');
- Enumeration enum = this.enumerateChildren();
- while (enum.hasMoreElements()) {
- XMLElement child = (XMLElement) enum.nextElement();
+ Enumeration myEnum = this.enumerateChildren();
+ while (myEnum.hasMoreElements()) {
+ XMLElement child = (XMLElement) myEnum.nextElement();
child.write(writer);
}
writer.write('<'); writer.write('/');
30 changes: 30 additions & 0 deletions dev-java/laf-plugin/laf-plugin-0.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Look'n'feel Java library"
HOMEPAGE="http://laf-plugin.dev.java.net/"
SRC_URI="mirror://gentoo/${P}-src.tar.bz2 -> ${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND=">=virtual/jdk-1.6"
RDEPEND=">=virtual/jre-1.6"

S="${WORKDIR}/${P}"

PATCHES=( "${FILESDIR}/${P}-enum.patch" )

src_prepare() {
default
}

src_install() {
java-pkg-simple_src_install
}

0 comments on commit a96d532

Please sign in to comment.