Skip to content

Commit

Permalink
dev-python/PyPDF2: bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20
  • Loading branch information
Ian Delaney committed Aug 16, 2015
1 parent 1a17d75 commit aa18370
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/PyPDF2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST PyPDF2-1.24.tar.gz 59891 SHA256 aca40d5155524120fceaf2eb4ae054480b8a2b6ffcfa0a2e77e3e45666428c64 SHA512 91a9338b0338eee1cfddc25dd0f21494f73696e630b08a71ff9195fe7b0fc77cf6c07b38a0c6aa4856536be6fe0a474c3b292c13fdd0187b62cb8848e69b29f9 WHIRLPOOL b5d33c209d5e0ce7d2d567d9266faacbbc6c1e49ac714e0063eeeb3879f400482a3fa887bd165b364a7216b4240b5236dec1954683ade632ea802a36a5272303
DIST PyPDF2-1.25.1.tar.gz 194181 SHA256 43d324f70f8994c25a08e6edc02ec2d5c1e84c9231d3537f785b3f97641182eb SHA512 0cb43d4557d17ec82298ceabce5c4731438a0e16ad6c6b2abc54204a3d93373a46b86c995e9b39cec475de1dce325d552da17ce36de3733c7b0471779e3b0899 WHIRLPOOL 71467c2b43d462fde0486a1ca9c300bc3c6b048c21450affa6f09e3b2a5b893b5125fec10cb6ac9d1c1157fdfacdcf5c5b6ed37a1e3742f95595b3f76bd9868a
29 changes: 29 additions & 0 deletions dev-python/PyPDF2/PyPDF2-1.25.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/PyPDF2/PyPDF2-1.24.ebuild,v 1.3 2015/03/08 23:38:15 pacho Exp $

EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1

DESCRIPTION="Python library to work with pdf files"
HOMEPAGE="http://pypi.python.org/pypi/${PN}/ https://github.com/mstamy2/PyPDF2"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"

# https://github.com/mstamy2/PyPDF2/issues/216
RESTRICT="test"

python_test() {
"${PYTHON}" -m unittest Tests.tests
}

python_install_all() {
use examples && local EXAMPLES=( Sample_Code/. )
distutils-r1_python_install_all
}

0 comments on commit aa18370

Please sign in to comment.