Skip to content

Commit

Permalink
dev-vcs/repo: version bump to 2.17
Browse files Browse the repository at this point in the history
Signed-off-by: Mike Frysinger <[email protected]>
  • Loading branch information
vapier committed Oct 2, 2021
1 parent 42cec65 commit aa3c2b3
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-vcs/repo/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST repo-2.14 44203 BLAKE2B 72094daad380b3a03c9dca488e0bfc2a64bcaed5b025490c07fdc627eaae825bd71d0a8aafca5307dd4a0fecf59d530e7a692b030699a2cdc34cbec569076383 SHA512 37bc4e5b63e2cb1567633708f9680817c346b8105ca495538036aad87fe278f3ab5143f0f57fd40d4051de8016cc785648e9f0b65ebf2430677f037030f71343
DIST repo-2.15 44704 BLAKE2B 6d90cecb4d748f7fb3febec95e16ed1638112a945aa36f7d7cc12232cdf4bcd66d286aa1054fd23de5ae7e896ac52c05465778aaec759e5d0251227deb220d18 SHA512 e6aad90f6058f4e5750ce44f8951ac4df39dd39c1615d7f68670a0b8ac5007f52e3bb6219d6ca0842908ef6c87843c6fd655b3b2a47fcf410e2a74d47a334d34
DIST repo-2.17 44944 BLAKE2B 8f5db36d6acedd9c79fca1c9fe5a29e4da9b483d4f356d8ad88d6510f13ec7ff8200723c836ff7ac17419e571c2c4970182385a248b8005aaae1cbd4d93d3423 SHA512 b8d459c619f537d8afce00c78594027ef983e31f1bf47341d3388e39da4505270fa07f8c93b1ab5110795c1b6b952f01f48f0e18ce15e8126a484c98fd73e8c8
DIST repo-511a0e54f5801a3f36c00fac478a596d83867d10-bash-completion.sh.base64 4280 BLAKE2B 6c369d36176d5bd4d3f4ed4df39bbd6542022dd186375bd05a978889c574819e3328d19c7dac2982233614786078f73bfd1f0c80aa7c0c6c79bdfab776ed6e39 SHA512 f484bee79c3724a6daf8a69b3df80feef3c6aaad3bfb49443caabc52735dd7f3b0fcb3ad4b7480bc020c9b4cac2f3b044693ef761df6fc9d34e854289baf1f3d
DIST repo-v2.17-bash-completion.sh.base64 5736 BLAKE2B 59c357d76feb176b7c64791ffb838ab522179c7e05d1a1cca6e121c9c908cdbccc49f177951986470806302b881b39ab44710b66b0a6a8c9643d4a647841eddf SHA512 9bc4f57d58222297f53e6dcbed1b895e8d0a90558be58a423243c886cb5cfad11c32e7c599b2e237e3f53b2857f8441ddb476484189135b71f52ca7250dfaf62
42 changes: 42 additions & 0 deletions dev-vcs/repo/repo-2.17.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
# of the repo project. The launcher only gets a new update when changes are
# made in it.

EAPI="7"

PYTHON_COMPAT=( python3_{7..9} )

inherit bash-completion-r1 python-r1

# This file rarely changes, so track it independently.
COMP_VER="v2.17"
COMP_NAME="${PN}-${COMP_VER}-bash-completion.sh.base64"

DESCRIPTION="Google tool for managing git, particularly multiple repos"
HOMEPAGE="https://gerrit.googlesource.com/git-repo"
SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}
https://gerrit.googlesource.com/git-repo/+/${COMP_VER}/completion.bash?format=TEXT -> ${COMP_NAME}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
!app-admin/radmind
!dev-util/repo"

S=${WORKDIR}

src_unpack() {
base64 -d <"${DISTDIR}/${COMP_NAME}" >completion.bash || die
}

src_install() {
python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
newbashcomp completion.bash ${PN}
}

0 comments on commit aa3c2b3

Please sign in to comment.