Skip to content

Commit

Permalink
app-shells/thefuck: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
mrueg committed Mar 13, 2016
1 parent c33ed76 commit aa66ef2
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/thefuck/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST thefuck-3.4.tar.gz 781871 SHA256 ce98f6219e64b6e9e9f2cad22fa1bac121a5d79f3a530d9b2cb8bc61a629904f SHA512 8d78a91d3320230fbd47bdd79ad352bf7b5c9bc2f7d41bd8382177e650f9e01d1660c0620e443a3bb7e36c193c73ea3aaaab5f2e5bc1b469b8d919602b8c1d4f WHIRLPOOL 44408d18caae4c41e51360cdce720d2514f4288fbc2a70f7894718b2c14caa9c0baa7df3d28501e3421be2ff7e69a7293f2b4822003e1f7cacbaa55a1b1e8b78
DIST thefuck-3.5.tar.gz 782640 SHA256 eaa6b6466634ab4c87506a1404871af5bfd013043157b335165a63da3b14d90e SHA512 b1d5c542e25dc88ddceef98cd067f3bd48023c4ca5ee33ea61c76ad089ca85d0f440b212633ad99f9e7caa2ca56da8ba236c481cacfb50fd07dec44e896a0a71 WHIRLPOOL dd8e7bde96b45e61874f519db52550f82aa269a1e0df94271bb58bd6605e1165e1e6e8682c257ca8129ebff2955c0014b71a0191a360ad035d4de2e17fab4ba8
35 changes: 35 additions & 0 deletions app-shells/thefuck/thefuck-3.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=(python{2_7,3_4})

inherit distutils-r1

DESCRIPTION="Magnificent app which corrects your previous console command"
HOMEPAGE="https://github.com/nvbn/thefuck"
SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

LICENSE="MIT"
SLOT="0"
IUSE="test"

RDEPEND="dev-python/pathlib[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"

src_prepare() {
sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
distutils-r1_src_prepare
}

python_test() {
py.test || die
}

0 comments on commit aa66ef2

Please sign in to comment.