Skip to content

Commit

Permalink
net-libs/rabbitmq-c: bump to v0.9.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Dec 19, 2018
1 parent b8de633 commit aaf111c
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/rabbitmq-c/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rabbitmq-c-v0.8.0.zip 249220 BLAKE2B 171ae0ffc093851089f4dc11cc1e8ef25ae90cbb0cce75ffb93c04a765b7d195e5bde8bbdaa4ce0c598c7f4bb291ed204d157443ed927db373a89f8ab9e7ebc0 SHA512 e386979ce1bc05c02cda06e8582981e0df25f9b31ca950f8a921bd2b249020f751ba65a6f38b8f5ba0be1b3e89492b29b72c6cd1d5ed3d6f19440799d6419ba6
DIST rabbitmq-c-v0.9.0.zip 227245 BLAKE2B ea37e0a9734bc7a8923cab880a9e150f055bab83bb79eb793882a1d435e6e435fbf4610034235f858d0e4d20978287b9432b312c8c3eea5e588655dc2f831554 SHA512 0cac0e26b4caca3de22b468200a20c38c8ace1a824442faa0855d93922b0c3a649fc2067366f6694eca0be635187ca9a9cfe47643472f4abb3d67028768f49fb
54 changes: 54 additions & 0 deletions net-libs/rabbitmq-c/rabbitmq-c-0.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit cmake-utils

DESCRIPTION="RabbitMQ C client"
HOMEPAGE="https://github.com/alanxz/rabbitmq-c"

if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/alanxz/${PN}.git"
else
SRC_URI="https://github.com/alanxz/${PN}/archive/v${PV}.zip -> ${PN}-v${PV}.zip"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi

LICENSE="MIT"
SLOT="0/4"
IUSE="doc libressl test +ssl static-libs tools"

REQUIRED_USE="test? ( static-libs )"

RDEPEND="ssl? (
libressl? ( dev-libs/libressl:= )
!libressl? ( dev-libs/openssl:0= )
)
tools? ( dev-libs/popt )"
DEPEND="${DEPEND}
doc? ( app-doc/doxygen )
tools? ( app-text/xmlto )"
DOCS=( AUTHORS README.md THANKS TODO )

src_configure() {
mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DBUILD_API_DOCS=$(usex doc)
-DBUILD_STATIC_LIBS=$(usex static-libs)
-DBUILD_TESTS=$(usex test)
-DBUILD_TOOLS=$(usex tools)
-DBUILD_TOOLS_DOCS=$(usex tools)
-DENABLE_SSL_SUPPORT=$(usex ssl)
)
cmake-utils_src_configure
}

src_test() {
pushd "${BUILD_DIR}" > /dev/null || die

# Skip "basic" test which requires running local rabbitmq-server instance,
# see https://github.com/alanxz/rabbitmq-c/issues/530
ctest -v -E basic || die
}

0 comments on commit aaf111c

Please sign in to comment.