Skip to content

Commit

Permalink
app-shells/heirloom-sh: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
monsieurp committed Feb 24, 2017
1 parent 773a84e commit ab82b16
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit flag-o-matic toolchain-funcs

# slightly broken
RESTRICT="test"

DESCRIPTION="Heirloom Bourne Shell, derived from OpenSolaris code SVR4/SVID3"
HOMEPAGE="http://heirloom.sourceforge.net/sh.html"
SRC_URI="mirror://sourceforge/heirloom/${P}.tar.bz2"

LICENSE="CDDL"
SLOT="0"
KEYWORDS="~amd64 ~x86"

src_compile() {
append-cppflags -D_GNU_SOURCE
emake \
"CFLAGS=${CFLAGS}" \
"CPPFLAGS=${CPPFLAGS}" \
"LDFLAGS=${LDFLAGS}" \
"LARGEF=" \
"CC=$(tc-getCC)"
}

src_install() {
exeinto /bin
newexe sh jsh
newman sh.1 jsh.1
}

0 comments on commit ab82b16

Please sign in to comment.