Skip to content

Commit

Permalink
app-shells/fish: Bump to version 3.1.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Apr 27, 2020
1 parent 9ca86cb commit ad2c828
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/fish/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST fish-2.7.1.tar.gz 5760550 BLAKE2B 71568a3a17f4222b05a314464a61fceb241409a7d42c46249486ca742ef0cf990c46d693bcc22521c18f58a558e6aab35759d0da6eb62ee6611a2a7946fe714d SHA512 45ee3453404c5d6c56d307b4cd19197de862f9f42d7fa06461acec56dea7146db5675cf6419dd5f72e939b3e4b1955d3761098df1de89a8cebe47645eb6f7a4b
DIST fish-3.0.2.tar.gz 6477869 BLAKE2B fedc8bd5fd6d7856b695207ce9ac7a5a47f0e3c211d2aa2151a7a3c1bd944b3cf5c86ddf8b6e4c4d3499bb72d4ede64886706e05a44786d70c665b4ffb85369f SHA512 cd4a8e6a0d7770ef17e92d3d20ea23e754b9fa53e5ee5459ab5838fcbbcac69544ca2f83551e93a004b140cc14ec556860a711ce216197753c1704901518c9c3
DIST fish-3.1.0.tar.gz 6810953 BLAKE2B 93143d9a2496b569ff6f73f4332beb3b738b7b03ede5357b0d7cc02a0c7da99852eb44a61c16d2524396ae37e76a1b439d708ae01488e79b0e03ba72504ebdec SHA512 143e462b5329790fa9834e135109e1397c3525756a0209d0ec68a53f7d2a1f581cd45fbbdcde6a5b53dff447da18ed6a62277993d851e7b18ef7f1a6b6d49cff
DIST fish-3.1.1.tar.gz 6816063 BLAKE2B 0b390ea4d887b392170e6003d7b02417ade7c6015348b201b2af6ce1a5a7f8b764057208e98c73c7616114863806098dab9386726dfdf606ba53d8d74d64ca6d SHA512 edda6739427b7ba140445430b93388ada116c7c9064da7deb6924f2ace3832de7da8e1e20730bfd12b081ab1cc4b7ffaf8f60c5ee5204f59e65889e30c913eae
71 changes: 71 additions & 0 deletions app-shells/fish/fish-3.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake readme.gentoo-r1

DESCRIPTION="Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"

MY_PV="${PV/_beta/b}"
MY_P="${PN}-${MY_PV}"

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
else
SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi

LICENSE="GPL-2"
SLOT="0"

IUSE="doc nls test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-libs/libpcre2-10.32[pcre32]
sys-libs/ncurses:0=[unicode]
"

DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
nls? ( sys-devel/gettext )
test? ( dev-tcltk/expect )
"

S="${WORKDIR}/${MY_P}"

src_prepare() {
# workaround for https://github.com/fish-shell/fish-shell/issues/4883
sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
cmake/Tests.cmake || die
cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DCURSES_NEED_NCURSES=ON
-DBUILD_DOCS="$(usex doc)"
-DWITH_GETTEXT="$(usex nls)"
)
cmake_src_configure
}

src_install() {
cmake_src_install
keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
readme.gentoo_create_doc
}

src_test() {
cmake_build -j1 test
}

pkg_postinst() {
readme.gentoo_print_elog
}

0 comments on commit ad2c828

Please sign in to comment.