Skip to content

Commit

Permalink
app-admin/kube-bench: Version bump to 0.0.14
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
mrueg committed Apr 10, 2018
1 parent fac6bb8 commit ad6cf04
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/kube-bench/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -22,3 +22,4 @@ DIST github.com-spf13-pflag-4c012f6dcd9546820e378d0bdda4d8fc772cdfea.tar.gz 4007
DIST github.com-spf13-viper-25b30aa063fc18e48662b86996252eabdcf2f0c7.tar.gz 30849 BLAKE2B 8e66dbb5c90c47e66ea72848d86602861791fe3198ce6cde5ea87330f15dd19cdd249788bebc31b2a66577c20edeef01c8beb59a4140d57167c4b13d33118a04 SHA512 4acd37411683d753d81d839e83c2257bc424c42b8e295868da84cb045db131be063b0e5a0fb88c587332582f356186659d5a181e65ae1838e868576543c1fecd
DIST kube-bench-0.0.11.tar.gz 175361 BLAKE2B 844e252ccf270561154f1bab9c02144ff10a0594d71a2cd6e63a828ecabee2132a8756848642c475bfa705f360a5d69812519f705ad7c4717d5a4bf9d84cbd1b SHA512 52debf132bae38588f0b49c54f07d2550fc254665a0549b7369fb34b6884724624a44d14e6ea1120dc0c2586f2647b56d30e66695f2d8829c3f26ec5f2443f38
DIST kube-bench-0.0.12.tar.gz 175549 BLAKE2B f909caa4735ed4c6698b756bea24ffbf176c1ff111130ed17f421c894dbefbec28e88305701ab42e40c255dbc4f4a748db2d3ede29951cf38715afd1f61cefe6 SHA512 c91de2ca9b1cb5769885dfb7691c95680f2a82d22e0df3b0060135281c3e42a8824302ec14b3f462ad2f76fa39c32bf93721428c2f3e9a50dbebcacfc6d840a4
DIST kube-bench-0.0.14.tar.gz 175554 BLAKE2B 08625739f4128ba0a19ecd8088c49ca9dbc1637393771ae4a2d086f167028047902c8be998e86f10050dd7dfa948ace2c9ae8806c3329935c92da1450fb128c4 SHA512 d07cc3759e8d11908791df983434607a798b3f77e8520ca03445528fab19025aee2f80c6e2386a73090caf37e7f7fb1e9c47a6a585023c7b5f80b4dceeb12332
59 changes: 59 additions & 0 deletions app-admin/kube-bench/kube-bench-0.0.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGO_PN="github.com/aquasecurity/kube-bench"

EGO_VENDOR=(
"github.com/fatih/color 570b54cabe6b8eb0bc2dfce68d964677d63b5260"
"github.com/fsnotify/fsnotify 4da3e2cfbabc9f751898f250b49f2439785783a1"
"github.com/golang/glog 23def4e6c14b4da8ac2ed8007337bc5eb5007998"
"github.com/hashicorp/hcl 23c074d0eceb2b8a5bfdbb271ab780cde70f05a8"
"github.com/inconshreveable/mousetrap 76626ae9c91c4f2a10f34cad8ce83ea42c93bb75"
"github.com/jinzhu/gorm 5174cc5c242a728b435ea2be8a2f7f998e15429b"
"github.com/jinzhu/inflection 1c35d901db3da928c72a72d8458480cc9ade058f"
"github.com/lib/pq 83612a56d3dd153a94a629cd64925371c9adad78"
"github.com/magiconair/properties 49d762b9817ba1c2e9d0c69183c2b4a8b8f1d934"
"github.com/mattn/go-colorable 5411d3eea5978e6cdc258b30de592b60df6aba96"
"github.com/mattn/go-isatty 57fdcb988a5c543893cc61bce354a6e24ab70022"
"github.com/mitchellh/mapstructure 06020f85339e21b2478f756a78e295255ffa4d6a"
"github.com/pelletier/go-toml 0131db6d737cfbbfb678f8b7d92e55e27ce46224"
"github.com/spf13/afero 57afd63c68602b63ed976de00dd066ccb3c319db"
"github.com/spf13/cast acbeb36b902d72a7a4c18e8f3241075e7ab763e4"
"github.com/spf13/cobra 7b2c5ac9fc04fc5efafb60700713d4fa609b777b"
"github.com/spf13/jwalterweatherman 12bd96e66386c1960ab0f74ced1362f66f552f7b"
"github.com/spf13/pflag 4c012f6dcd9546820e378d0bdda4d8fc772cdfea"
"github.com/spf13/viper 25b30aa063fc18e48662b86996252eabdcf2f0c7"
"golang.org/x/sys e24f485414aeafb646f6fca458b0bf869c0880a1 github.com/golang/sys"
"golang.org/x/text e19ae1496984b1c655b8044a65c0300a3c878dd3 github.com/golang/text"
"gopkg.in/yaml.v2 c95af922eae69f190717a0b7148960af8c55a072 github.com/go-yaml/yaml"
)

inherit golang-build golang-vcs-snapshot bash-completion-r1

ARCHIVE_URI="https://github.com/aquasecurity/kube-bench/archive/v${PV}.tar.gz -> ${P}.tar.gz
${EGO_VENDOR_URI}"
KEYWORDS="~amd64"

DESCRIPTION="Kubernetes Bench for Security runs the CIS Kubernetes Benchmark"
HOMEPAGE="https://github.com/aquasecurity/kube-bench"
SRC_URI="${ARCHIVE_URI}"

LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

RESTRICT="test"

src_compile() {
pushd src/${EGO_PN} || die
GOPATH="${S}" go build -o ${PN} . || die
popd || die
}

src_install() {
dobin src/${EGO_PN}/${PN}
insinto /etc/kube-bench
doins -r src/${EGO_PN}/cfg
}

0 comments on commit ad6cf04

Please sign in to comment.