Skip to content

Commit

Permalink
x11-misc/alock: Remove Google Code upstream
Browse files Browse the repository at this point in the history
Removed Google Code upstream, added "doc" USE flag, which pulls in
app-text/asciidoc to generate the manpage.

Package-Manager: portage-2.3.2
  • Loading branch information
Daniel Campbell committed Nov 9, 2016
1 parent 7f84e29 commit ad73e1d
Show file tree
Hide file tree
Showing 3 changed files with 80 additions and 1 deletion.
1 change: 1 addition & 0 deletions x11-misc/alock/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST alock-94.zip 93058 SHA256 7f283b775902b5b3bdebd498e3d295408a0e603c5e1ff4863806d3844e3c70ce SHA512 3f321ebbb5526f6d1f66c7e80d2e0126ca15cb614b8ffd2ebbb824bff8d87a1eb4d8db1b33edb294398c9919d99e9983a2db7555a1330e3cb5307be369ef0e50 WHIRLPOOL 555ee700dbe1b6c376344ee1fe72bfc75c3d135c501a91f42f46e3904fd52eebcdb0f6fc2705abc7e5ed9c748d4a9003d58b419a41ffd9e070965e47ef98109a
DIST alock-svn-94.tar.bz2 68140 SHA256 37938b56588e0e9bdfdf52097bccd000f992ea725c87cd8c8b3ea4df847e8f26 SHA512 91166bf6ca4fa715754048b9ac39367f691dbaef7ac39cbe32a92541a00cb522de9070b35bb70646f53cb7f32f7a8028455a5c7bcb0729c6948a089304a26a64 WHIRLPOOL 5c28a8ca3da7b4d31c9fa4994f1ddda3a11a73ea7719d96238b41651bf80a4be99bd7b5f159264ed0495ebc63d20e220769ffe205afb523b49c2c7bcbfadd932
76 changes: 76 additions & 0 deletions x11-misc/alock/alock-94-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils toolchain-funcs

# we need this since there are no tagged releases yet
COMMIT_ID="fd3ea42bda834a6b6f023291be23eb32f117f1b4"
DESCRIPTION="locks the local X display until a password is entered"
HOMEPAGE="http://darkshed.net/projects/alock
https://github.com/mgumz/alock"
SRC_URI="https://github.com/mgumz/${PN}/archive/${COMMIT_ID}.zip -> ${P}.zip"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc imlib pam"

S="${WORKDIR}/${PN}-${COMMIT_ID}"

DEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm
x11-libs/libXrender
x11-libs/libXcursor
imlib? ( media-libs/imlib2[X] )
pam? ( virtual/pam )
doc? ( app-text/asciidoc )"
RDEPEND="${DEPEND}"

src_prepare() {
epatch "${FILESDIR}"/implicit_pointer_conversion_fix_amd64.patch
epatch "${FILESDIR}"/check-setuid.patch
epatch "${FILESDIR}"/tidy-printf.patch
epatch "${FILESDIR}"/fix-aliasing.patch
epatch "${FILESDIR}"/no-xf86misc.patch
eapply_user
}

src_configure() {
tc-export CC

econf \
--prefix=/usr \
--with-all \
$(use_with pam) \
$(use_with imlib imlib2)
}

src_compile() {
# xmlto isn't required, so set to 'true' as dummy program
# alock.1 is suitable for a manpage
emake XMLTO=true
}

src_install() {
dobin src/alock
if use doc; then
# We need to generate the manpage...
a2x -d manpage -f manpage ./"${PN}".txt || die "a2x conversion failed."
doman alock.1
dodoc {CHANGELOG,README,TODO}.txt
fi

insinto /usr/share/alock/xcursors
doins contrib/xcursor-*

insinto /usr/share/alock/bitmaps
doins bitmaps/*

if ! use pam; then
# Sets suid so alock can correctly work with shadow
fperms 4755 /usr/bin/alock
fi
}
4 changes: 3 additions & 1 deletion x11-misc/alock/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,9 @@
<email>[email protected]</email>
<name>Mathias Gumz</name>
</maintainer>
<remote-id type="google-code">alock</remote-id>
<remote-id type="github">mgumz/alock</remote-id>
</upstream>
<use>
<flag name="doc">Build and install manpage with <pkg>app-text/asciidoc</pkg>.</flag>
</use>
</pkgmetadata>

0 comments on commit ad73e1d

Please sign in to comment.