Skip to content

Commit

Permalink
sys-auth/seatd: New package
Browse files Browse the repository at this point in the history
Signed-off-by: Haelwenn (lanodan) Monnier <[email protected]>
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
lanodan authored and FuzzyGophers committed Nov 11, 2020
1 parent 665fbaf commit ad89812
Show file tree
Hide file tree
Showing 5 changed files with 111 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-auth/seatd/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST seatd-0.4.0.tar.gz 34242 BLAKE2B 295ee18736b5f7e1b06013d00514321aad5fb09c285690cfbd78833a9efbfeb2cfaef69c075fb096fedaac42ff249ee1a43593dbd03132770c1be293ffe7ddc1 SHA512 498ab4040c19ff90842bf82f580ba24c2c98e0aded7ba636dcffc80f6bfd8869eec3e87e784455b66e2b69786b2fc6e7315b2867effa825440759d58e391378c
4 changes: 4 additions & 0 deletions sys-auth/seatd/files/seatd.initd
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
#!/sbin/openrc-run
supervisor=supervise-daemon
command="seatd"
command_args="-g video"
12 changes: 12 additions & 0 deletions sys-auth/seatd/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Haelwenn (lanodan) Monnier</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>
47 changes: 47 additions & 0 deletions sys-auth/seatd/seatd-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="Minimal seat management daemon and universal library"
HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
if [[ ${PV} == 9999 ]]; then
inherit git-r3

EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
else
KEYWORDS="~amd64"
SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="MIT"
SLOT="0/1"
IUSE="elogind systemd"
REQUIRED_USE="?? ( elogind systemd )"

DEPEND="
elogind? ( sys-auth/elogind )
systemd? ( sys-apps/systemd )
"
RDEPEND="${DEPEND}"
BDEPEND=">=app-text/scdoc-1.9.7"

src_configure() {
local emesonargs=(
-Dman-pages=enabled
)

if use elogind || use systemd; then
emesonargs+=( -Dlogind=enabled )
else
emesonargs+=( -Dlogind=disabled )
fi

meson_src_configure
}

src_install() {
meson_src_install
newinitd "${FILESDIR}/seatd.initd" seatd
}
47 changes: 47 additions & 0 deletions sys-auth/seatd/seatd-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="Minimal seat management daemon and universal library"
HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
if [[ ${PV} == 9999 ]]; then
inherit git-r3

EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
else
KEYWORDS="~amd64"
SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="MIT"
SLOT="0/1"
IUSE="elogind systemd"
REQUIRED_USE="?? ( elogind systemd )"

DEPEND="
elogind? ( sys-auth/elogind )
systemd? ( sys-apps/systemd )
"
RDEPEND="${DEPEND}"
BDEPEND=">=app-text/scdoc-1.9.7"

src_configure() {
local emesonargs=(
-Dman-pages=enabled
)

if use elogind || use systemd; then
emesonargs+=( -Dlogind=enabled )
else
emesonargs+=( -Dlogind=disabled )
fi

meson_src_configure
}

src_install() {
meson_src_install
newinitd "${FILESDIR}/seatd.initd" seatd
}

0 comments on commit ad89812

Please sign in to comment.