Skip to content

Commit

Permalink
dev-php/xdebug: bump to v2.9.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Apr 29, 2020
1 parent c9ff327 commit adf8597
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/xdebug/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST xdebug-2.6.1.tgz 283961 BLAKE2B 4478d591591102a9efa248820831e4d43d89eb9b803
DIST xdebug-2.9.2.tar.gz 432926 BLAKE2B 3d524e5a1aec0621389970e80cdc23dfd40a17113ad09294de65290531cac1b33cbc248be341e0c29d9ebb825be25dd6d6b65b9ebcca0c2c3ca43784d2bf9d50 SHA512 ef1780f34572ea47de7e107b5120a0ec640e0ce4ec2a1c98c128c4f69ec9916879d82b11d2eb94d9630ed27b2d20afec7ccda9f79040d47dbaba9e1933331d03
DIST xdebug-2.9.3.tar.gz 434509 BLAKE2B dd6a42518e9100db32a4858f131fc5cd8f6ed715bbf16a8d20fbba40b7503a897dd6d010af81d0001301b999a64b5d67b193c72a456e396b54ddd61823556d57 SHA512 ec77a036e622a867d4ef46aa844d4d3a2b9ce04c8ce64300451f50539c9889dd10cec96b18292268540e2aee0260caeffbd9fa03abd24891b4c9fe68d02598d5
DIST xdebug-2.9.4.tar.gz 434622 BLAKE2B bd0d0c6a46867ffba88693f142346d11b5abfab3254c549b74ff9169536c42903b1fb1cb94c3344060590b63e287878ea05c6ef7ad8343234bada3857e0dbe75 SHA512 cf19fb9fd12c32e04c18f296694d0667dfe6e14617da932804d17526c88ab19dd2307ad43d036a8c0cb1f871a964523473879da8815f346faf83ec3b9e3952e3
DIST xdebug-2.9.5.tar.gz 434947 BLAKE2B 08fd7cc92880c9b00180d495341fc7e54998cf3c2294b824d94c3c4ed982ae5b087084b776bcc4f8f4e1aa420396c803d330bc76748cf972cccab4e3f1416d38 SHA512 2a937d08468d3a2963559a56bdf9c9aa6ede3f0ee63797aa14831bcab33a5ede65b87791171a0c794eefdfcffa65bb4d0c06b5377fe03ade65f4defa6e328c72
42 changes: 42 additions & 0 deletions dev-php/xdebug/xdebug-2.9.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
PHP_EXT_NAME="xdebug"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="yes"
PHP_EXT_INIFILE="2.6.0-xdebug.ini"

USE_PHP="php7-2 php7-3 php7-4"

MY_PV="${PV/_/}"
MY_PV="${MY_PV/rc/RC}"

S="${WORKDIR}/${PN}-${MY_PV}"

inherit php-ext-source-r3

KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"

DESCRIPTION="A PHP debugging and profiling extension"
HOMEPAGE="https://xdebug.org/"
# Using tarball from GitHub for tests
#SRC_URI="https://pecl.php.net/get/${PN}-${MY_PV}.tgz"
SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Xdebug"
SLOT="0"
IUSE=""

DEPEND=""
RDEPEND="${DEPEND}
~dev-php/xdebug-client-${PV}"
DOCS=( README.rst CREDITS )
PHP_EXT_ECONF_ARGS=()

pkg_postinst() {
ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
ewarn "installed as a dependency, and not all users will want xdebug to be"
ewarn "enabled by default. If you want to enable it, you should edit the"
ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
ewarn "call xdebug_enable() in your code."
}

0 comments on commit adf8597

Please sign in to comment.