Skip to content

Commit

Permalink
games-emulation/mgba: Fixed compilation with imagemagick-7 (bug #610578)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed May 23, 2017
1 parent 805ded8 commit adf8d0f
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
59 changes: 59 additions & 0 deletions games-emulation/mgba/files/mgba-0.5.2-imagemagick7.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
From 2e3daaedc208824c9b8a54480bd614160cdda9e7 Mon Sep 17 00:00:00 2001
From: Vicki Pfau <[email protected]>
Date: Wed, 18 Jan 2017 12:51:05 -0800
Subject: [PATCH] Feature: Support ImageMagick 7

---
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38120827e..6be159915 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -322,6 +322,7 @@ if(HAVE_UMASK)
endif()

# Feature dependencies
+set(FEATURE_DEFINES)
set(FEATURES)
if(CMAKE_SYSTEM_NAME MATCHES .*BSD)
set(LIBEDIT_LIBRARIES -ledit)
@@ -431,11 +432,16 @@ if(USE_MAGICK)
list(APPEND FEATURE_SRC "${CMAKE_CURRENT_SOURCE_DIR}/src/feature/imagemagick/imagemagick-gif-encoder.c")
list(APPEND DEPENDENCY_LIB ${MAGICKWAND_LIBRARIES})
string(REGEX MATCH "^[0-9]+\\.[0-9]+" MAGICKWAND_VERSION_PARTIAL ${MagickWand_VERSION})
+ string(REGEX MATCH "^[0-9]+" MAGICKWAND_VERSION_MAJOR ${MagickWand_VERSION})
if(${MAGICKWAND_VERSION_PARTIAL} EQUAL "6.7")
set(MAGICKWAND_DEB_VERSION "5")
+ elseif(${MagickWand_VERSION} EQUAL "6.9.7")
+ set(MAGICKWAND_DEB_VERSION "-6.q16-3")
else()
set(MAGICKWAND_DEB_VERSION "-6.q16-2")
endif()
+ list(APPEND FEATURE_DEFINES MAGICKWAND_VERSION_MAJOR=${MAGICKWAND_VERSION_MAJOR})
+
set(CPACK_DEBIAN_PACKAGE_DEPENDS "${CPACK_DEBIAN_PACKAGE_DEPENDS},libmagickwand${MAGICKWAND_DEB_VERSION}")
endif()

@@ -595,7 +601,6 @@ if(USE_DEBUGGERS)
list(APPEND FEATURES DEBUGGERS)
endif()

-set(FEATURE_DEFINES)
foreach(FEATURE IN LISTS FEATURES)
list(APPEND FEATURE_DEFINES "USE_${FEATURE}")
endforeach()
diff --git a/src/feature/imagemagick/imagemagick-gif-encoder.h b/src/feature/imagemagick/imagemagick-gif-encoder.h
index 13505e6db..842cad942 100644
--- a/src/feature/imagemagick/imagemagick-gif-encoder.h
+++ b/src/feature/imagemagick/imagemagick-gif-encoder.h
@@ -15,7 +15,11 @@ CXX_GUARD_START
#define MAGICKCORE_HDRI_ENABLE 0
#define MAGICKCORE_QUANTUM_DEPTH 8

+#if MAGICKWAND_VERSION_MAJOR >= 7
+#include <MagickWand/MagickWand.h>
+#else
#include <wand/MagickWand.h>
+#endif

struct ImageMagickGIFEncoder {
struct mAVStream d;
4 changes: 4 additions & 0 deletions games-emulation/mgba/mgba-0.5.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -33,6 +33,10 @@ RDEPEND="
DEPEND="${RDEPEND}
>=dev-util/cmake-3.2.2"

PATCHES=(
"${FILESDIR}/${P}-imagemagick7.patch"
)

src_prepare() {
default

Expand Down

0 comments on commit adf8d0f

Please sign in to comment.