Skip to content

Commit

Permalink
app-emulation/bochs: Bump to version 2.6.8
Browse files Browse the repository at this point in the history
Address bug #551258

Thanks to Kobboi for reminding me and the initial patches.

Package-Manager: portage-2.2.23
  • Loading branch information
lu-zero committed Oct 31, 2015
1 parent afd0578 commit adff78a
Show file tree
Hide file tree
Showing 3 changed files with 91 additions and 4 deletions.
1 change: 1 addition & 0 deletions app-emulation/bochs/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST bochs-2.6.8.tar.gz 5075617 SHA256 79700ef0914a0973f62d9908ff700ef7def62d4a28ed5de418ef61f3576585ce SHA512 5e7438a6a09417cbc0b311810a485374bb9b10be452edd9daff0afacd487ada66f37b8189d4868d3420dae82ef6c38fe279d541d24f8a41bf1ca59359572e7bd WHIRLPOOL 798a40aafad7269e4708b443d6511d86236289b7b19b14d2ed33f2c80618b5b3251a7294c70433cfd0f63ebdbcf8d34fc4aa407f70c9874ff1ce2f226d72c4a0
DIST bochs-2.6.tar.gz 4212828 SHA256 65123e44a6d2c1148d741da025d16311b9ccd600ef268b911aba73c67eaf86e1 SHA512 506e7816c96caf56005c74df20d243aef111dded41b65dbf440844af3d49bc5987af333ef65a53f90de9fbdfc4d18e3e23fff1157ccb08bd95afff8fdbbcfba3 WHIRLPOOL 4598ad37b6792a001e3301770318c6a6d53bda98dc9a21337db4659573d8bf4ec64cf3376386f5e298dc25813c9bcc5e29b7a82383b96c1e2f82c77a75877001
86 changes: 86 additions & 0 deletions app-emulation/bochs/bochs-2.6.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

WX_GTK_VER=2.8

inherit eutils wxwidgets

DESCRIPTION="LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE="3dnow avx debugger doc gdb ncurses readline svga sdl +smp wxwidgets vnc X +x86-64"
REQUIRED_USE="avx? ( x86-64 )
gdb? ( !debugger !smp )
debugger? ( !gdb )"

RDEPEND="X? ( x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXpm )
sdl? ( media-libs/libsdl )
svga? ( media-libs/svgalib )
wxwidgets? ( x11-libs/wxGTK:2.8[X] )
readline? ( sys-libs/readline:= )
ncurses? ( sys-libs/ncurses:= )"

DEPEND="${RDEPEND}
doc? ( app-text/docbook-sgml-utils )
X? ( x11-proto/xproto )
sys-apps/sed
>=app-text/opensp-1.5"

src_prepare() {
sed -i "s:^docdir.*:docdir = ${EPREFIX}/usr/share/doc/${PF}:" \
Makefile.in || die
}

src_configure() {
use wxwidgets && \
need-wxwidgets unicode

econf \
--enable-all-optimizations \
--enable-idle-hack \
--enable-cdrom \
--enable-clgd54xx \
--enable-cpu-level=6 \
--enable-disasm \
--enable-e1000 \
--enable-gameport \
--enable-iodebug \
--enable-monitor-mwait \
--enable-ne2000 \
--enable-plugins \
--enable-pci \
--enable-pnic \
--enable-raw-serial \
--enable-sb16=linux \
--enable-usb \
--enable-usb-ohci \
--enable-usb-xhci \
--prefix=/usr \
--with-nogui \
$(use_enable 3dnow) \
$(use_enable avx) \
$(use_enable debugger) \
$(use_enable doc docbook) \
$(use_enable gdb gdb-stub) \
$(use_enable readline) \
$(use_enable smp) \
$(use_enable x86-64) \
$(use_with ncurses term) \
$(use_with sdl) \
$(use_with svga) \
$(use_with vnc rfb) \
$(use_with wxwidgets wx) \
$(use_with X x) \
$(use_with X x11) \
${myconf}
}
8 changes: 4 additions & 4 deletions app-emulation/bochs/bochs-2.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=4
EAPI=5

WX_GTK_VER=2.8

Expand All @@ -27,8 +27,8 @@ RDEPEND="X? ( x11-libs/libICE
sdl? ( media-libs/libsdl )
svga? ( media-libs/svgalib )
wxwidgets? ( x11-libs/wxGTK:2.8[X] )
readline? ( sys-libs/readline )
ncurses? ( sys-libs/ncurses )"
readline? ( sys-libs/readline:= )
ncurses? ( sys-libs/ncurses:= )"

DEPEND="${RDEPEND}
doc? ( app-text/docbook-sgml-utils )
Expand Down

0 comments on commit adff78a

Please sign in to comment.