Skip to content

Commit

Permalink
app-emulation/free42: Bump to version 1.5.10
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
Chema Alonso Josa committed Sep 24, 2016
1 parent 47244d4 commit ae20937
Show file tree
Hide file tree
Showing 4 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/free42/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST free42-1.5.10.tgz 22616956 SHA256 960d94cce3d67047d8968b4ee8b4d324bf1257002d67f971bd1f6e2552a870d1 SHA512 dfdcbdb051aa7cf7a60c27e44ae8dc5458dd418e08cd71e79eff443d09f8021efacc87e06531f312521e5b1f5af0aa72e77b0ce18b8d657499ad174b6a12578e WHIRLPOOL 8324418ab0047e05136937aa6741a4faa518f39eae203eec181958fdc6aa42f577c66716deb81b0dc6d833f79e4e49cfda37fc80e3917f0157583feac1b66985
DIST free42-1.5.7.tgz 8159655 SHA256 63c868880e0c18374f4b309dc19e2ea36b9463471d2d77563f53036eea645316 SHA512 fb18712643f73388512fc4dc069d55ef3597f5e6a4e1b47bcd12ab05224027c4ec981ade2398fd8c1e4534003ee6c4de2b7402bade66a3dbe90a46299e7132a3 WHIRLPOOL 0504da8589d3dbf9270a914b2cb6ad86982b926f40abee43d6bbe3f8ec997efe8b0ae50b9d61952e5acd3f2a70d34e16cf0e665cec06d555b0c92438c7a32a43
DIST free42-1.5.8.tgz 45400324 SHA256 f8ffa54a5f77b5061e1a983962e989fc6679f7e128d996a0550922e366855f2f SHA512 1abaeea314b55f456b65eef530fe692534d92dde95876982c6df1715853055632a4a2305774dc691ca0af28632a393d8d9872bd86353c09d57d2dc8a0ef6cfe2 WHIRLPOOL 9b0abef9d548f09e567e8debe15f9a0635038d6ef655a64885ebc02eb241a0f577ca40b4bdc39c881fe8b2c6f4d97e5575c715a05ccc06df37f90bc5d28d16e8
12 changes: 12 additions & 0 deletions app-emulation/free42/files/free42-1.5.10-fix-build-intel-lib.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -Nuar a/gtk/build-intel-lib.sh b/gtk/build-intel-lib.sh
--- a/gtk/build-intel-lib.sh 2016-09-04 18:56:12.000000000 +0200
+++ b/gtk/build-intel-lib.sh 2016-09-24 19:39:49.284126118 +0200
@@ -4,7 +4,7 @@
cd IntelRDFPMathLib20U1
patch -p0 <../intel-lib-linux.patch
cd LIBRARY
-make CC=gcc CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0
+make A=a CC=gcc CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0
mv libbid.a ../../gcc111libbid.a
cd ../..
( echo '#ifdef FREE42_FPTEST'; echo 'const char *readtest_lines[] = {'; tr -d '\r' < IntelRDFPMathLib20U1/TESTS/readtest.in | sed 's/^\(.*\)$/"\1",/'; echo '0 };'; echo '#endif' ) > readtest_lines.cc
38 changes: 38 additions & 0 deletions app-emulation/free42/files/free42-1.5.10-fix-makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
diff -Nuar a/gtk/Makefile b/gtk/Makefile
--- a/gtk/Makefile 2016-09-04 18:56:12.000000000 +0200
+++ b/gtk/Makefile 2016-09-24 16:13:34.824116365 +0200
@@ -15,11 +15,10 @@
# along with this program; if not, see http://www.gnu.org/licenses/.
###############################################################################

-CFLAGS = -MMD \
+CFLAGS := -MMD \
-Wall \
-Wno-parentheses \
-Wno-write-strings \
- -g \
-I/usr/X11R6/include \
$(shell pkg-config --cflags gtk+-2.0) \
-DVERSION="\"$(shell cat ../VERSION)\"" \
@@ -27,14 +26,16 @@
-DDECIMAL_GLOBAL_ROUNDING=1 \
-DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
-DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
- -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
+ ${CFLAGS}

-CXXFLAGS = $(CFLAGS) \
+CXXFLAGS := $(CFLAGS) \
-fno-exceptions \
-fno-rtti \
- -D_WCHAR_T_DEFINED
+ -D_WCHAR_T_DEFINED \
+ ${CXXFLAGS}

-LDFLAGS = -L/usr/X11R6/lib
+LDFLAGS := -L/usr/X11R6/lib ${LDFLAGS}
-LIBS = gcc111libbid.a -lXmu $(shell pkg-config --libs gtk+-2.0)
+LIBS = gcc111libbid.a -lX11 -ldl -lXmu $(shell pkg-config --libs gtk+-2.0)

ifeq "$(shell uname -s)" "Linux"
47 changes: 47 additions & 0 deletions app-emulation/free42/free42-1.5.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils toolchain-funcs

DESCRIPTION="An HP-42S Calculator Simulator"
HOMEPAGE="http://thomasokken.com/free42/"
SRC_URI="mirror://gentoo/${P}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa"

DEPEND="dev-libs/atk
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
x11-libs/pango
alsa? ( media-libs/alsa-lib )"

RDEPEND="${DEPEND}
x11-libs/libX11
x11-libs/libXmu"

S="${WORKDIR}/${PN}"

src_prepare() {
sed -i -e 's/print_gif_name\[FILENAMELEN\]/print_gif_name\[1000\]/' \
"${S}/gtk/shell_main.cc" || die
epatch "${FILESDIR}"/${P}-fix-makefile.patch
epatch "${FILESDIR}"/${P}-fix-build-intel-lib.patch
}

src_compile() {
local myconf
use alsa && myconf="AUDIO_ALSA=yes"
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C "${S}/gtk"
}

src_install() {
dodoc CREDITS HISTORY README TODO
dobin gtk/free42dec
}

0 comments on commit ae20937

Please sign in to comment.