Skip to content

Commit

Permalink
dev-scheme/guile: version bump 2.0.12 bug #355355
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
Amynka committed Aug 4, 2016
1 parent fa6edab commit ae5cef0
Show file tree
Hide file tree
Showing 2 changed files with 82 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-scheme/guile/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST guile-1.8.8.tar.gz 3956654 SHA256 c3471fed2e72e5b04ad133bbaaf16369e8360283679bcf19800bc1b381024050 SHA512 ede6feb90cd419d8763feb8c5169275490a653919573c4dfced025b74cf591072b3a10ffb9a3f6ee3fe7b0a0956ffcf434e0859b421455c8349cea56bf427db0 WHIRLPOOL 104810030b5dae16805595a5b398e5a7e600771b64b08d5ff686036e2f273dcec3829a16e4cdb1dbb9db5813f2e225476f83e0535a789bc570fc2fc15a76dbe2
DIST guile-2.0.12.tar.gz 7421088 SHA256 8e382930ea17bc547b22349bba819caf61313f6de9ed110e7d87f1ec68349026 SHA512 638562b18bca8f5192ea116f89de5802c1193440c6394bbc2aad873a5b897dc9a2a05f05208c089437626d25ea4ab016bea56feb04a8cdea26d7e495cd5b3a7b WHIRLPOOL 4485e2820c9ce73370d6eb41fe81e8d6135d4e266dce396c4ec42c0ac214f3c36d9fa36c8456ef6587f0213577c89d8cbd9cc2a8e3de9665a3a4b97736ac731e
81 changes: 81 additions & 0 deletions dev-scheme/guile/guile-2.0.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit flag-o-matic

DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
HOMEPAGE="https://www.gnu.org/software/guile/"
SRC_URI="mirror://gnu/guile/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
LICENSE="LGPL-3+"
IUSE="debug debug-malloc +deprecated networking nls +regex static-libs +threads"

# emacs useflag removal not working

RDEPEND="
>=dev-libs/boehm-gc-7.0[threads?]
dev-libs/gmp:=
virtual/libffi
dev-libs/libltdl:=
sys-devel/libtool
sys-libs/ncurses:="
DEPEND="${RDEPEND}
virtual/pkgconfig
sys-apps/texinfo
sys-devel/gettext"

SLOT="12"
MAJOR="2.0"

DOCS=( GUILE-VERSION HACKING README )

src_configure() {
# see bug #178499
filter-flags -ftree-vectorize

# will fail for me if posix is disabled or without modules -- hkBst
econf \
--disable-error-on-warning \
--disable-rpath \
--enable-posix \
--with-modules \
$(use_enable debug guile-debug) \
$(use_enable debug-malloc) \
$(use_enable deprecated) \
$(use_enable networking) \
$(use_enable nls) \
$(use_enable regex) \
$(use_with threads)
}

src_install() {
default

# From Novell
# https://bugzilla.novell.com/show_bug.cgi?id=874028#c0
dodir /usr/share/gdb/auto-load/$(get_libdir)
mv "${D}"/usr/$(get_libdir)/libguile-*-gdb.scm "${D}"/usr/share/gdb/auto-load/$(get_libdir) || die

# texmacs needs this, closing bug #23493
dodir /etc/env.d
echo "GUILE_LOAD_PATH=\"${EPREFIX}/usr/share/guile/${MAJOR}\"" > "${ED}"/etc/env.d/50guile || die

# necessary for registering slib, see bug 206896
keepdir /usr/share/guile/site

# Dark magic necessary for some deps
dosym /usr/$(get_libdir)/libguile-2.0.so /usr/$(get_libdir)/libguile.so
}

pkg_postinst() {
[[ "${EROOT}" == "/" ]] && pkg_config
}

pkg_config() {
if has_version '>dev-scheme/slib-3.2.4'; then
einfo "Registering slib with guile"
install_slib_for_guile
fi
}

0 comments on commit ae5cef0

Please sign in to comment.