Skip to content

Commit

Permalink
media-video/makemkv: Bump to 1.9.10, EAPI 6, minor fixes
Browse files Browse the repository at this point in the history
  • Loading branch information
rindeal authored and chewi committed May 8, 2016
1 parent f3695a1 commit ae9c0f2
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 10 deletions.
4 changes: 2 additions & 2 deletions media-video/makemkv/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
DIST makemkv-bin-1.9.9.tar.gz 5516983 SHA256 66c9e8db89d461ddafb2682af75102611a492ae4c7bf91645b2840d9bdd355e7 SHA512 1ef8d5d588b5ffff2c9ca255c8588fd7c50cedba8b76304d55b6bf112f7903832c46650633525106c066234d2214a8348b9c5d951977bacb89fb230265a31f0b WHIRLPOOL e8f3b3387b1ef4a84add3977da3090405bf388a81ba383ddbc33ba280b934bb4c24425b13b8cc5c4e73f62c6f68351f9bee2524d81187dcceeb5b5f8a4c83838
DIST makemkv-oss-1.9.9.tar.gz 4419556 SHA256 608d89170b66d2bb89fe80497d4d4f00d604346412f997da52e06c8b10451d1c SHA512 4901d19c331d2256e024a2c739fbb7d89d6d2fafdc5530ec5fea3931587da058ec438bf2a7d9aefc362e5211996e940ab3f1a404264a276d737f6d9ccdf613c1 WHIRLPOOL 23d88f8bcd1458812df65b8d0e6c9d03985b10a51aff477209bfaab21cf5ff1d70cc6e9d0d3fa9fdbbc6453c55b8f6f9f9cf3eac0b73aeb3518375ddea351083
DIST makemkv-bin-1.9.10.tar.gz 5619754 SHA256 d94468b1cb1ec815b5ab899baab7ab9a03fcdb35c93bc0f6cbc646ffcac4b6c4 SHA512 fb42fad4404aab5196eb506ce82cfb0b094193e38cd5f42992c7007b4fb1870658cfca518e7258b8c29baf50c2b2c9be75857b7464d7a555aaadfedcf710c1f0 WHIRLPOOL 668ed528b8ca3695e039fe35028690c38e785d91c159ff4646a647b1e37fbfde1ea807e0c4d74eddc6168c8b69f1c26d92a5c8cfbbaa708afcbcbec185122c38
DIST makemkv-oss-1.9.10.tar.gz 4419555 SHA256 b395bebd64d4c95b1558573d316e88221b4ce03798dace65bd339cae2314ecfa SHA512 b9ac8679dbb62f7174cf085726301fefbd6384dcf9beeb2a2e73c157120bd03b3313700711fda69543764b0dd27c7b4b262515315eb3cd055d42c162a26bff82 WHIRLPOOL ce31538bc888c15266d5bed10fade07a42a976cb6c0dc32d710f88270085daedb1aac45acca449e00805f3abe8912335fe6e2eb0ebd4b5af8da5195b3dd1663b
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6

inherit eutils gnome2-utils multilib flag-o-matic

MY_P=makemkv-oss-${PV}
Expand Down Expand Up @@ -42,30 +43,36 @@ RDEPEND="
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/makemkv-oss-${PV}
S="${WORKDIR}/makemkv-oss-${PV}"

src_prepare() {
epatch "${FILESDIR}"/${PN}-{makefile,path}.patch
PATCHES+=( "${FILESDIR}"/${PN}-{makefile,path}.patch )

# Qt5 always trumps Qt4 if it is available. There are no configure
# options or variables to control this and there is no publicly
# available configure.ac either.
if use qt4; then
epatch "${FILESDIR}"/${PN}-qt4.patch
PATCHES+=( "${FILESDIR}"/${PN}-qt4.patch )
elif use qt5; then
epatch "${FILESDIR}"/${PN}-qt5.patch
PATCHES+=( "${FILESDIR}"/${PN}-qt5.patch )
fi

default
}

src_configure() {
# See bug #439380.
replace-flags -O* -Os

local econf_args=()

if use qt4 || use qt5; then
econf --enable-gui
econf_args+=( '--enable-gui' )
else
econf --disable-gui
econf_args+=( '--disable-gui' )
fi

econf "${econf_args[@]}"
}

src_compile() {
Expand Down

0 comments on commit ae9c0f2

Please sign in to comment.