Skip to content

Commit

Permalink
app-misc/figlet: Add live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Jul 16, 2020
1 parent 55d81a3 commit af16fd4
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions app-misc/figlet/figlet-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit bash-completion-r1 git-r3 toolchain-funcs

DESCRIPTION="program for making large letters out of ordinary text"
HOMEPAGE="http://www.figlet.org/"
EGIT_REPO_URI="https://github.com/cmatsuoka/figlet"

LICENSE="BSD"
SLOT="0"
KEYWORDS=""

src_compile() {
emake clean
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
LD="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}" \
prefix="${EPREFIX}/usr" \
all
}

src_install() {
emake \
BINDIR="${EPREFIX}/usr/bin" \
DESTDIR="${D}" \
MANDIR="${EPREFIX}/usr/share/man" \
prefix="${EPREFIX}/usr" \
install

doman chkfont.6 figlet.6 figlist.6 showfigfonts.6
dodoc README figfont.txt

newbashcomp "${FILESDIR}"/figlet.bashcomp-r1 figlet
}

0 comments on commit af16fd4

Please sign in to comment.