Skip to content

Commit

Permalink
games-action/descent2-vertigo: New package, closes bug #369399
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
chewi committed Apr 27, 2017
1 parent 724f9c5 commit b0d7ed3
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
57 changes: 57 additions & 0 deletions games-action/descent2-vertigo/descent2-vertigo-1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cdrom eutils

DESCRIPTION="Data files for Descent 2: The Vertigo Series"
HOMEPAGE="http://www.interplay.com/games/descent.php"
LICENSE="descent-data"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="videos"
RESTRICT="bindist"

S="${WORKDIR}"

src_unpack() {
cdrom_get_cds vertigo/d2x.hog:hoard.ham

case ${CDROM_SET} in
0) einfo "Found Descent 2 Vertigo Series CD" ;;
1) einfo "Found Descent 2 Vertigo Series installation" ;;
esac

cd "${CDROM_ABSMATCH%/*}" || die
eshopts_push -s globstar nocaseglob nullglob

# Strip directories
# Lowercase
# *.{hog,mn2} into data/missions
# Remainder into data

tar c \
--mode=u+w \
--ignore-case \
--xform='s:.*/::xg' \
--xform='s:.*:\L\0:x' \
--xform='s:.*\.(hog|mn2)$:data/missions/\0:x' \
--xform='s:^[^/]+$:data/\0:x' \
--exclude="$(use videos || echo '*.mvl')" \
**/{hoard.ham,d2x-h.mvl,{d2x,panic}.{hog,mn2}}* \
| tar x -C "${WORKDIR}"

assert "tar failed"
eshopts_pop
}

src_install() {
insinto /usr/share/games/d2x
doins -r data/*
}

pkg_postinst() {
elog "A client is needed to run the game, e.g. games-action/dxx-rebirth."
echo
}
8 changes: 8 additions & 0 deletions games-action/descent2-vertigo/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Games Project</name>
</maintainer>
</pkgmetadata>

0 comments on commit b0d7ed3

Please sign in to comment.