Skip to content

Commit

Permalink
kde-apps: Move kdeedu-meta 15.12.3 from kde overlay
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
a17r authored and Michael Palimaka committed Mar 25, 2016
1 parent c7580d8 commit b0db5d5
Show file tree
Hide file tree
Showing 65 changed files with 1,535 additions and 11 deletions.
1 change: 1 addition & 0 deletions kde-apps/analitza/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST analitza-15.12.3.tar.xz 232928 SHA256 2b69d6692c91e3bf7c8abe053f2dd85f708ae8502a3a0559d67e12f8dd4ee543 SHA512 09b70419d4073027be426efcc9275ae4f7ffd6f431c1e7ae4b9a43bc301fe73dd4eb8d39e72f81e668af152895b282a480f17f2397bc73fdde66275fb097d548 WHIRLPOOL 5374303755461af18440331835bd4c48d544b6d81312a98c20840d5983b1d808cfa8c06fe13db1eb369781ffbfe071b1b957218ba8397bdacfae6599bf3af8c9
DIST analitza-4.14.3.tar.xz 199964 SHA256 00227cf6006c2ee08d83ca3b502662bba331c3d007013e6bc981114cfccce422 SHA512 ac79692671bb82e5759ce7c030e21710e24e40be05a5c987f5e5b1107a8e24898937394fa8bac2825fbb77de8bef4e2d8b71d55db9b42e5746b60d144060efa0 WHIRLPOOL 2cf3c6944a03739f5cd4c2c8ab32789f15a060814238c557e3dec2ff4f51c26718dda2b8083d9a5c211c9804a3bc11d24464c8f70aac62e1ed3d97aa5bd1eca4
51 changes: 51 additions & 0 deletions kde-apps/analitza/analitza-15.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_TEST="forceoptional"
VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="KDE library for mathematical features"
KEYWORDS=" ~amd64 ~x86"
IUSE="eigen opengl"

DEPEND="
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
eigen? ( dev-cpp/eigen:3 )
opengl? (
$(add_qt_dep qtopengl)
virtual/opengl
)
"
RDEPEND="${DEPEND}"

src_prepare() {
# Nothing is installed
sed -i \
-e "/add_subdirectory(examples)/ s/^/#DONT/" \
analitzaplot/CMakeLists.txt || die

if ! use test ; then
sed -i \
-e "/add_subdirectory(tests)/ s/^/#DONT/" \
analitza{,gui,plot}/CMakeLists.txt || die
fi

kde5_src_prepare
}

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package eigen Eigen3)
$(cmake-utils_use_find_package opengl OpenGL)
)

kde5_src_configure
}
3 changes: 3 additions & 0 deletions kde-apps/analitza/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,7 @@
<email>[email protected]</email>
<name>Gentoo KDE Project</name>
</maintainer>
<use>
<flag name="eigen">Enable <pkg>dev-cpp/eigen</pkg> mathematical templates support</flag>
</use>
</pkgmetadata>
1 change: 1 addition & 0 deletions kde-apps/artikulate/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST artikulate-15.12.3.tar.xz 3743640 SHA256 a12293fd319f51e37fdf716f88e1cf0f907b11454d5431cd531237f9e77db001 SHA512 5e5af44e18a6ad6270af8ed5236df0bd4df39017609c4a5ce9c5e091abe7cc6c11f45bf42e33b712f6665ea1ec264645e0522a89d2404c2f68e622786ead888d WHIRLPOOL 538482e8f4a49d7c2fec4fe7cb56f5e5f88ca1eab715669a2aaf41ab16d4932fae78052b20234cdcb6296a13a1cfcc373d812a0acbb90260ff1e8bc090b8dec4
DIST artikulate-4.14.3.tar.xz 3850740 SHA256 d30197496b36358eeb43013d27e25950e91eea83274abbcd614f09e3381eebea SHA512 ef2421229fd88ecc85d0f4f98f847c9607459f3c58a1b3c3e9cb9204deb789504085819a757f80160179150cdbcdab3c7711ece3c6b85be2fb449229c2a1a572 WHIRLPOOL a62d1c7cd429c1cc0ad0a903206bf297d6b8759954569eb958318b50892e691c4216fc6c76ad761a7e240d0c98195740fcdbaa164dfa87e8b52d88380d54d814
32 changes: 32 additions & 0 deletions kde-apps/artikulate/artikulate-15.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="true"
inherit kde5

DESCRIPTION="Language learning application that helps improving pronunciation skills"
HOMEPAGE="https://edu.kde.org/applications/language/artikulate"
KEYWORDS=" ~amd64 ~x86"
IUSE=""

DEPEND="
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdeclarative)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep knewstuff)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtsql)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
$(add_qt_dep qtxmlpatterns)
>=media-libs/qt-gstreamer-1.2.0[qt5]
"
RDEPEND="${DEPEND}"
1 change: 1 addition & 0 deletions kde-apps/blinken/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST blinken-15.12.3.tar.xz 567496 SHA256 a1cb720a21f2c870ad60b2afa1e4f5cdd02db6bfc33e588d83cf1c039f715312 SHA512 28b5d84e265c8ef10a390555f11a39222a73c1d8158ac95bba6411f0ed9d402d13bf93720389d8cef3723efc96a81825f74ac82e88bbb2f9e604f089138c31a2 WHIRLPOOL c3707b7c22e9e59689f0ccdb098de446af552d616cf65a39ab5f5aa1c0f356ee018a896066cf638709f4f562d7c840b5a3e5efca9d18fb30fe3f297cbafd7b38
DIST blinken-4.14.3.tar.xz 565784 SHA256 7c14af0d6e9b3e8132ae0d15f24fc12f5b53edd44ca4de6a4df1fd4e8cdcae7e SHA512 7def87717f62645b029d916ab5f666fb15d93c1f2aeb7706eccd080959693face7b12a1b85c58a0ae1ba8644d94509490881cb984ce0570d69985ad0f0703fd9 WHIRLPOOL a20c563f6d60cbffcbbb1b623e88d89943ac88179ebeaa42b53b325973b2b9324e46ab74e7ca67dd98846decc004d051e3bdb739bb42f0c3359ae0d0ee584c86
34 changes: 34 additions & 0 deletions kde-apps/blinken/blinken-15.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="forceoptional"
inherit kde5

DESCRIPTION="KDE version of the Simon Says game"
HOMEPAGE="https://www.kde.org/applications/education/blinken
https://edu.kde.org/blinken"
KEYWORDS=" ~amd64 ~x86"
IUSE=""

DEPEND="
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep qtgui)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwidgets)
media-libs/phonon[qt5]
"
RDEPEND="${DEPEND}"

src_install() {
kde5_src_install

rm "${D}"/usr/share/${PN}/README.packagers
}
1 change: 1 addition & 0 deletions kde-apps/cantor/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cantor-15.12.3.tar.xz 350924 SHA256 0c67d99038cc7b2f59de6f001337267131e3d420035dd10a05b860859afe423b SHA512 0544574803085fdad61eb2a6896fa7b5b7fc8bd96ebb251f3b3c5efafcb9dc0e30cf8a8719c3bd8e77bcbf140e7798b8cce498ccb92db415e4e816dd19ecd0d8 WHIRLPOOL 62e637230e997bd65c098f9f92245e50c0c67d790d4b6138133188ddbedbc102254701626b9e7828c7ad8dc25602e39c00fd3a42429c580dd5ba9eeffd01aa00
DIST cantor-4.14.3.tar.xz 342140 SHA256 8fc81454666aa082ab392ae796f233acfb83a46fd9064952c643d89bed4565e1 SHA512 5da20030a74ef4f3b9d59f37d07b4a893b1f9cfea43728b4aa7c0aefe219d0de554201bbbf57ab9cd3e10a97ba381171cd2a907843246c42616da2a5d6b6afa9 WHIRLPOOL e5d46da3a7081d23fbb47e51c96ae58cac32a6d90354bc335bfb1926ec6586070da64ee7b973aeebbe75d81eea5858fdceadecc667f17c49bbb3fb48ea43db58
104 changes: 104 additions & 0 deletions kde-apps/cantor/cantor-15.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

KDE_HANDBOOK="forceoptional"
KDE_TEST="forceoptional"
PYTHON_COMPAT=( python2_7 )
# FIXME: PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit kde5 python-r1

DESCRIPTION="Interface for doing mathematics and scientific computing"
HOMEPAGE="https://www.kde.org/applications/education/cantor https://edu.kde.org/cantor"
KEYWORDS=" ~amd64 ~x86"
IUSE="analitza lua postscript python qalculate +R"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
RDEPEND="
$(add_frameworks_dep karchive)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdelibs4support)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
$(add_frameworks_dep knewstuff)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kpty)
$(add_frameworks_dep ktexteditor)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep qtgui)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
$(add_qt_dep qtxmlpatterns)
analitza? ( $(add_kdeapps_dep analitza) )
lua? ( dev-lang/luajit:2 )
qalculate? (
sci-libs/cln
sci-libs/libqalculate
)
postscript? ( app-text/libspectre )
python? ( ${PYTHON_DEPS} )
R? ( dev-lang/R )
"
DEPEND="${RDEPEND}
>=dev-cpp/eigen-2.0.3:2
"

RESTRICT="test"

PATCHES=( "${FILESDIR}/${P}-tests.patch" )

pkg_setup() {
use python && python_setup
kde5_pkg_setup
}

src_prepare() {
kde5_src_prepare

# FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
-i src/backends/CMakeLists.txt || die

if ! use test ; then
sed -e "/add_subdirectory(test)/ s/^/#DONT/" \
-i src/lib/CMakeLists.txt || die
sed -e "/add_subdirectory(tests)/ s/^/#DONT/" \
-i src/backends/python3/CMakeLists.txt || die
fi
}

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package analitza Analitza5)
$(cmake-utils_use_find_package lua LuaJIT)
$(cmake-utils_use_find_package postscript LibSpectre)
$(cmake-utils_use_find_package python PythonLibs)
$(cmake-utils_use_find_package qalculate Qalculate)
$(cmake-utils_use_find_package R R)
)
kde5_src_configure
}

pkg_postinst() {
kde5_pkg_postinst

if ! use analitza && ! use lua && ! use python && ! use qalculate && ! use R; then
echo
ewarn "You have decided to build ${PN} with no backend."
ewarn "To have this application functional, please do one of below:"
ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'analitza', 'lua', 'python', 'qalculate' or 'R' USE flag enabled"
ewarn " # emerge -vaDu sci-mathematics/maxima"
echo
fi
}
49 changes: 49 additions & 0 deletions kde-apps/cantor/files/cantor-15.12.3-tests.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
--- a/src/backends/maxima/CMakeLists.txt 2016-03-21 02:16:05.549024821 +0100
+++ b/src/backends/maxima/CMakeLists.txt 2016-03-21 02:22:07.951014021 +0100
@@ -21,12 +21,14 @@
target_link_libraries(cantor_maximabackend KF5::Pty)
endif(NOT WIN32)

+if (BUILD_TESTING)
add_executable( testmaxima testmaxima.cpp)
target_link_libraries( testmaxima
cantorlibs
cantortest
${QTTEST_LIBRARY}
)
+endif()

install( FILES cantor_maxima.knsrc DESTINATION ${KDE_INSTALL_CONFDIR} )
install( FILES keywords.xml cantor-initmaxima.lisp DESTINATION ${KDE_INSTALL_DATADIR}/cantor/maximabackend)
--- a/src/backends/sage/CMakeLists.txt 2016-03-21 01:23:19.251791138 +0100
+++ b/src/backends/sage/CMakeLists.txt 2016-03-21 01:27:16.300827617 +0100
@@ -17,12 +17,14 @@

target_link_libraries( cantor_sagebackend KF5::Pty)

+if (BUILD_TESTING)
add_executable( testsage testsage.cpp)
target_link_libraries( testsage
${QT_QTTEST_LIBRARY}
cantorlibs
cantortest
)
+endif()

install( FILES cantor_sage.knsrc DESTINATION ${KDE_INSTALL_CONFDIR} )
install( FILES keywords.xml DESTINATION ${KDE_INSTALL_DATADIR}/cantor/sagebackend)
--- a/src/backends/python2/CMakeLists.txt 2016-03-21 01:28:39.055793038 +0100
+++ b/src/backends/python2/CMakeLists.txt 2016-03-21 01:35:01.451012440 +0100
@@ -20,10 +20,12 @@
cantor_pythonbackend
)

+if (BUILD_TESTING)
add_executable(testpython2 testpython2.cpp)
target_link_libraries(testpython2 ${QT_QTTEST_LIBRARY} cantorlibs cantortest)

add_test(NAME testpython2 COMMAND testpython2)
+endif()

install(FILES cantor_python2.knsrc DESTINATION ${KDE_INSTALL_CONFDIR})
install(FILES python2backend.kcfg DESTINATION ${KDE_INSTALL_KCFGDIR})
1 change: 1 addition & 0 deletions kde-apps/kalgebra/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kalgebra-15.12.3.tar.xz 256164 SHA256 0a6e8b1e776487aed34807ae6f0048eb2f927e68557baa042c0e440fc6424835 SHA512 6b3bf7040763856b449b6e3a91d2c819bd2886725719d0235777b2a1e0b47f92eaf3c13d2b82be52d824db69286c74831b2ae08fe633055604947feceb1af720 WHIRLPOOL 8490d2bf07202e27cd2aeda9f77675941521bab6a96690425ca5b7408c8f856e3bf3c3bb927343faaa82f09c27c183e899c5e676ddb94e87896152d31329d2ff
DIST kalgebra-4.14.3.tar.xz 274600 SHA256 3a9b9fe63c8d1b6d9326d098254e5e4a32bb48f3b4514fb055e0896aebbdf67d SHA512 23f49a1389117dab08212de4130c49c7ed269d2d4adbb80b2f4c24d3e25b882495d79702db1d459b7cc83135914d17b48a1ef9333371a7eb4bc0d79858ebf65a WHIRLPOOL 429f6fe06ff00a2968e5a62b5553bef57f8654794c31e393140b959928690afa7ecbabe5f907618df7067906481f3489f75e04fdc5dc2f8989a081beb309fb28
47 changes: 47 additions & 0 deletions kde-apps/kalgebra/kalgebra-15.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="forceoptional"
inherit kde5

DESCRIPTION="MathML-based graph calculator for KDE"
HOMEPAGE="https://www.kde.org/applications/education/kalgebra
https://edu.kde.org/kalgebra"
KEYWORDS=" ~amd64 ~x86"
IUSE="opengl readline"

DEPEND="
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_kdeapps_dep analitza 'opengl?')
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtwebkit)
$(add_qt_dep qtwidgets)
opengl? (
$(add_qt_dep qtopengl)
$(add_qt_dep qtprintsupport)
virtual/glu
)
readline? ( sys-libs/readline:0= )
"
RDEPEND="${DEPEND}
!kde-apps/analitza:4
"

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package opengl OpenGL)
$(cmake-utils_use_find_package readline Readline)
)

kde5_src_configure
}
1 change: 1 addition & 0 deletions kde-apps/kalzium/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kalzium-15.12.3.tar.xz 3944560 SHA256 a1c2a052997db83ccf3ad827330d7227cb6b34d56225762cb45e7e3641512c53 SHA512 70808cd3df8b15941146444410f75c955dc925417a89e4b77612680d2a0bda53124e3c44e2b632c095408287db5481c32535a608b48e938d22a43b624073a271 WHIRLPOOL 03d538cebab06c24725a06ebee29fb79fc46ac25a261594a6e2d2eb69664ea5e88067831dd5c21f938ab40483806132c2c0106beef783d6e9766f99017e6c27c
DIST kalzium-4.14.3.tar.xz 3944960 SHA256 4b8d086c942874c56b4835079991f2d86289d163d2dbb3e86390270c758317e5 SHA512 11f6f06379571cb92a7cb0c13d068596b2cbe014a5974dce628ac138c20f50ca5c207c4b6328c0c4d83dadf75d43455ce6794564933f2520dc1589570ddada94 WHIRLPOOL 50d392d8aac63dcc7143db1b2dd3e7e7c411f6457d4005b5313a0043bf68178f12c20b60e278697687aca28720b2759522c2f135dd1143873149bb4c3a754234
47 changes: 47 additions & 0 deletions kde-apps/kalzium/kalzium-15.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="optional"
CPPUNIT_REQUIRED="optional"
OPENGL_REQUIRED="always"
inherit kde4-base flag-o-matic

DESCRIPTION="KDE: periodic table of the elements"
HOMEPAGE="https://www.kde.org/applications/education/kalzium
https://edu.kde.org/kalzium"
KEYWORDS=" ~amd64 ~x86"
IUSE="editor debug solver"

DEPEND="
editor? (
>=dev-cpp/eigen-2.0.3:2
sci-chemistry/avogadro
>=sci-chemistry/openbabel-2.2
)
solver? ( dev-ml/facile[ocamlopt] )
"
RDEPEND=${DEPEND}

KMEXTRACTONLY="
libkdeedu/kdeeduui/
libkdeedu/libscience/
"

src_configure(){
# Fix missing finite()
[[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H

local mycmakeargs=(
$(cmake-utils_use_with editor Eigen2)
$(cmake-utils_use_with editor Avogadro)
$(cmake-utils_use_with editor OpenBabel2)
$(cmake-utils_use_with editor OpenGL)
$(cmake-utils_use_with solver OCaml)
$(cmake-utils_use_with solver Libfacile)
)

kde4-base_src_configure
}
1 change: 1 addition & 0 deletions kde-apps/kanagram/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kanagram-15.12.3.tar.xz 4789992 SHA256 f2ffeeee716d94d42e7ffbf70079f3ab8575256cca870dd0612f37485c60b0a9 SHA512 9b03cd394928203177450168a1e8387358b8f6b53535c981e5d6977f18e9bc3c3e654b022ce243666ec24ed0e5dea1a49b66bce0176c5ac07bc50d6eb5f97e4c WHIRLPOOL b473c06f63d28acb51baea14e1ee1766de503af3273aa91590f3243c68f617dd5abb772767cb528a1b3559a28c08ceb5335fd16712739251cab832aff6bfb7e4
DIST kanagram-4.14.3.tar.xz 4612252 SHA256 95e551f5c1d923d0c3dbca4a024b0381fab7c35f56e7a9ce26fdb75ccc28495b SHA512 b8150717ffa61012bfcceec1defe739573f9b91fbe0089d340aa924624806a9629a183740980e6dbd6e206e1b33e0b18600c6900ff43f754e1373f7e3ba27427 WHIRLPOOL e016993986001abedefbb4d373756a4fcc5ade99c6d8ab24d385c9ef1a0133ea7a862563c2e8d76f04b52cf208add1fb653024d3b1465662d27a691760ca52fe
Loading

0 comments on commit b0db5d5

Please sign in to comment.