Skip to content

Commit

Permalink
gui-libs/wlroots: revbump with x11-base/xwayland dependency
Browse files Browse the repository at this point in the history
Signed-off-by: Piotr Karbowski <[email protected]>
  • Loading branch information
Piotr Karbowski committed Jul 26, 2021
1 parent e9590c3 commit b121303
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 2 deletions.
68 changes: 68 additions & 0 deletions gui-libs/wlroots/wlroots-0.14.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
HOMEPAGE="https://github.com/swaywm/wlroots"

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
inherit git-r3
SLOT="0/9999"
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
SLOT="0/14"
fi

LICENSE="MIT"
IUSE="x11-backend X"

DEPEND="
>=dev-libs/libinput-1.14.0:0=
>=dev-libs/wayland-1.19.0
>=dev-libs/wayland-protocols-1.17.0
media-libs/mesa[egl,gles2,gbm]
sys-auth/seatd:=
virtual/libudev
x11-libs/libdrm
x11-libs/libxkbcommon
x11-libs/pixman
x11-backend? ( x11-libs/libxcb:0= )
X? (
x11-base/xwayland
x11-libs/libxcb:0=
x11-libs/xcb-util-image
x11-libs/xcb-util-wm
)
"
RDEPEND="
${DEPEND}
"
BDEPEND="
>=dev-libs/wayland-protocols-1.17
>=dev-util/meson-0.56.0
virtual/pkgconfig
"

src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
"-Dxcb-errors=disabled"
"-Dexamples=false"
"-Dwerror=false"
"-Drenderers=gles2"
-Dxwayland=$(usex X enabled disabled)
-Dx11-backend=$(usex x11-backend enabled disabled)
)

meson_src_configure
}

pkg_postinst() {
elog "You must be in the input group to allow your compositor"
elog "to access input devices via libinput."
}
4 changes: 2 additions & 2 deletions gui-libs/wlroots/wlroots-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
SLOT="0/9999"
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
SLOT="0/14"
fi

Expand All @@ -33,7 +33,7 @@ DEPEND="
x11-libs/pixman
x11-backend? ( x11-libs/libxcb:0= )
X? (
x11-base/xorg-server[wayland]
x11-base/xwayland
x11-libs/libxcb:0=
x11-libs/xcb-util-image
x11-libs/xcb-util-wm
Expand Down

0 comments on commit b121303

Please sign in to comment.