Skip to content

Commit

Permalink
dev-lang/open-cobol: bump EAPI and stuff
Browse files Browse the repository at this point in the history
* bump EAPI to 7
* Fix HOMEPAGE
* Use MY_PN to future proof if maintainer or p-m want to bump to GnuCOBOL
* License remains the same unless pkgmove is done
* Use src_configure and remove other unneeded stuff

Bug: https://bugs.gentoo.org/641888
Bug: https://bugs.gentoo.org/685960
Closes: https://bugs.gentoo.org/697350

Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
FuzzyGophers committed Nov 23, 2019
1 parent 95cabb3 commit b17c2c4
Showing 1 changed file with 14 additions and 15 deletions.
29 changes: 14 additions & 15 deletions dev-lang/open-cobol/open-cobol-1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,35 +1,34 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=0
EAPI=7

inherit eutils
MY_PN="open-cobol"
# Future proof pkg if maintainer or p-m want to bump to latest GNUCobol

DESCRIPTION="an open-source COBOL compiler"
HOMEPAGE="http://www.opencobol.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="https://sourceforge.net/projects/open-cobol/"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.gz"

LICENSE="GPL-2 LGPL-2.1"
# License must be changed to GPL-3+ if/when pkgmove is done
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="berkdb nls readline"

RDEPEND="dev-libs/gmp
berkdb? ( =sys-libs/db-4* )
RDEPEND="dev-libs/gmp:0=
berkdb? ( sys-libs/db:4.8= )
sys-libs/ncurses
readline? ( sys-libs/readline )"
DEPEND="${RDEPEND}
sys-devel/libtool"

src_compile() {
DOCS=( AUTHORS ChangeLog NEWS README )

src_configure() {
econf \
$(use_with berkdb db) \
$(use_enable nls) \
$(use_with readline) || die "econf failed."
emake || die "emake failed."
}

src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS ChangeLog NEWS README
$(use_with readline)
default
}

0 comments on commit b17c2c4

Please sign in to comment.