Skip to content

Commit

Permalink
www-client/firefox: add rust-1.29+ support
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/666898
Signed-off-by: Thomas Deutschmann <[email protected]>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
  • Loading branch information
Whissi committed Sep 28, 2018
1 parent f43bde5 commit b1e7185
Show file tree
Hide file tree
Showing 3 changed files with 39 additions and 0 deletions.
37 changes: 37 additions & 0 deletions www-client/firefox/files/firefox-60.0-rust-1.29-comp.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
https://bugs.gentoo.org/666898

https://bugzilla.mozilla.org/show_bug.cgi?id=1479540
--- a/build/moz.configure/init.configure
+++ b/build/moz.configure/init.configure
@@ -572,17 +572,26 @@ option('--target', nargs=1,
@imports(_from='__builtin__', _import='KeyError')
@imports(_from='__builtin__', _import='ValueError')
def split_triplet(triplet, allow_unknown=False):
# The standard triplet is defined as
# CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM
# There is also a quartet form:
# CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM
# But we can consider the "KERNEL-OPERATING_SYSTEM" as one.
- cpu, manufacturer, os = triplet.split('-', 2)
+ # Additionally, some may omit "unknown" when the manufacturer
+ # is not specified and emit
+ # CPU_TYPE-OPERATING_SYSTEM
+ parts = triplet.split('-', 2)
+ if len(parts) == 3:
+ cpu, _, os = parts
+ elif len(parts) == 2:
+ cpu, os = parts
+ else:
+ die("Unexpected triplet string: %s" % triplet)

# Autoconf uses config.sub to validate and canonicalize those triplets,
# but the granularity of its results has never been satisfying to our
# use, so we've had our own, different, canonicalization. We've also
# historically not been very consistent with how we use the canonicalized
# values. Hopefully, this will help us make things better.
# The tests are inherited from our decades-old autoconf-based configure,
# which can probably be improved/cleaned up because they are based on a




1 change: 1 addition & 0 deletions www-client/firefox/firefox-60.2.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -126,6 +126,7 @@ src_prepare() {

eapply "${FILESDIR}"/bug_1461221.patch
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch

# Enable gnomebreakpad
if use debug ; then
Expand Down
1 change: 1 addition & 0 deletions www-client/firefox/firefox-62.0.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -187,6 +187,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
eapply "${FILESDIR}"/${PN}-60.0-do-not-force-lld.patch
eapply "${FILESDIR}"/${PN}-60.0-sandbox-lto.patch # 666580
eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch

# Enable gnomebreakpad
if use debug ; then
Expand Down

0 comments on commit b1e7185

Please sign in to comment.