forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Sebastian Parborg <[email protected]> Closes: gentoo#20498 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
1 parent
b997f04
commit b26f9d3
Showing
3 changed files
with
63 additions
and
8 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 13e66268..27ff8364 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -218,7 +218,7 @@ if (WASM_ENABLED) | ||
list(APPEND ISPC_TARGETS wasm-i32x4) | ||
endif() | ||
|
||
-set(CLANG_LIBRARY_LIST clangFrontend clangDriver clangSerialization clangParse clangSema clangAnalysis clangAST clangBasic clangEdit clangLex) | ||
+set(CLANG_LIBRARY_LIST clang clang-cpp) | ||
set(LLVM_COMPONENTS engine ipo bitreader bitwriter instrumentation linker option frontendopenmp) | ||
|
||
if (X86_ENABLED) | ||
@@ -402,11 +402,8 @@ if (ISPC_USE_ASAN) | ||
endif() | ||
|
||
# Link against Clang libraries | ||
-foreach(clangLib ${CLANG_LIBRARY_LIST}) | ||
- find_library(${clangLib}Path NAMES ${clangLib} HINTS ${LLVM_LIBRARY_DIRS}) | ||
- list(APPEND CLANG_LIBRARY_FULL_PATH_LIST ${${clangLib}Path}) | ||
-endforeach() | ||
-target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_FULL_PATH_LIST}) | ||
+find_package(Clang REQUIRED) | ||
+target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_LIST}) | ||
|
||
# Link against LLVM libraries | ||
target_link_libraries(${PROJECT_NAME} ${LLVM_LIBRARY_LIST}) | ||
diff --git a/src/llvmutil.cpp b/src/llvmutil.cpp | ||
index 06fab989..57a7130f 100644 | ||
--- a/src/llvmutil.cpp | ||
+++ b/src/llvmutil.cpp | ||
@@ -42,6 +42,7 @@ | ||
#include <llvm/IR/BasicBlock.h> | ||
#include <llvm/IR/Instructions.h> | ||
#include <llvm/IR/Module.h> | ||
+#include <llvm/Support/raw_ostream.h> | ||
|
||
#ifdef ISPC_GENX_ENABLED | ||
#include <llvm/GenXIntrinsics/GenXIntrinsics.h> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 13e66268..27ff8364 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -352,7 +352,7 @@ target_include_directories(${PROJECT_NAME} PRIVATE | ||
set_source_files_properties(${FLEX_OUTPUT} PROPERTIES COMPILE_FLAGS "/wd4005 /wd4003") | ||
set_source_files_properties(${BISON_OUTPUT} PROPERTIES COMPILE_FLAGS "/wd4005 /wd4065") | ||
else() | ||
- target_compile_options(${PROJECT_NAME} PRIVATE -Wall -Wno-sign-compare -Wno-unused-function -Werror ${LLVM_CPP_FLAGS}) | ||
+ target_compile_options(${PROJECT_NAME} PRIVATE -Wall -Wno-sign-compare -Wno-unused-function ${LLVM_CPP_FLAGS}) | ||
# The change implementing -Wno-unused-but-set-variable in clang was reverted, so commenting out for now. | ||
#if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "13.0.0") | ||
# set_source_files_properties(${BISON_CPP_OUTPUT} PROPERTIES COMPILE_FLAGS "-Wno-unused-but-set-variable") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters