Skip to content

Commit

Permalink
games-util/pyfa: version bump to 2.15.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Andreas Zuber <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
ZeroPointEnergy authored and juippis committed Dec 18, 2019
1 parent 5433f2d commit b2c792a
Show file tree
Hide file tree
Showing 2 changed files with 97 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-util/pyfa/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST pyfa-1.35.0.tar.gz 8743938 BLAKE2B 623a70ea8d28c41f94b5c54c3b8b57ddc6b6604f
DIST pyfa-1.35.1.tar.gz 8746324 BLAKE2B f224f78c97f15d37e2276512541985bfd2ae80c031233261837cd142eddc16a853688a4f1f1f8684736f757d60fd57c41fb14987f336274b2284bd1de26239b3 SHA512 6da5e2d3351157f35c32c7b210d8bfb86a9dc2ea3a3df02449950c498ffabecff3a48fe38086dce75ec5a2cc2549dd28b474015edc0ea01c56a2ff58d1ba3f69
DIST pyfa-1.37.0.tar.gz 8795428 BLAKE2B 33aa0159b41fe2f228be13788f4e91933205a1883af229ffa97af0816dbce307fa8ce9ebc53b335a99decb84f9a28e83b977daf3c600df1cdd0336ba2c413ba3 SHA512 21094a1c374a60447e38261762ee13cd212f6af5f8d757c8b626774fb5a10d10e99267da1311d3164664b62169edd2772519a7b4ebd7414db2493f5121df5c8c
DIST pyfa-2.14.1.tar.gz 14452477 BLAKE2B e4c688cff14eecaa71f86fb9e22f6a585a3136a4bd7df65c8dd65ed82c2aa9e530210134daaba25251df92dc55a7e538474b39c1d54e4bcb1817eac17791d517 SHA512 d3d3219fa37f44c81d85165c7e780261e149b47db147417ea26edaff448484ce565607aded714a4f44ca23b8c1586c8597ace856020c4c319cea6d39f353b140
DIST pyfa-2.15.1.tar.gz 14516568 BLAKE2B ba3b1170f35681ab33bece447b4bdf563c8f964037dc6b35cbd23360f7e36c61dd9074e34b5648c7a04b59ad192f5babd75ce2a935940a52e62de8cc174f7e5b SHA512 2d8fcb8608e31c135b8dac7239afe0a5acb0d32fba1291ce6ebafe093ef232c08f0aa42d172ebac5beefb7dba47aad9eb3833c679e3d02edc9cc056739c7538b
96 changes: 96 additions & 0 deletions games-util/pyfa/pyfa-2.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="sqlite,threads"

inherit desktop eutils python-single-r1 xdg-utils

DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
HOMEPAGE="https://github.com/pyfa-org/Pyfa"

LICENSE="GPL-3+ all-rights-reserved"
SLOT="0"
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
inherit git-r3
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S=${WORKDIR}/Pyfa-${PV}
fi
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror bindist"

DEPEND="
>=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
>=dev-python/logbook-1.0.0[${PYTHON_USEDEP}]
>=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
>=dev-python/wxpython-4.0.4[webkit,${PYTHON_USEDEP}]
${PYTHON_DEPS}"
RDEPEND="${DEPEND}
>=dev-python/beautifulsoup-4.6.0[${PYTHON_USEDEP}]
>=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
>=dev-python/packaging-16.8[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
>=dev-python/roman-2.0.0[${PYTHON_USEDEP}]
>=dev-python/matplotlib-2.0.0[wxwidgets,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]"
BDEPEND="app-arch/zip"

PATCHES=(
# fix import path in the main script for systemwide installation
"${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
)

src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work
edos2unix config.py pyfa.py gui/bitmap_loader.py service/settings.py

default

# make python recognize pyfa as a package
touch __init__.py || die

sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
-e "s:%%EPREFIX%%:${EPREFIX}:" \
"${FILESDIR}/configforced-1.15.1.py" > configforced.py || die
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
pyfa.py > pyfa || die
}

src_install() {
python_moduleinto ${PN}
python_domodule eos gui service utils graphs
python_domodule config*.py __init__.py version.yml configforced.py db_update.py
python_doscript pyfa

insinto /usr/share/${PN}

einfo "Creating database ..."
python ./db_update.py || die
doins eve.db

einfo "Compressing images ..."
pushd imgs > /dev/null || die
zip -r imgs.zip * || die "zip failed"
doins imgs.zip
popd > /dev/null || die

dodoc README.md
doicon -s 32 imgs/gui/pyfa.png
newicon -s 64 imgs/gui/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit b2c792a

Please sign in to comment.