Skip to content

Commit

Permalink
net-fs/nfs-utils: Bump to version 2.1.2_rc5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.7, Repoman-2.3.3
  • Loading branch information
Lars Wendler committed Aug 15, 2017
1 parent 440d4b8 commit b2dbe93
Show file tree
Hide file tree
Showing 2 changed files with 191 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-fs/nfs-utils/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST nfs-utils-1.3.1.tar.bz2 785800 SHA256 748c4afbdfd3e92017fe579f1dd3280a10db1
DIST nfs-utils-1.3.4.tar.bz2 814545 SHA256 c529c82a82320daae811f3d3a143f83d2714d7e7a43beadd42fcd6022c17d590 SHA512 765c0bc55a9a0bdb2c25d8fb7189a9054fb9f2dd51726eda29f44e5d5c423e245b02307dfcfab9239276d8f44869a72732416f6e9ef5a1f80753d9243ba1b38c WHIRLPOOL 6dc556ef7d00a583c222eb62a600b0d83c6f91ad65d89ca14e1fb3c8aaacf4fbae492e6f0ca3fb0821e2b666f0806ad5fddec041a1124b86b9941540cdfb08b4
DIST nfs-utils-2.1.1.tar.bz2 820083 SHA256 0a28416948516c26f3bfe90425b0de09b79364dc1f508bf1dda8de66e1edbb09 SHA512 ed358280b7e124154632040bf747f6e4c3c6e4156bf90e82ff6915b1488f1c0dd65251a3a0f9b7ca96b9664d64e24b379828da9b524e64a3c769a44f4c930448 WHIRLPOOL bb28ae312b64c3493a1393a5b41eda457367594a71e230379ec04ffea3eb29d60ab8254e4981b0aa9cbe778dc1fbe9b08dc8615184a35cdb22bf4e5e04e56a6c
DIST nfs-utils-2.1.2_rc3.tar.gz 475356 SHA256 5b379316a2cc49b07f72042b72eadee0bfe7c88e65d7b5baa4798e6cefca5a82 SHA512 2f948994f275b405678240deecc879900cc0e72476adaf552db059364f08f0929722013d751e0bc7913c30eb3f8183d1fc7693709c063fc92e20b71edd24ccef WHIRLPOOL 6a16a9cc3d22d883b6a8aa2d2f01dce81f9a1df03154a80e4aa43ae9bb878a15f0ca37951702f780341283da94d885b7be3656a950285ef79619e09dc465727f
DIST nfs-utils-2.1.2_rc5.tar.gz 476401 SHA256 52b32896572e0f81dffd5ccd90c367e5d00b5d371b8deef45dc744ee1b7ad2ab SHA512 28670ca993c1bf953632086ab15cec1b6a525fb1b28243e382f246362cfb2629c9d0416f4f65c6a2f2c46202a4c6855d1924a7f8c984395ddb98b6d4f4b0cbcb WHIRLPOOL f2e2f75c0a989402f75740164870e250a12f29f4b3f0eb7102cecf57aea0d647a0a7860798f9333e8bef9efc4af72f516c885c62cd079e89470d108cdaca4b9d
190 changes: 190 additions & 0 deletions net-fs/nfs-utils/nfs-utils-2.1.2_rc5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,190 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools flag-o-matic multilib systemd

DESCRIPTION="NFS client and server daemons"
HOMEPAGE="http://linux-nfs.org/"

if [[ "${PV}" = *_rc* ]] ; then
inherit versionator
MY_PV="$(replace_all_version_separators -)"
SRC_URI="http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=snapshot;h=refs/tags/${PN}-${MY_PV};sf=tgz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
else
SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="caps ipv6 kerberos +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 selinux tcpd +uuid"
REQUIRED_USE="kerberos? ( nfsv4 )"
RESTRICT="test" #315573

# kth-krb doesn't provide the right include
# files, and nfs-utils doesn't build against heimdal either,
# so don't depend on virtual/krb.
# (04 Feb 2005 agriffis)
DEPEND_COMMON="tcpd? ( sys-apps/tcp-wrappers )
caps? ( sys-libs/libcap )
sys-libs/e2fsprogs-libs
>=net-nds/rpcbind-0.2.4
net-libs/libtirpc:=
libmount? ( sys-apps/util-linux )
nfsdcld? ( >=dev-db/sqlite-3.3 )
nfsv4? (
dev-libs/libevent:=
>=net-libs/libnfsidmap-0.21-r1
kerberos? (
>=net-libs/libtirpc-0.2.4-r1[kerberos]
app-crypt/mit-krb5
)
nfsidmap? (
>=net-libs/libnfsidmap-0.24
>=sys-apps/keyutils-1.5.9
)
)
nfsv41? (
sys-fs/lvm2
)
uuid? ( sys-apps/util-linux )"
RDEPEND="${DEPEND_COMMON}
!net-nds/portmap
!<sys-apps/openrc-0.13.9
selinux? (
sec-policy/selinux-rpc
sec-policy/selinux-rpcbind
)
"
DEPEND="${DEPEND_COMMON}
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
"${FILESDIR}"/${PN}-1.2.8-cross-build.patch
)

src_prepare() {
default

sed \
-e "/^sbindir/s:= := \"${EPREFIX}\":g" \
-i utils/*/Makefile.am || die

eautoreconf
}

src_configure() {
export libsqlite3_cv_is_recent=yes # Our DEPEND forces this.
export ac_cv_header_keyutils_h=$(usex nfsidmap)
local myeconfargs=(
--with-statedir="${EPREFIX}"/var/lib/nfs
--enable-tirpc
--with-tirpcinclude="${EPREFIX}"/usr/include/tirpc/
$(use_enable libmount libmount-mount)
$(use_with tcpd tcp-wrappers)
$(use_enable nfsdcld nfsdcltrack)
$(use_enable nfsv4)
$(use_enable nfsv41)
$(use_enable ipv6)
$(use_enable caps)
$(use_enable uuid)
$(use_enable kerberos gss)
$(use_enable kerberos svcgss)
--without-gssglue
)
econf "${myeconfargs[@]}"
}

src_compile(){
# remove compiled files bundled in the tarball
emake clean
default
}

src_install() {
default
rm linux-nfs/Makefile* || die
dodoc -r linux-nfs README

# Don't overwrite existing xtab/etab, install the original
# versions somewhere safe... more info in pkg_postinst
keepdir /var/lib/nfs/{,sm,sm.bak}
mv "${ED%/}"/var/lib "${ED%/}"/usr/$(get_libdir) || die

# Install some client-side binaries in /sbin
dodir /sbin
mv "${ED%/}"/usr/sbin/rpc.statd "${ED%/}"/sbin/ || die

if use nfsv4 && use nfsidmap ; then
# Install a config file for idmappers in newer kernels. #415625
insinto /etc/request-key.d
echo 'create id_resolver * * /usr/sbin/nfsidmap -t 600 %k %d' > id_resolver.conf
doins id_resolver.conf
fi

insinto /etc
doins "${FILESDIR}"/exports
keepdir /etc/exports.d

local f list=() opt_need=""
if use nfsv4 ; then
opt_need="rpc.idmapd"
list+=( rpc.idmapd rpc.pipefs )
use kerberos && list+=( rpc.gssd rpc.svcgssd )
fi
for f in nfs nfsclient rpc.statd "${list[@]}" ; do
newinitd "${FILESDIR}"/${f}.initd ${f}
done
newinitd "${FILESDIR}"/nfsmount.initd-1.3.1 nfsmount # Nuke after 2015/08/01
for f in nfs nfsclient ; do
newconfd "${FILESDIR}"/${f}.confd ${f}
done
sed -i \
-e "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" \
"${ED%/}"/etc/conf.d/nfs || die #234132

local systemd_systemunitdir="$(systemd_get_systemunitdir)"
systemd_dounit systemd/*.{mount,service,target}
if ! use nfsv4 || ! use kerberos ; then
rm "${ED%/}${systemd_systemunitdir}"/rpc-{gssd,svcgssd}.service || die
fi
if ! use nfsv41 ; then
rm "${ED%/}${systemd_systemunitdir}"/nfs-blkmap.* || die
fi
sed -i \
-e 's:/usr/sbin/rpc.statd:/sbin/rpc.statd:' \
"${ED%/}${systemd_systemunitdir}"/* || die

keepdir /var/lib/nfs #368505
keepdir /var/lib/nfs/v4recovery #603628

}

pkg_postinst() {
# Install default xtab and friends if there's none existing. In
# src_install we put them in /usr/lib/nfs for safe-keeping, but
# the daemons actually use the files in /var/lib/nfs. #30486
local f
for f in "${EROOT%/}"/usr/$(get_libdir)/nfs/*; do
[[ -e ${EROOT%/}/var/lib/nfs/${f##*/} ]] && continue
einfo "Copying default ${f##*/} from ${EPREFIX}/usr/$(get_libdir)/nfs to ${EPREFIX}/var/lib/nfs"
cp -pPR "${f}" "${EROOT%/}"/var/lib/nfs/
done

if systemd_is_booted; then
if [[ ${REPLACING_VERSIONS} < 1.3.0 ]]; then
ewarn "We have switched to upstream systemd unit files. Since"
ewarn "they got renamed, you should probably enable the new ones."
ewarn "You can run 'equery files nfs-utils | grep systemd'"
ewarn "to know what services you need to enable now."
fi
else
ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
ewarn "same runlevel as nfsmount."
fi
}

0 comments on commit b2dbe93

Please sign in to comment.