Skip to content

Commit

Permalink
app-text/pdftk: bump to 3.3.2
Browse files Browse the repository at this point in the history
eapi7, min java to 1.8

Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
fordfrog committed Dec 24, 2021
1 parent 5774a77 commit b3d9f51
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/pdftk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pdftk-v3.2.2.tar.bz2 1245439 BLAKE2B ac1991e60ad06308cb7be1e74f9b3772c80416e490fe525e806efb6d30c6bbc9d310b98c255ef9e3eb3f814541d7388140210c4df2b694bd4a9ee325c27b3f24 SHA512 03220ac3036098768dd4250bbfeb6675561e9126697b99703ab5788b2cee7551256c301d9191745c5fdedf429056b46641351d1fb92631ef17673d7e740c5431
DIST pdftk-v3.3.2.tar.bz2 2169492 BLAKE2B 53cb98fe3e3d1dbe8b01a45b5b11c6fbe57017ea8029efe35677914a48ffd446c5d67621443a89f512b15d0f7e77a81c945d4c220ccaf4fd658cc1726cc32059 SHA512 b02c713b67531205e760e8d8a240a82af47dbdc28e59aa683e03772d2fb27b504b98f8be1e8dc73bfc967cc9532f3dc1eccbd105abb21db396268855233051eb
42 changes: 42 additions & 0 deletions app-text/pdftk/pdftk-3.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit java-pkg-2 java-ant-2

DESCRIPTION="gcj-free version of pdftk written in Java"
HOMEPAGE="https://gitlab.com/pdftk-java/pdftk"

if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/pdftk-java/pdftk/"
else
SRC_URI="https://gitlab.com/pdftk-java/pdftk/-/archive/v${PV}/pdftk-v${PV}.tar.bz2"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
S="${WORKDIR}/pdftk-v${PV}"
fi

LICENSE="GPL-2"
SLOT="0"

JAVA_PKG_STRICT="yes"
EANT_GENTOO_CLASSPATH="bcprov,commons-lang-3.6"
JAVA_ANT_REWRITE_CLASSPATH="true"

CDEPEND="
dev-java/bcprov:0
dev-java/commons-lang:3.6"

RDEPEND="
${CDEPEND}
>=virtual/jre-1.8:*"

DEPEND="
${CDEPEND}
>=virtual/jdk-1.8:*"

src_install() {
java-pkg_newjar "build/jar/pdftk.jar"
java-pkg_dolauncher ${PN} --main com.gitlab.pdftk_java.pdftk
}

0 comments on commit b3d9f51

Please sign in to comment.