Skip to content

Commit

Permalink
app-office/texmacs: bump to 1.99.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.16
Signed-off-by: Andrey Grozin <[email protected]>
  • Loading branch information
Andrey Grozin committed Jun 29, 2019
1 parent 0682016 commit b562e48
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/texmacs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST TeXmacs-1.99.10-src.tar.gz 31879944 BLAKE2B 3576d1abff1040d2b0236718a5ef5149bf0e445567408e44b85cae5d43a631acd42fa59f0973e375e347720083ee2368398a1a2cec6aa679c5f47a3952877615 SHA512 5da8e789a5f7b6b9e2846714c751173616e572b5426f2c29d7f979037b1bca1542c9e77048abf9c5b95974e7b198c2a857bfa84eeb428390b2c1088bf87984d8
DIST TeXmacs-1.99.6-src.tar.gz 25081652 BLAKE2B 08d0a141ff1b8ab59def50c636d917f9290488031d6f7f4343be4a04af44d8994dc791eb23a2a2b71b7a853a3a90482313062fbfc045cf585afdf8f1f8d2a5f3 SHA512 2e262037654493075cc4a3d47b93de08c3ad2d6f10ce5fe814a8046b38d327c5dd88c1575dff7e2145f1541f9765dc50ec5abcd63146090eea98ab5db9d103ee
DIST TeXmacs-1.99.9-src.tar.gz 30109108 BLAKE2B 182db26c645e1445780f8e153f7283eb517ec3aa8be6ce137b6c305df33657f15c3efb57198e81f8dd9e1682b3bf1c6c0ff6f3798c54bcb74aedb8b3cef67b40 SHA512 96971060536007e542cd3e1789f07bcc30ceda01cbf32cabf43e3a5e61a2ba15f604e49601d891a956732d90d224353f8dac495be05677758146206b549f9d1f
72 changes: 72 additions & 0 deletions app-office/texmacs/texmacs-1.99.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils xdg-utils gnome2-utils qmake-utils

MY_P=${P/tex/TeX}-src

DESCRIPTION="Wysiwyg text processor with high-quality maths"
HOMEPAGE="http://www.texmacs.org/"
SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/tmftp/source/${MY_P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
IUSE="debug jpeg netpbm sqlite svg spell"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
app-text/ghostscript-gpl
<dev-scheme/guile-1.9[debug?,deprecated]
media-libs/freetype
x11-apps/xmodmap
x11-libs/libXext
virtual/latex-base
>=dev-qt/qtcore-5.9.1:5
>=dev-qt/qtgui-5.9.1:5
>=dev-qt/qtwidgets-5.9.1:5
>=dev-qt/qtprintsupport-5.9.1:5
sqlite? ( dev-db/sqlite )
jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
netpbm? ( media-libs/netpbm )
spell? ( app-text/aspell )
svg? ( || ( media-gfx/inkscape gnome-base/librsvg:2 ) )
"
DEPEND="${RDEPEND}
x11-base/xorg-proto"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}"/${PN}-1.99.2-desktop.patch

# remove new/delete declarations, bug 590002
"${FILESDIR}"/${PN}-1.99-remove-new-declaration.patch

"${FILESDIR}"/${PN}-1.99.6-math_util.patch

# fix build failure on 32-bit systems, bug #652054
# "${FILESDIR}"/${PN}-1.99.6-guile-size_t.patch
#"${FILESDIR}"/${PN}-1.99.9-guile-remove-deprecated.patch
)

src_configure() {
local mycmakeargs=(
-DUSE_SQLITE3=$(usex sqlite 1 0)
-DDEBUG_ASSERT=$(usex debug 1 0)
)
cmake-utils_src_configure
}

pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

0 comments on commit b562e48

Please sign in to comment.