Skip to content

Commit

Permalink
media-gfx/gif2png: version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Aug 27, 2015
1 parent 125fb7a commit b633eb2
Show file tree
Hide file tree
Showing 3 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/gif2png/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gif2png-2.5.10.tar.gz 138944 SHA256 c5a43875b3c616ce102462d8c23cd09c13c9e0c234d9d7df4e4eae7ccee5494d SHA512 3ca1c0d41a38b4b628f929afa231b8f67079f9998210e63b68e4438379a5d70b64d332f7e0786fb199ef866e188f5095c0d0d4570ec9da829aeac63c8918ad3e WHIRLPOOL 668dcc30a9644495f45c3ae93d08a4463290b79b1fd7f5cca6a1813da75e696ecaea1be93fd6278557d8b2760172d44b29f572e492f673bafd2d5a4f9d010a3f
DIST gif2png-2.5.11.tar.gz 31507 SHA256 40483169d2de06f632ada1de780c36f63325844ec62892b1652193f77fc508f7 SHA512 c7e42aca45f941bca970ff14f49881f485c4dee18be448ae71aa7c80dabd9384bcba6d6de05a0a78757150b3e775d99df315231ddae8e32c91c08f1c9cfefb67 WHIRLPOOL 436bed50cff84dde0359d6034cd872b85db60d12908c074b2db19de69747bede8661870887d65b594c500f6495cce50b0d6469d7de1eebdba3eb9ebf891a58cd
DIST gif2png-2.5.8.tar.gz 128373 SHA256 f962c6d1a76d6ec376cd380112235901dc0c130cc134db5e65a3408b4904ff18 SHA512 050c516c125efda315e6bc7e4fadcdd612a9596bd1e6f611865a457efb06153a45516eca343422e15ad75b1219f82ec855f03781285df411590008f5a67e0554 WHIRLPOOL 7e1e69e4f74b12033a30ef9ec86be2d454e9ce2b138af38a5a1e6438f1a264dad5d4ab02e79be089d89b7fa8694c371e6e18e4e81dc84bd0fb4e60f1049f4fc4
DIST gif2png-2.5.9.tar.gz 137750 SHA256 c8406b7c0c08f504952a1719e04f2366ee44c888c0edfac3a63fea2ab05b64c7 SHA512 0632f1b4b96a1e4b5567101fbac36db55e658503977c8c875d75d9c1db5b374deba5afbda5507585b6b79242781fd70afc477e686458cc124adb8e1b29860c1e WHIRLPOOL c4777997a3222ca209dcb10a21503130a2a691f2c5b3deb8e27f800048e502199a2ab66cc417fbec306a7f7f26eb63ac33c2b224e8f3230fd325179e0fc0b901
39 changes: 39 additions & 0 deletions media-gfx/gif2png/files/gif2png-2.5.11-makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
Respect CFLAGS/LDFLAGS/DESTDIR and don't try to run missing tests.

--- gif2png-2.5.11/Makefile
+++ gif2png-2.5.11/Makefile
@@ -2,8 +2,7 @@

VERSION = 2.5.11

-CFLAGS = -DVERSION=\"$(VERSION)\" -O2
-LDFLAGS = -s
+CFLAGS += -DVERSION=\"$(VERSION)\"

SOURCES = 437_l1.c gif2png.c gifread.c memory.c version.c
OBJECTS = $(SOURCES:.c=.o)
@@ -28,19 +27,16 @@
web2png.1: web2png.xml
xmlto man web2png.xml

-check:
- cd test; make --quiet test
-
clean:
rm -f gif2png *.o gif2png.1 web2png.1

-prefix?=/usr
+prefix ?= /usr

install: gif2png gif2png.1 web2png.1
- mkdir -p $(prefix)/bin
- mkdir -p $(prefix)/share/man/man1
- cp gif2png web2png $(prefix)/bin/
- cp gif2png.1 web2png.1 $(prefix)/share/man/man1/
+ mkdir -p $(DESTDIR)$(prefix)/bin
+ mkdir -p $(DESTDIR)$(prefix)/share/man/man1
+ cp gif2png web2png $(DESTDIR)$(prefix)/bin/
+ cp gif2png.1 web2png.1 $(DESTDIR)$(prefix)/share/man/man1/

uninstall:
rm $(prefix)/bin/gif2png $(prefix)/bin/web2png
30 changes: 30 additions & 0 deletions media-gfx/gif2png/gif2png-2.5.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit toolchain-funcs eutils

DESCRIPTION="Converts images from gif format to png format"
HOMEPAGE="http://catb.org/~esr/gif2png/"
SRC_URI="http://catb.org/~esr/${PN}/${P}.tar.gz"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"

RDEPEND=">=media-libs/libpng-1.2:0
sys-libs/zlib"
DEPEND="${RDEPEND}"

DOCS="AUTHORS NEWS README"

src_prepare() {
epatch "${FILESDIR}"/${P}-makefile.patch
tc-export CC
}

src_install() {
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
}

0 comments on commit b633eb2

Please sign in to comment.